New ASUS router still no fix found? Core does not connect to router

Core Machine (Operating system/System info/Roon build number)

NUC Intel i5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Modem in bridge mode, Asus ax11000 in router mode

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
PC as remote, and iphone

Description Of Issue

Hi all, I have installed new router (old was tp link), nuc is plugged directly with ethernet cable. Router does not give ip to Nuc and the core does not show as a connected at all on router, when I turn off and on the NUC (with Rock installed of course) I sometimes get roon to see the core it tries to connect and fails a few times until it stops trying (or so it showes on remotes). I have enabled mutlicast routing and IGMP snooping, Anything I should do? I see that Asus routers tend to be problematic with Roon cores is there a fix coming?

Tried a different LAN cable? tried plugging in a HDMI TV/Monitor to see what the NUC is doing on the boot up screen?

Good point! The static IP might be the problem, any chance I could change that via the nuc itself? Setting it back to DHCP could be a solution.

Thanks for the prompt reply

Had a similar problem with my ASUS GT-11000 router, Got an 8 port Trends network switch from Amazon. Took all router ethernet inputs out except the modem input and hooked them into switch. Problem solved.

Ok, the static IP is not covered by the new router, any way I can change it directly without webdui, a command on the rock directly?

Funny!! I’m having a similar problem tonight! Just purchased an Asus RT-AX58U as I’ve got quite a few Apple bits so wanted to take advantage of the Wifi 6 ax speeds…

Everything wireless connected up fine and working well.

Roon Core (Intel NUC like yours), connected directly to the router via ethernet cable. Can browse the network from my Mac and see the storage folder etc. But when I launch the Roon Remote on my mac, it can’t find the Core!

Saw on some other threads to start by turning off the firewall… made no difference until I restarted the Roon server software - then the remote software opened up fine.

But if I close it and open again, same issue - cannot find the core. So something’s definitely amiss. I don’t want to be restarting the room server software every time I want to use a remote!!??

Did you have your core NUC on a static or reserved IP address on your previous router? I just bought an Asus router and the DHCP IP address range is different to my previous one so I had manually reset a couple of things including the IP address of my NAS where the music folder is.

When I restarted the Roon server, it seems to have picked up the DCHP details correctly. So unsure what I need to change?

But now every time I launch the Roon remote on my Mac, it won’t find the Core until I manually go to the IP in a browser and restart the server software - and that makes it work, regardless of whether the Asus router firewall is on or off! (Firewall is on right now - but it’s the exact same behaviour even if the firewall is off! Go figure!! :man_shrugging:t5:)

Absolutely no idea what’s going on there??

You could try assigning a reserved IP address to the NUC. Do you also have the same issue if you use another device, like a phone or tablet, as the remote?

I hadn’t tried that actually! But interestingly…

iPad and iPhone found the Roon Core no problem - and both devices remembered what was playing on them last! Had a message on both about iOS14 and needing to allow ‘network discovery’… soon as I pressed ok, no issue with connection

It’s only the Mac which comes up with the dreaded…

Good news about the phone.
Is the firewall on your Mac turned off?

No. Firewall on the Mac is on.

But I don’t see how playing with that would make a difference - because when the roon server is restarted, the mac remote connects to the core fine (and stays that way as long as it isn’t closed).

Running out of ideas, and I don’t know anything about the NUC I’m afraid. Is it running Windows or ROCK?

Yeah, it’s running ROCK.

Thanks for all your help and suggestions though @Rockhound :facepunch:t5: :ok_hand:t5: :ok_hand:t5:

It’s probably something really stupid!! But I can’t think either - especially as the Core is found by both iPad and iPhone remotes :man_shrugging:t5: Just not by the Mac software (until a roon server restart!)

Two things:

  1. IGMP snooping causes problems (sometimes) with Roon’s network discovery, so turning it off may help solve the problem.

  2. Setting a fixed IP on a device itself is a source of endless problems because different routers and DHCP servers use different IP ranges. If you do want fixed IPs, use a router with a DHCP server that you can tell to assign that fixed IP to a particular MAC address (that’s what I do with my Ubiquiti EdgeRouter).

Even just tried reinstalling the Roon software on the Mac - just to rule that out… no joy; problem still exists

Can’t you access its web interface to check/modify its network configuration, as described here?

This is the strange thing @Fernando_Pereira… the web interface has the correct details already. (Which makes sense now - because every time I restart the server, the mac remote connects fine).

To see that pic from my last post, I signed out of the Mac remote and noticed that the remote software was pointing to that incorrect ip (ending 138). I can’t see how I can change it directly from the remote settings? It doesn’t need to be changed on the web interface as that’s already correct?

Mad!! I know, right!!??

Can you not see it from within the Asus software, and assign it a reserved IP address?

  1. Yep, web interface is correct!

  2. After restarting the Roon server software - so I can connect with the Mac remote (iPhone and iPad absolutely no issue)… In the Settings - General area of Mac remote, shows me signed in and IP in the ‘Core box’ is also correct!

  3. However, when going to Settings - Setup - Configure Roon OS devices and then clicking on the Configure button… it’s here where the IP address is wrong (underneath Roon Optimized Core Kit).

This is the issue methinks - and the reason why, when the remote is opened and can’t find the core - but the roon server is restarted, it connects!

All was working fine on the old router, without the need to configure a static IP or mess around with firewalls, IGMP etc

And as it’s only the mac software remote with this issue - and my iPhone and iPad connect to the ROCK fine without having to restart it, this is the only little hurdle I need to get over.

I’m wondering what will happen if I choose to select a new core rather than restart the server?