New Issues with Nucleus - Network Error please check your internet connection

I have been using a Roon Nucleus Rev. B. with Roon Remote on my IMac and also on an iPad. For several weeks, Roon has been showing the spinning circle icon which, when clicked, brings up the message, “Metadata Improver: Halted. Roon needs a software update.” I think this issue was first noted a short time after updating the Roon software. Roon Core in the Nucleus is Version 1.7 (build 667), and Roon Remote (in my iMac) is the same version. This issue occurs with both Room Remote in my iMac and the Roon app in my iPad. Roon is connected to a Linksys Velop mesh router. My WiFi download speed is around 100 Mbps, and if I connect my iMac to the router via ethernet, I get a download speed of 178 Mbps. I have subscriptions to both Tidal and Qobuz.

I have tried the various measure suggested for this problem (which, frankly, appear to be shooting blindly), to no avail. I have changed ethernet cables. I have rebooted the Nucleus. I have reinstalled the Roon software. Etc.

The problem has gotten worse. Early on, I noted a problem in adding albums: it took a long time, and often the album graphics did not appear. Roon Search also took a long time. I then noted that Searches seemed to have stopped showing any new results, but were only showing albums previously found.

Yesterday, I went to Settings > Setup >Configure Roon OS devices and successfully reinstalled the Operating System (Version 1.0 (build 227)) and I restarted Room Server Software (Version 1.7 (build 667)). The problems persisted.

I next clicked the Reset button for Roon Database & settings. The initial result was “Error / Settings and databases could not be reset. Please try again, or contact support. (“status”: “Failure”, “exitcode” :2).”

Networking showed Ethernet. I clicked the Rest button and got, “Success / Settings and databases have been reset successfully.”

I then got the message, “Remote Connection / Waiting for Remote Core.” However, I now am unable to log in with Roon Remote, which is needed to access the Core in my Nucleus. I am using the same email address and password that works when I log into my Roon account on the Roon web site, but that log in is not working when I try to re-establish the Nucleus as the location of Roon Core. The login fails, and I get a message, “Network error. Please check your internet connection.”

My internet connection is working. The mesh router used with Nucleus can be connected to my iMac and my iMac then accesses the Internet via this connection.

So, I now have two issues: (1) What do I need to do to get Nucleus recognized by Roon Remote? (2) After getting Nucleus recognized, if the Metadata Improver issue persists, then what?

Thanks in advance.

HI Jeff,

I moved your post to its own thread. Roon support prefer each user issue to be it’s own thread. While you may have the same symptoms as the other thread, the cause and solution, may be different.


Hi @Jeff_Kane,

Can you please share a screenshot of your Nucleus Web UI?
Does the login issue also occur from other remotes or just the iPad?

I apparently solved the firts (internet connection) issue. My Nucleus is connected to one of my Linksys Velop routers, but not to my “primary” router: i.e., not to the router connected to my cable modem. I just restarted (turned off then on) the primary modem. After rebooting, I was able to log into my Nucleus from Roon Remote. Apparently the Nucleus IP address needed to be reset by the primary router, or something like that.

As for the second problem—the Metadata Improver issue—I’ll need to wait and see. I currently have a spinning circle at the top of my Roon screen. When I click on it, I get a message, “Adding music to the library.” It also appears that Qobuz is loading slowly ( but that could be from the Qobuz end?). I’ll let the adding music process continue and see where it ends up, after which I’ll report back.

Hey Jeff, I was readying your original post and thought it all sounded Network related then got distracted. Can you wire the nucleus to your primary router? That is where I would start. Just a suggestion.

Thanks, Mike.
It looks like both issues are resolved: the network issue where I had been unable to log in to my Nucleus, and the spinning ball with the Metadata Improver message. Apparently rebooting the primary router was the key (although I also reinstalled the Roon software). My WiFi system has 5 Linksys Velop (mesh) routers: 1 primary (connected to the cable modem) and 4 satellites (each with several ethernet ports). My Nucleus is connected to one of the satellite routers, which is on a different floor from the primary. Rebooting the satellite Nucleus-connected satellite router had no effect, while rebooting the primary router resolved the issue. In retrospect, a network issue may have been the culprit for the Metadats Improver issue all along; but I was thrown off the track because this issue surfaced shortly after a Roon update, which made me think more along the lines of a software issue.

1 Like

Hi @Jeff_Kane,

Happy to hear that since rebooting the primary router all issues are solved, this is great news!

I will go ahead and mark this one as [solved] but if you encounter any further difficulties with Roon, please just let us know and we can take another look, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.