New Reading In with different dates

After loosing the hd, Roon is Reading in again, but shows different Numbers of Files, What does this mean

Interesting is the difference between read and imported files

I’d guess it has seen/read 1,278,800 files on the disk and has so far properly imported (identified, analyzed) 632,520 of those as titles into the library.

For future reference, here’s a better way of showing screenshots in the forum…

1 Like

I feel the same way. The only strange thing is that roon always showed me 950,000 titles on the user interface?! Also the number of albums is no longer correct, otherwise it was 53,000, now only 37,000. What’s going on?!

Maybe it’s not done yet, is the imported number still changing?

Where? And do you have “show hidden albums” set to on or off? If it’s off (i.e. the album versions are hidden under the Versions tab), then the numbers differ between Home and My Albums. Home gives the overall number including different versions, My Albums gives only the number of visible albums, i.e. excluding different versions

Thanks, I am aware of these settings. Rather, the cause of the problem seems to be the fact that my NUC keeps losing connection to the external hard drive, it is connected via USB3. I’ve had this problem for a long time, but otherwise the PC found the data much faster. So the question is, why does the NUC keep losing connection? I’ve tried different USB3 and USBC ports, same result everywhere.
another question is why roon only imports 630000 titles although roon found 1390068 files, the rest are pictures?!
my dear…

There is another post about a failing USB connection to a backup drive. It is a Seagate drive and the solution was to re-format from NFTS to exFAT. This would appear to be a known roon problem

I also have a Seagate drive formatted exFAT that I use for backup. But I also get these dropped USB connections. I find it is cured by re-booting roon. That’s clearly not a solution and it is not clear to me that NTFS or drive formatting is the problem so before going through the pain of reformatting and restoring your library maybe roon should chip in if there is a more general problem with USB attached drives? Move this to support?

1 Like

it’s progressing slowly, roon is finding more and more albums. Is the reason possibly an update that has to read in the data again?
But it can’t be that I need an hour or two every day after I’ve switched on the computer before I can access my data.
Is the problem with roon or with the nuc?!

But in that case they don’t keep losing connection, it is caused by the NTFS file system having a “dirty” flag and Roon refuses to mount it to avoid corruption. I.e., such a drive does not work at all until a checkdsk is run on Windows to return it to a clean state

That is exactly the symptoms I get but the drive is a Seagate drive already formatted exFAT. The disk is not recognised by roon when attempting a database backup but is recognised by other programs including windows explorer and freefilesync that I use to backup the content. I have tried running chkdsk several times but windows does not find any errors and neither will roon recognise the disk afterwards. What is required is to re-start roon and then the drive is recognised by roon. I do not seem to get the same effects with various Western Digital drives.

It seems to me that Matthias’s problem is that the drive intermittently loses connection. Then it’s not the known NTFS issue with a dirty filesystem. Of course there may be other causes with certain drives that lead to intermittent connection loss

I don’t know if the OP’s issue is a dirty NTFS files system because I don’t know what his file system is. In any case my point was precisely that I doubted this was an NTFS issue or at least restricted to NTFS file systems as I get the same symptoms with an exFAT file system. The common experience seems to be that roon intermittently drops the USB connection whatever the file system. I have even tried reformatting my Seagate drive but roon still intermittently drops USB connection although other windows programs do not. So far I have not experienced the same with various Western Digital drives to which I backup on a regular basis. The main difference is that the Seagate drive is attached by USB directly to a Windows 11 core whereas the WD drives are attached via USB to several TerraMaster NAS.

that’s how it really is, seems as every day roon has to re-read my collection…
ran roon tonight and it’s now up to 44000 albums again…and as I write the number keeps increasing?!

The problem seems to be solved, it would be interesting to know what caused it…
as if roon had to read in everything again?!


19 03h
something is still missing…

I just remembered that a few days ago I gave roon the job to clean up the library, it must be related to that.
Roon is not finished yet, the program is still very slow at the moment…

…and it´s slowly, but workin´
yesterday 18:47h

today 06:19h