New Roon NUC setup frustrations - network shared core data folder issue

First let me say I know just enough about computers to be dangerous. I have a new Bean Canyon i3 with a 128 PCIE m.2 and 8 gigs of ram. Bios was updated to version 86A.074.2019. I struggled getting the bios configured properly (instructions don’t match the newer bios options/layout) but did get ROCK installed. I accessed it’s UI via my browser. All looked good except missing some codecs. So I followed the instructions on that and have the ffmpeg file ready to drop in the ROCK data folder.

But now I cannot locate the shared data folder on my network. I can see the NUC Rock via my Windows laptop explorer but cannot access it due to “unkown path”. I did enable all the SMB features in Windows. After an hour of trying Roon Remote on my phone, it finally initialized and I was able to sign in. However, my NAS could not be seen so the full setup failed. I used Fing app on my Android phone to scan the network. Here is what it showed:

NUC Rock - (to router via Ethernet cable)
Arris TG1682G router/gateway -
Wireless Laptop -
Synology NAS - (to router via Ethernet cable)
LG Thin-Q Android Phone - (via 802.11 wifi)

Apparently it is not a subnet issue. My guess is it may be some sort of security setting in the router. The router is new and was just installed yesterday. I can’t get into it’s settings right now because I don’t have the new login info but I can get that without a problem from my internet provider.

So ROCK is missing codecs and I can’t install them because of network issues. Where do I go from here? I am in my trial phase and need to get this up and running before I pay for a full subscription.

Thanks in advance for any input.


Hi John.

So what is the error message when you enter \\rock\ in file explorer. What if you use the ROCKs IP instead?

I nhad an issue earlier this summer detailed here, not saying it is the same

Yep. In my case I finally got this error:

After Googling the warning I found out it is a Windows default setting in a security group policy that doesn’t allow unauthenticated guest access. I found this info:

I followed the instructions and edited my registry to enable the unauthenticated guest access and was successful getting to the data/codec folder. But transferring the file over kept getting interrupted. Turned out the file size was too large but temporarily turning off network firewalls and virus protection solved the problem. So now my ROCK core software is all up to date.

In Windows 10 Pro:
Within the run box, type “gpedit.msc”

Within the local Group Policy Editor, select “Administrative Templates”

Select “Network”

Select ”Lanman Workstation”

Double click “Enable Insecure guest logons” option

Tick the “Enable” option

Select OK

Now I need to enable all my virus protection and network firewalls. I will leave the security policy as edited as it is my network and I don’t need to worry about some disgruntled employee trying to sabotage anything. But this issue may be a huge problem for anyone using Windows Home edition as I thought I read that only the Pro version could edit security group polices.

It’s late now and I am tired so I will try to configure the music library locations tomorrow. Hopefully I won’t have to deal with yet another curve ball.

But seriously, why isn’t that codec file already in the data folder when installing the core??

Licensing issues, I believe. The KB article on missing codecs states:

Roon does not ship with patented codecs such as MP3 and AAC on any platform.

1 Like

There is a windows client only.

You are SO close to having this up and running! But I do understand the frustration. From what I can tell you don’t give yourself enough credit for computer savvy considering what you’ve gotten done so far.

This is a bit odd, since the ffmpeg codec file is only 69 Kb. It is a very small file, although it is zipped up in a much bigger file.

Also, as @ged_hickman1 said, the Windows applications come both as a server only version (Roon Server,what you’d run in the NUC) and Roon, which is a version that can run as either the server and Roon GUI, or as a Roon GUI only (what is essentially a remote), depending on how you set it up.
Although ROCK is a little bit of work to set up, it is about as much work as a microwave once it is running. A lot of people just above never need to touch it.

If you don’t mind, I’m going to move your post over to Support, where the Roon Technical folks can help you get this running (presuming you want to give it another chance).

1 Like

That’s why I plan to purchase a Nucleus or Nucleus+

That restriction is not enabled on Home edition or Win 10 pro editions or at least was not enabled last time I checked when I had the issue in August. Are you sure you are not running one of the Win OS versions on the list in the link I posted earlier that described the issue and the resolution. I ran into the issue because I use Enterprise. If MS is enabling it across all versions then yes it will become more of an issue.

That being said, RoonServer works fantastically well on Windows. Personally, I always suggest that someone use the OS with which they are most comfortable. There are certainly benefits to running Win OS, just as there are different benefits in using ROCK.

It was not configured on my new Dell Precision 7530 with Windows Pro. I couldn’t access the ROCK data folder until I did the enable in the registry. My other computer with Windows Home will not access the folder and does not have the option of enabling in the registry.

Yeah, maybe I am jumping the gun. But man I am exhausted and needed a break. Now I get to learn about my Synology NAS and all the possible settings for mounting a shared folder so Roon will see it.

Then there is the issue that ROCK does not enable wifi ! It appears to only enable Ethernet. If I cannot enable wifi on the NUC then this is absolutely a deal breaker.

What will you be doing for D>A conversion. What sort of DAC are you using?

One thing to know about Roon is that it is a data intensive beast. The rich user experience one gets comes from Roon pulling a ton of information from the network. The core really needs to be connected to a router to make everything run smoothly (especially when you are first setting things up).
There are a lot of ways to get data from the Nuc to your DAC, but how that is done depends on the DAC.

Update: Loaded Windows and appropriate Roon software and all went smooth. With windows, network ethernet and wifi is automatically configured. No codecs to load. Except for needing to configure my NAS all is working smooth. And a shout out to Rugby for his help.


Hi @John_Berard,

I’m glad to hear that you were able to get things up and running on Windows. If you have any questions about this setup please let us know!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.