New Tidal albums not showing up in Roon

@kevin, After I removed them on the TIDAL app I was able to add except for the Motorhead. I still can’t seem to add that album to my collection.

Hi @Mystic, try going into Settings > Services > Edit > Sync library now, and let me know if you can add them then. If not, let’s get those logs submitted and we’ll look at this further.

still no luck with Motorhead. It’s in My Music in TIDAL on my phone but no luck after sync library.

OK, submit your logs and we’ll take a look.

sending data seems to be taking forever?

EDIT: just finished… logs sent.

Hi @Mystic, everything in your logs points to this album being added to your collection already, and I also emulated your collection on my machine and saw it there. You can confirm that it’s not showing in the album browser?

Weird… Here are a couple screen captures to show it is not showing up.

Did this fix also fix the allmusic data issue? Not at home to confirm. Would really like to have that data right away to make better use of new releases.

Ok @Mystic, thanks for the screenshots, we’ll take a look at this one further.

I’ll have to do some digging but so far it looks good. The allmusic data is there too.

Thanks so much. Now let’s hope Tidal stays afloat for a good while longer. Maybe work a deal with Deezer or something.

So I’m having similar problem as Mystic. The Panda Bear EP is showing up in New Music section but it’s not adding to My Library. I unfavorited in Tidal web browser and then tried to add again in Roon but didn’t work. It did however add back to my favorites in Tidal browser. Kind of strange.

Same issue here with " The Club Album" by Anne-Sophie Mutter.

I can search for it and play it - but can’t add it. Clicking on “Add to my Library” does nothing.

Until yesterday, this album would not show up in a search.

Just reporting: I was able to add The Club Album to my library just fine.

Just tried The Club Album again after seeing your post - no go.

Click on the add to library button, nothing happens, and the album is not in the library. Tried a few other albums and it works fine.

@mvrlogins @anon94274355

Can you guys try this:

  1. Close Roon
  2. Find and open your Roon folder
  3. Navigate to /Library/Roon/Cache
  4. Move all the contents of that folder elsewhere, like a RoonCache folder on the desktop
  5. Try restarting Roon and syncing Tidal

Let me know if this works – it might be helpful us to have a look at the RoonCache folder if this fixes the issue for you.

If this doesn’t fix it, we’ll keep looking at the issue, but you can toss the RoonCache folder in that case :smile:

@mike, Thanks, that did it… I didn’t even need to do a new sync with Tidal just restart Roon. The Motorhead album is the latest added on my overview page.

Great! Any chance you saved the contents of your cache?

This issue has come up a handful of times, but we haven’t figured out how to reproduce – maybe your cache has a clue! :smile:

I feel like I sent you instructions for using our file uploader in the past – if I’m remembering correctly and you have the cache, feel free to zip it up and upload. If you need instructions, let me know.

Thanks for reporting back @Mystic!

Yeah it’s still on my desktop. No, I haven’t sent you files before. PM me the instructions and I’ll send you a zip file of it.

1 Like

Worked for me too.

1 Like

Thanks for letting us know guys – @anon94274355 I’ve got your cache folder now. Appreciate your help!