New user unable to get started with additional music on a another Mac [Resolved]

Trying to set up Room on 2 MacMinis on ethernet LAN. Have exported native files from SooLoos to office Mac mini (upstairs) and downloaded the all in one Room package to the lounge Macmini which feeds into a Meridian audio system. Appeared to work initially but realised only reading music files on the lounge Mac mini. Unable to get it to read the ex sooloos files on the office machine after much trial and error and reading of help pages. Then read that on a 2 machine set up core and control should be on separate computers so deleted the Roon installation (moved to trash…is that sufficient??) and downloaded RoonServer to office Mac. Nothing happens when I double click the icon in the dock or the Roon file in Applications…should it? Then downloaded the full Roon package to the lounge Mac…again (does not seem to be a control only download for OSX) now if I double click on the Roon icon it appears to start loading but never finishes. Have rather lost track of all I have tried but have probably messed up somewhere so not sure what to try next. Do I delete everything and start again or what?? Any help appreciated.

That is just not true. Best you uninstall everywhere and start again only installing Roon core on the lounge system. I am not a mac person but you should be able to “mount” the disk containing the Sooloos files on the lounge mac. Then on the lounge mac in roon settings storage add the mount for the office mac that you created.

If you want to control the lounge system from the office mac just load control on uit, else you can control from the lounge mac or from and android phone or tablet with the app from the play store or an apple iphone or ipad (of an appropriate model) using the app from the app store.

Thanks Tony,
Have now the full install on both Macs, core and control in lounge, control and storage in office. All working except that I still cannot access storage on office Mac, get “unauthorised” every time I try to add network connection as on screen shot. Sadly both iPhone and iPad are too old to support the control app.

Can’t see your screen shot, but it sounds like the Mini’s OS is complaining about userid/pw for the other machine (?). BTW - you don’t need to mount the disk you have your music on, just specify the network address to Roon. I have a Mini, that’s all I do.

on a mac smb server, I think you enter your mac username there, not your full name

Thanks for the suggestion. My Mac username is my full name…on both computers. Have tried it with and without username/password, have checked all the “share” parameters with Apple support. I feel I am missing something pretty basic…a box unchecked somewhere.

Your username has spaces? That seems really unlikely. Not saying you are wrong, just that you might be :slight_smile:

Show us your finder window? it generally has your username on the left side… like this:

I struggle with the inner workings of computers but I assume the network address is the number found in System Preferences/Share which I have tried in the following format smb://, and with .local after the number, in the “add network” box. I am assuming one can have the storage on a second computer.

Usually, if the storage is on your local network, which it sounds like it is, the address starts out with 192.168.x.yyy. Where x is usually either 0 or 1 and yyy is your device address. For example, my storage address is \\\directory, where directory is whatever you named it. In my case its music, i.e. \\\Music. I’ve never used smb:\
\etc… Isn’t that for Windows shares. Can you see your Music files in Finder? if you can, that’s the address you tell Roon in the storage dialog. I think you are not specifying the correct userid/password when you are connecting to server in the Roon dialog. Of course, data on the other computer must be shared and the userid/password on the other computer is the one you want to use.

That’s definitely common. But Comcast routers use the format. At least mine does.

Comcast, those devils.

Come to think of it, I’ve seem to remember having connection problems with a userid that had spaces in it. Have you ever successfully connnected over network to either computer. Apple is funny that way, Windows doesn’t care, as I recall. It may be that somewhere, deep in the bowels of the connection code, there is logic that stops interpreting userid when it finds a space. Wouldn’t be the first time for something like that. Try putting quotes around your userid. Or, as an experiment, try setting up a userid without spaces and see if that works. Just saying …

@Andrew_McMurdo In Finder if you Command K to add a server connection you should put in something like smb:// where xxx.yyy is the remains of the address of your Mac you are trying to access. if there is a password needed it will prompt you…then you should be able to determine the correct one that Roon needs to use. you need to pick the folder name too where your music is…see below

Once you have that and can connect if you do a Get Info on the folder where your music is you should see something like this in the path and this is what you need to put in the Roon Network connection details - this is on one of my macs as an example only…your IP and username/folder etc will be obviously based on your setup


You may or mayn’t need a username and password depending on if its using the same details as the mac your remote is using…I fine most people use the same username on multiple macs if they have them

Thanks for your suggestions, my user name is my log-in name, home folder name is andrewsmacmini2. as on screen shot.

Thanks to all for their suggestions, have worked through them all with no success and had a screen sharing session with Apple support who confirm all sharing permissions are all OK. So I give up!

I am now wondering if storage on a second computer is supported , noticeably not mentioned as an option in the user guide. May keep storage on the core computer and add a USB drive if disc space becomes a problem.

One last thought. Maybe it’s Roon that is not processing a userid, with spaces, correctly.

Have tried all variations, username, home folder name, computer name, with and without spaces. If it is a Roon problem I will hope a future update will solve it.

Maybe the developers can give a quick answer on that. Your problem, since no one else has it, must be something incredibly and stupidly obvious, that we are all overlooking.:sob:


@support just to highlight it to them and moving to support threads

Hi @Andrew_McMurdo — Thank you for the report and sharing the results of the testing you have done this far, the feedback is appreciated!

I want to momentarily take a step back to make sure I am conceptualizing everything correctly that has been tried up to this point.

The Goal:
MAC in the lounge hosts your core (+ control) and in the office you want to control Roon and access your storage from this room as well.

The issue:
You are unable to access the NAS on the office Mac, thus you are unable see it from the lounge either.

So far you’ve tried:
smb://AMAcmini.local/share (Username + Password)
smb:// (w/ .local after the number)

Moving forward, can you verify a few things for me:

  1. You can definitely access the NAS from both stations via finder without issue, correct?

  2. Can you provide me some details about your network configuration/topology? I want to understand what the chain of communication looks like and what “links” make up the chain. For example, any switches, repeaters, extenders, power line adaptors etc. Having a complete picture about how information is going from point A to point B would be useful.

This configuration you’re trying should work as I have a very simple version of this that I use for testing myself. With my MacBook Pro acting as my core machine, I am able to mount a network share folder from my MacBook Air acting as a Roon remote.


Hi Eric,
I don’t have a NAS, I was hoping to use the office Mac for storage but as that is not listed as an option in the user guide I am now wondering if that is not possible …I am not experienced with networks! but you say you are doing it with 2 Macbooks.
I have now deleted Roon from the office computer but can still access the core, and music files stored on. the lounge/core computer, using screen share.

I have tried several network paths including those you list, I am assuming userid is my log-in name and password but I have tried home folder name “andrewsmacmini2” as well. The System Preferences/share menus show "other uses can reach this Mac a “|AMacmini.local”

Network is satellite dish feeding modem
cable to
Apple extreme wi fi router
cable to
8way ethernet switch feeding various AV devices (sky/TV/BDplayer/Meridian wi fi remote thing/MacMini)This Macmini feeds into a Meridian H621 with an HDMI cable.
Cat5e cable to office
8way ethernet switch (Netgear)
feeding second Macmini, second Apple wi fi router

No repeaters, extenders or power adaptors

Hope that makes sense but ask if you need more detail.