No Audio although "Roon Ready"

In Settings under Audio, Roon recognized my NAD M50.2 which has been designated “Roon Ready” and is where my music files reside. The Core is on my MacBook Pro. When I select something to play, however, there is no audio, despite the fact that the timer indicates visually that a file is playing.

Hello @David_Waring — Thank you for the report!

To start, may I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

  • Have you tried power cycling your Core machine, the NAD, and and networking hardware?
  • Can you share a screenshot of your settings for this audio zone in Settings > Audio > Device Setup for that device.
  • Have you tried playing to this device outside of Roon?


Hi Dylan. Here are a couple of screen shots:

                **David Waring’s Wifi**

I’m using an Airport Extreme as a router connected to a cable modem. My MacBook Pro (2012 vintage) named “Murray” is where Roon Core resides. My NAD M50.2, named “Marcel” is where my music files reside. I have a Sonos Connect and Zone Player 90 with the Connect attached via Ethernet to the router. An Airport Express is connected via Wifi. At present, I have disconnected a Lacie hard drive with another copy of my music library from the Connect while I try to get Roon operational before my trial period expires.
BluOS controllers currently play the music files on the NAD M50.2 without any issues, other than a UI I’m not crazy about. The NAD M50.2 also plays CDs without problems.
I have tried power cycling both the MacBook Pro with Roon Core and the NAD M50.2 and the router. The problem still persists. The MacBook Pro plays the music files audibly from my Library on the NAD M50.2.
I hope this helps with the diagnosis. -David

Thanks for the information, @David_Waring!

Just to confirm, is your MacBook Pro and NAD connected via Ethernet?

Is this behavior happening for all audio zones you play to? In the Zone Picker on the bottom right, do you see all of your audio zones there too? If you play to System Output (default output for your MacBook), can you hear audio then? What about if you change to your Sonos zone?.

despite the fact that the timer indicates visually that a file is playing.

Just to be clear, the timer never stops after a certain amount of time? It continues playing as you would expect, you just can’t hear audio?


Hi Dylan,
Both MacBook Pro and NAD are connected via WiFi
I am only interested in having one zone and that would be the NAD, aka “Marcel”. Marcel is located on another floor from the router. However, I will try the other zones, at least the ones with associated speakers.
I’m not sure about the timer question. I’ll check tonight. --David

Hi Dylan I’m following up on my last post.
The timer is visible and counting while a song plays and stops when it ends or restarts if a subsequent song starts to play.
However, now my NAD has disappeared as a share. I’ve tried adding it again using its IP address, but I just receive the message “Adding . . .”, until the message “an unexpected error occurred” appears. Also, copies of songs appear to be proliferating in my music folder. I seem to be going backward. -David

Hey @David_Waring ---- Thank you for the update!

If at all possible, a great test would be to connect both the NAD and the MacBook Pro via Ethernet and seeing if the experience improves. We recommend in all cases that the Core machine and wherever the media is stored are using a wired connection.

Additionally, were you able to confirm if you were able to get other audio zones working? I know that you want to use the NAD, but knowing if the behavior is limited to one device or all of them will definitely help us narrow down the possible root cause here.


Hi Dylan,
Unfortunately my MacBook Pro doesn’t have an Ethernet port. The NAD M50.2 has only USB ports. Can you think of a workaround to establish wired connection between the MacBook and the NAD?
I will try the SONOS zone over the weekend and report the results to you.
A wired run isn’t feasible to connect the Mac and the NAD in the long term as they are on different floors, which suggests I invest in another relatively inexpensive computer for a permanent connection. Any suggestions for a computer to consider? -David

This just in: I apologize, the NAD M50.2 does have an ethernet port.

Just tried to play tracks from Roon through my Sonos zone. However, I found I was not able to designate any zone whatsoever in Settings/Audio. As before, the MacBook Pro is the only device that will play files from Roon. However, my NAD M50.2 has reappeared as a connected device. Also, it is the only device with the ilittle " i " icon providing info about RAAR version, etc.

Hey @David_Waring — Thank you for the update!

Yes, I believe for the MacBook the only way to use a wired connection is by using a thunderbolt Ethernet adapter. We always advise that you use a wired connection for both the Core and library storage location. If you’re looking to find a new device for your Core, there are many options available to you. I’d suggest making sure that you follow the specs in this article for optimal performance.

In your previous screenshot of Settings > Audio it appeared that Sonos was showing up as a networked device. Is it no longer displaying there? Are you able to select it from the zone picker (the circled section in the screenshot below)?


Hi Dylan,
I’m embarrassed to say, the zone picker did the trick; kind of a basic oversight on my part. I was able to select the NAD M50.2 and play music through my main system, which is what I had in mind all along. I could not play music through the Sonos zone, but that is the result of an unrelated issue. Sonos still shows up as it did in the screen shot I sent. In any case, I envisioned Roon as a replacement for the Sonos rig due to Roon’s metadata and hi-res capabilities.
Thanks for your patience and help! -David

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.