No Audio Device Found

After months of glorious Roon performance I came home and turned on my mid 2011 MacMini running 10.12.6 and opened Roon Version 1.3 (build 269) stable (64 bit) to find the “No Audio Devices Found” message. Below that message is an option to Manage Audio Devices. I select that option and what I see is “Networked” and an option to add HQ Player. No options for my NAD D1050 headphone DAC as when I originally setup Roon. I am not running any third party anti-virus, etc. I can’t find my NAD DAC anywhere in settings. When I open Roon I can still see all the Playlists I’ve created, the queue is still there etc, nothing will play. I am playing the Tidal desktop software through the NAD headphone DAC so I know that works. I normally play music through Roon from my QNAP TS251 NAS and Tidal.

Please help, I need my Roon back!

Moving to support thread and adding @support

Where is your Core? On the mini or the NAS? Have you tried rebooting the core?

The core is on the Mac Mini,

Thank you, did I post in the wrong area?

By rebooting the core do you mean just restarting the MacMini? If so then yes I’ve done that several times. Also checked to make sure Roon was still monitoring the shared folder on my QNAP NAS where the music is stored.

Have you powered off the DAC and on again? Likewise maybe its worth rebooting everything (network switches and router too) if you haven’t done that. Replug all your cables too - ethernet especially and USB to the DAC incase something might have oxidised over time.

It showed as “uncategorized”, so I just categorized it in the Support thread. What thread did you try to post it to?

Does music play with any other player on the Mac mini? Did something happen to the audio devices to disable them? I am not a Mac dude so…not sure if this helps…

I unplugged the USB cable from MacMini to NAD DAC and plugged in an AudioQuest Dragonfly into the same USB port on the Mac and I unplugged and plugged back in the network cable to the Mac (did not power cycle the Luxul switch or router). After that the Select A Zone option returned, went into Device Setup and was able to see the Dragonfly. Reconnected the NAD DAC USB cable in place of the Dragonfly and the NAD DAC also showed up and playback is back to normal. I appreciate your help and will report back if the issue persists.

Hello everyone, I just renewed my Roon subscription but I’m still having the same issue that when I open Roon it does not see my NAD D1050 headphone DAC, the core is my MacMini. I have the MacMini’s ethernet port plugged into a Luxul XGS-1005 5 port switch which is connected to my Luxul XWR-1750 router.

If I power cycle the switch Roon then see’s my audio device. This switch power cycle seems to solve the problem more consistently than unplugged the USB cable between the MacMini and the NAD DAC. In device settings > Playback tab I have “Use Exclusive Mode” and “Use Integer Mode If Support” turned ON.

Any thoughts on what is happening and how to remedy this would be appreciated. Thank you.

Hey @SJC,

Have you tried to bypass the switch ? If not, can you try to remove it from the chain for a couple of days and see if issue appears again ?


Hi Vova, yes I bypassed the switch but with the same issue persisting. As soon as I unplug the ethernet cable going into the MacMini and plug it back in the audio settings pop up and show my NAD DAC. I also tried using an AudioQuest DragonFly DAC with the same issue. I have a feeling it is something with my MacMini hardware or possibly the NAD DAC itself. Refreshing the network connection solves the issue every time but it is annoying.

Any other suggestions are welcome and appreciated, thanks again.

Hello @SJC,

Apologies for a slow response here. Do you have any other machine you can temporary use as a host for a Roon Core ? If so, would you mind trying install Roon there, connect the DAC over USB and see if the same issue occurs ?


I have a PC running Windows 7 PRO, with Roon running as a remote. How would I go about making that machine the core? I also have a MacBookPro with no Roon installed. I should mention that this problem just came up a couple of months ago. Do you think it is network related or something to do with the specific computer that is running the Roon core?

I think that this is the problem with MacMini, switching to another machine should confirm or deny this theory.

For Win7 machine:

  1. Launch Roon
  2. Open General tab in Settings
  3. Press Disconnect button
  4. Login your Roon account
  5. Roon will prompt you to deauthorize the previously active installation.
  6. Press Unauthorized button

For MBP:
Just install the app and deauthorize the previously active installation.

By de-authorizing the previous active installation does that mean that the core is switching from the MacMini to the Win7 machine (through the process of disconnecting and logging back in again). Currently the Roon on the Win7 machine is installed as a remote. I think using the Win7 machine is a good test as it is plugged into the same switch as the MacMini.


Ok, so I deauthorized the MacMini as the Core and have the Core now on my Windows 7 Pro machine. I have my NAD DAC connected via USB to the PC. When I go into Audio settings in Roon I see an option for NAD USB Audio ASIO Driver with an Enable button, pressing Enable generates an Error: “Error Loading Device Info: DeviceInitFailed”.

I’m starting to think it may be the NAD DAC but that wouldn’t necessarily explain why unplugging/plugging back the network cable from the MacMini allows the NAD DAC to be recognized?

Did you install driver for the DAC on your windows 7 machine ? I’m not seeing a WASAPI driver for current DAC on the screenshot ( unless it is WsAudio_Device).
It looks like you can fins driver for this DAC on the manufacturer website.

It’s been a while and honestly I don’t remember installing Windows drivers for the NAD. I currently have the NAD DAC connected to the Windows machine via the optical digital output and before Roon running as a remote I was, and still do, use Foobar and it plays just fine via optical. When I made the Windows machine the core I tried connecting via USB and the screenshot of options is what I was presented with. I’ll look into the driver for the NAD and post the results. Thanks for your continued assistance.

More to the point of the problem, the list I posted is what showed up after making the Windows machine the core and restarting the computer, the Mac as the core was giving me the “manage audio devices” option at startup and nothing would show up in the list except sometimes that HQ Player option. And the key point is that unplugging the network cable to the Mac and plugging back in allows the NAD to show up, regardless of if the Mac is running through a gigabit network switch or directly connected to the router, I tried different CAT6 cables, etc. So you are probably right that the MacMini is not recognizing the NAD anymore but the question is why? It all worked perfectly a few months ago. Everything else connected to the Mac through the switch communicates just fine with the Mac. I’ll keep digging.


I finally got my Win7 PC setup as the Core, with my MacMini running as a remote. I did download and install the Windows driver for the NAD D1050. After that I restarted the computer and opened Roon and there was the NAD USB Audio option in Audio settings. After device setup I loaded a few tracks into the queue, they played fine, then quit Roon, restarted the computer and opened Roon again, Roon displayed the “Manage Audio Devices” for a split second then displayed my NAD D1050 audio zone, the NAD consistently showed up as the audio device after several restarts, etc. The MacMini as remote seems to be tracking the PC Core without having to unplug the network cable, this seems to be the case after several restarts, etc.

So something happened with the Mac being the Core, and it seems to be related to the network connection, having to unplug/plug the network cable on the MacMini to make it work. Having the PC as the Core is not the ideal situation for me because I use the Mac on a daily basis and the PC is my CD ripping/editing machine that I typically only use occasionally or to maintain the music library data, etc. Any recommendations about what to do with the Mac issue?