No Audio Devices - Devices get lost over Night

Dear Roon-Team,

I am running roon core on a Windows 10 Pro Intel NUC8 i7-8559U, which also serves as Desktop-PC. The machine is running 24x7 and does have Energy saving Sleep modes deactivated. After some time the Server looses all Audio devices, so the roon applications can not Play Music any more. A reboot fixes the issue for some time before it reappears. This happens mostly over night, when we are not listening to Music.

This is what can be seen when the Server has lost the devices.
RonnError1

After the reboot, the devices are present again:

All device drivers are updated.

Any suggestions or ideas?

Thanks in advance!

Best regards,
Thomas

Hi @Thomas_Stowasser,

Do you have any active firewall on the Core machine? Do you have exceptions placed for Roon?

Does this occur every night?

Hi Dylan,

thanks für the quick Reply. It seems to happen every night. Prior the last update (also some Intel Drivers) it worked for one or two weeks or so.

I checked the Firewall and see these Settings. I added public now, but don’t think it makes much sense, since I am connected on a private Network via Lan-cable.

RonnError4

RonnError5

I was a bit puzzled About the number of entries. The filepaths for these entries are teh following:
RAATServer
Private Network
C:\users\nina\appdata\local\roonserver\application\raatserver.exe
C:\users\nina\appdata\local\roon\application\raatserver.exe

Public Network
C:\users\nina\appdata\local\roon\application\raatserver.exe
C:\users\nina\appdata\local\roonserver\application\raatserver.exe

Roonappliance
Private
C:\users\nina\appdata\local\roonserver\application\roonappliance.exe
Public
C:\users\nina\appdata\local\roonserver\application\roonappliance.exe

The RAATServer running (as confirmed via Task Manager) now, when the System has no Audiodevices is in the Folder:
C:\Users\Nina\AppData\Local\RoonServer\Application

After the restart yesterday afternoon, I was listening to music til 23:14:43.

Strange stuff seems to happen here:
03/17 01:12:55 Info: [transport] about to sleep; disabling transport if needed
03/17 01:12:55 Trace: [transport] disabling transport

I can confirm, that around 02:55 a.m. the error “No Audio Devices” was back again.

I unfortunately can not attach my logfile as a ZIP here.

Checking tonight, I will keep you posted it the Firewall-Changes had any effect.

Cheers,
Thomas

Hi Thomas,

Maybe you should check the settings of your network adapter to see if there are any suspicious power save options active.

Regards,
Daniel

check your Bios settings for power saving too maybe.

Your active power plan might bear some network related options also.
grafik

Hi everybody,

thanks for the tips, but it did not solve the Problem so far.

I Have checked for the Network as well as the Windows Powersettings and changed two Settings to Never. Then rebooted. Also checked BIOS, but Nothing to set there, since BIOS was set to Maximum Performance.

RonnError6_Change

Same error. What I find strange is that Roon does not recognise the internal Audio-Devices “connected to the PC” either. Networking devices gone is one thing. But System Output and the internal Intel Display Audio devices are also gone.

I am Setting the Engery Plan of Windows now to Maximum Performance. I’ll Keep you posted if that helps tomorrow. :slight_smile:

Cheers,
Thomas

Hi @Thomas_Stowasser,

Let us know if this yields any change for you. If not, make a note of the time that you open up Settings > Audio and see no devices. Respond here with that timestamp (and your timezone) and we can enable diagnostics on your account to take a closer look.

Thanks!

Its the Elves, they can be quite mischievous…

No Elves. Only Dwarfes here, where I live. But they are not into IT. :wink:
It may rather be the Devil in the details.

Hi all,

the last two nights, the Audio devices did not disappear after setting the Windows Power Settings to Maximum Performance.

So far it looks like it solved the issue, but I keep watching it and will reply back if this changes.

Thanks all for the hints so far.

Cheers,
Thomas

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.