No audio devices found on Windows 10 PC's [Solved]

Since I upgraded to Roon 1.8 on Windows, no local audio devices are found on my PC (/laptop). Before the upgrade everything was OK and I could play Roon music on my PC.

What causes Roon 1.8 to not find my local PC audio?

If your laptop is on different subnet. Windows firewall could be blocking RAAT server. It often blocks it after updates so ensure its allowed through along with Roon.exe

Thanks for your reply Simon! Even when I disable the firewall (for a short period) I don’t see my local audio.
Although I do think that seeing your local audio in de Settings - Audio form is not dependent of a firewall.

Are you on the latest build. As there was a bug in earlier 1.8 version that stopped them showing for some people. Should be build 764.

I do have the latest build (764) so that’s OK.

Oh well must still have a bug then. I take it they are still enabled in settings but don’t show in the zone picker?

No, They are not visible in my Settings - Audio form so I’m not able to enable them. So something has changed in the way the Roon client is looking for local audio devices…

Or somethings blocking them. Odd.

Yep, on my tablet I see the local audio in my settings, but on both windows 10 PC and Windows 10 laptop, I don’t see the local audio. Even when I start Roon as administrator… Strange (and annoying)

Check this post, maybe it will help, works for me:

1 Like

Some things to try.

  1. Firewall/Antivirus settings on both the Laptop and Core.
  2. VPN software running on the laptop
  3. Other audio software running on the laptop, especially if it relates to game overlays, or audio editing.
  4. Follow the advice in this post by Dylan:

Thank you David! This is the trick I needed. I closed Roon, opened Taskmanager and killed the RAAT server process. After restarting Roon I have got my local audio back!

I hope Roon will fix this behavior in the next release, but this is a well working work-around. Again, thanks a lot!!

I have done this also. I could not see any difference on my Windows 10 PC. When I did what David suggested (kill RAAT server process) my local audio was back.

Just to clarify, is this a server issue or a remote one? Because I have 3 Windows machines with the Roon Remote installed and none show up as an audio endpoint (at any stage over 6 months of updates). I’d assumed this was intended behaviour, until I installed on a linux machine (using Wine) and that machine shows up as an endpoint. It would seem unlikely that the issue is client side when not a single windows machine works in my environment.

They would only show up as an Endpoint if Roon is running on them at the time. Unless, you’ve loaded Roonbridge.

If Roon is running and they don’t show up, then try turning off the firewall and av as a test. If they appear then you know that the firewall settings need to change to allow it.

Yes, I’m using the Roon app on the relevant PC at the time that I want to send audio to that PC.

I’ve tried turning off the firewall and AV before launching Roon and it makes no difference. I’m using the default/builtin Windows Defender and Firewall so I’m not doing anything fancy. As far as I can tell this function simply doesn’t work on Windows 10 or 11 (across both work and home PCs with quite different configurations).

No solution, but maybe an info brick there:

I have the observation since release 1.7 - 610 that audio devices are occasionally swapped or not displayed at all. It’s not that bad because it only happens to me on 2 out of 5 devices. Only those two have NVIDIA graphics cards!

Devices:

My zones are all on Windows/Linux computers. I can add an old MacBook Pro 2009 if needed.

A total of 6 notebooks and 2 Sharkoon USB DACs.

I never use more than two zones at a time, so I can plug the second DAC into the active remote.

So on each remote hangs a multiple and easily recognized Sharkoon DAC and my Sennheiser DT 770 Pro. The DAC needs no manual driver installation and is immediately recognized as an external sound card everywhere (Windows 10/11, Linux, MaxOS, Android). These 15 or 30 € solution deliver up to 96kHz 24bit 2ch.

Observation:

With Linux, instead of ALSA (Linux) devices from the Windows GUI (64bit Roon.exe) unusable WASAPI (Windows) devices were displayed.

On two Windows 10 devices, audio devices from the cores were incorrectly displayed as remote control devices. Which then of course do not work.

In Windows, instead of the devices of the switched on PC, those of another Windows device were displayed. This one was not switched on and connected to the network at that time, but similarly configured. I have two Acer V5 and only the one with NVIDIA - graphics card failed.

Conclusion:

One commonality I recognized was that both the Core and the affected remote have NVIDIA graphics cards that appear on Linux, but have no or a less than reliable device display on Windows.

There are several HDMI NVIDIA audio devices on Linux respectively, but I haven’t tried or need them.

If you have a Core on a one machine, and then run Roon on a different PC, that PC’s audio devices should show up while Roon is running on that PC. If not, then something is interfering with the Core’s discovery of audio devices on that PC.

There are any number of potential causes. Firewalls/AV was just the first and quickest to test. Go up thread to my March 2021 post and look at some other potential causes. Another not listed, is old and out of date Realtek drivers.

I had the same problem, turned out to be RAAT in the firewall excluions . NB there are 2 RAAT entries