"No audio devices found" [Resolved - Reboot]

Roon Core Machine

NUC10i3FNH with 4GB RAM and 64GB M.2 SSD Everything is completely vanilla as specified by Roon here: https://help.roonlabs.com/portal/en/kb/articles/roon-optimized-core-kit

Networking Gear & Setup Details

Using latest Eero Wi-Fi 6 meshed router. The primary access point is both a router and a Wi-Fi access point. Some of my audio devices are connected via wired Ethernet, some via Wi-Fi. I’m using a variety of consumer grade switches in my home network. If it’s important, I’ll find the model names but I suspect that the model per se is not the issue.

I pinged all of the audio devices and all show as connected to the network via the Eero UI and each device answers the ping. My conclusion: My network is working just fine. My laptop, my desktop, my wife’s laptop, my wife’s desktop, and the family printer are all working normally.

I am able to access the Rock server via its UI and I can ping it and get a reply. So I have no doubts about the data path between my laptop and the server.

Connected Audio Devices

Bluesound Node 2i – Wired
Bluesound Powernode 2i – Wifi
Pair of Sonos One speakers – Wired
Pair of Sonos One speakers – Wi-Fi
Denon AVR-4700H – Wired

Number of Tracks in Library

247 albums, 3208 tracks. Vast majority are Tidal, about 25 albums on my NAS

Description of Issue

My Roon Rock and its devices were working perfectly until I had a power outage in my house. After restarting the Rock server, I started getting “No audio devices found”.

FWIW, I set up the server when I was using another Wi-Fi router and it originally had a different IP address (192.168.86.x) than after I installed the Eero (192.168.4.x). I never changed the backup address so I haven’t had backups in a long time.

I searched for how others solved this problem and all are very old and/or very situationally specific. So that’s why I’m starting from scratch with this question.

It sounds like you will need to go to the devices and make sure they are on the proper network segment. I’d guess DHCP is being used at your home and leases aren’t being updated correctly. It is going to take a while, but your network/music stream, will be far better for the stability.
Good luck.

It could be many things causing the issues but i would, as suggested check ip addresses on all devices are in the correct range for your current router, look specifically for any fixed (static) ip addresses on the storage devices as their addresses may no longer be correct.
This really does sound like a network/hardware configuration issue.

Maybe won’t fix anything but its worth your time to try…

Power everything down (router, machines, endpoint, modem, etc. Everything that touches the network)

  1. Go to whatever Internet box your provider uses and power that on. Let it come up completely. For a cable modem this could take 5 minutes or more.
  2. Power on your Eero, give it time to boot fully.
  3. Boot / reboot a machine.
  4. Use that machine to verify the internet is up and working via both Ethernet and wireless.
  5. Now start Roon, let it boot.
  6. Now power on your audio endpoints.

Why this may make a difference… After a power outage things can boot out of order. Certainly things, like the DHCP server, should be availale first in the network but may not be after a power outage. This can lead to instability with the router, nodes, etc. as not everything is covered properly. My steps above will boot things in a proper order.

Low confidence this will fix your issue but its worth taking the time as an easy troubleshooting exercise.

1 Like
1 Like

Hi @Michael_Glish, I ran diagnostics on your Core and I’m seeing some strange errors. The typical errors associated with this kind of failure I’m not seeing, but I am seeing continual failures when trying to connect to a network share:


I’m wondering if this network change is part of the issue since that share appears to be from the old IP range. If you go to Settings > Storage do you see this network share? Can you remove it completely from Roon, reboot, and then let us know if you see any change?

I appreciate your thoughtful suggestion. It will take some time and prep to execute that plan. It’s probably good housekeeping in any case. Just for fun I unplugged my Bluesound Node. I’m assuming it will make a DHCP request if needed. But the Room app still tells me the same thing.

I mentioned this in my summary: I set up the Rock server on a previous network address space. I purchased a new Wi-Fi router which changed the address space. Everything worked fine with Roon after this except I didn’t change the backup volume destination. So you’re seeing my server trying to access the NAS volume on its old IP address.

I did change the backup address and I could see that it connected. I didn’t reboot. I just did that.

And lo and behold! Now I can see all of my devices. Imagine that. Rebooting was all I needed to do.


I love Roon and I love the Roon community.


1 Like