No audio in exclusive mode using USB with Teac UD-501


Roon: Version 1.4 (build 306) stable (64-bit)
OS: Max OS X High Sierra, version 10.13.3
Computer: Mac Mini (Late 2012)
Music Storage: On local disk (Samsung 850 Evo SSD)
Collection Size: 402 albums, 3771 tracks
DAC: Teac UD-501, connected via USB
Other: Schiit Wyrd, Schiit Eitr

The Issue

Attempting to use Exclusive Mode via USB to Teac UD-501 fails, with no sound for any format input files (both PCM and DSD).

I’ve tried this with and without a Schiit Wyrd - this did not make a difference.

Using the OS X ‘Audio Midi Setup’ application shows the output is always set to 32-bit when Exclusive Mode is enabled. Setting the Max Bits Per Sample to 24-bit has no effect: the OS X ‘Audio Midi Setup’ application shows the output remains set to 32-bit. That said, the Teac UD-501 claims to support 32-bit (

Everything works fine with Exclusive Mode disabled, though obviously then I cannot natively play DSD files (via DSD over PCM) or high sample rate PCM files.

Thanks for your assistance,

Hello @SNMoore,

When using exclusive mode, what does the LCD on the UD-501 show? Does the sample rate and format change with the media you are attempting to play to it? Does it show no input at all?


Hi John,

Well, I’m not sure what it going on, but it now seems to be working - partly and inconsistently.

I had previously tried multiple times, but failed each time. But I just switched back to the USB output and enabled exclusive mode, and now its playing audio (sometimes):

Flac 44.1kHz / 16-bit:
Played OK, showed as “PCM 44.1kHz” on the Teac, and “2ch 32-bit Integer 44.1kHz” in Audio Midi Setup.

Flac 48kHz / 24-bit:
Played OK, showed as “PCM 48kHz” on the Teac, and “2ch 24-bit Integer 48kHz” in Audio Midi Setup.

Flac 88.2kHz / 24-bit:
Played OK, showed as “PCM 88.2kHz” on the Teac, and “2ch 24-bit Integer 88.2kHz” in Audio Midi Setup.

Flac 96kHz / 24-bit:
Failed to play for one set of tracks - the Teac showed “PCM 88.2kHz” (presumably from the previous track"), Audio Midi Setup showed “2ch 32-bit Integer 96kHz”.

Played OK for another set of tracks - showed as “PCM 96kHz” on the Teac, and “2ch 24-bit Integer 96kHz” in Audio Midi Setup.

Then I reverted to the set of tracks that failed to play earlier, which then played OK - showed as “PCM 96kHz” on the Teac, and “2ch 24-bit Integer 96kHz” in Audio Midi Setup.

DSD64 (DSF file):
Failed to play - showed as “PCM 96kHz” on the Teac (presumably from the previous track), and “2ch 32-bit Integer 176.4kHz” in Audio Midi Setup.

I then switched to a Flac 44.1kHz / 16-bit track, then back to the DSD64 (DSF file) track - this then played OK - showed as “DSD 2.8MHz” on the Teac, , and “2ch 24-bit Integer 176.4kHz” in Audio Midi Setup.

Roon settings for the device were:
Use Exclusive Mode: Yes
Use Integer Mode if Supported: Yes
Use Max Hardware Buffer Size: No
Use Power-of-2 Hardware Buffer Size: No
Max Sample Rate (PCM): Up to 384kHz
Max Bits Per Sample (PCM): 24
DSD Playback Strategy: DSP over PCM 1.0 (DoP)
Max DSD Sample Rate: Up to DSD128


I am having the exact same issue with my UD-501. i have changed out USB cables, USB ports on the MacMini.with and without the AQ jitterbug.

Same symptoms exactly as above. weird stuff in exclusive mode on my mac. If I turn the DAC off and back on again, I can mess with playing files until I get what I want to play. the Audio MIDI shows some odd bitrates as above. the file will not play at all, until I mess with it enough. any thoughts?

Roon: Version 1.4 (build 310) stable (64-bit)
OS: Max OS X High Sierra, version 10.13.4
Computer: Mac Mini (Late 2012) 16GB Ram 2.5 Ghz i5
Music Storage: External Firewire 3TB
Collection Size: 4018 albums, 65567 tracks
DAC: Teac UD-501, connected via USB
Other: AudioQuest Jitterbug

Hello @Chad_Fagin & @SNMoore,

I’m quoting this from another thread about the UD-501, and unfortunately we do not have a better workaround available at this time. The TEAC UD-501 does not correctly follow MacOS CoreAudio conventions for switching sample rates, and this issue is solely in their domain to fix. If there’s any news to share from our end, I’ll be sure to update this thread.


1 Like

Thanks for the input John.
Total bummer btw, :frowning: do you know if the same symptoms exist with the UD-503 as well?

I have been doing some research and struggling with a path forward,
is this a problem with only specific DACs and Core Audio of Mac, or is this a problem using the Mac as a player all together with a USB DAC in exclusive mode.

will another DAC resolve the problem?
or should I be looking at a new end point and use the Mac as a core only?

Thank you

Thanks for the status update John. Is there any chance you have a compatibility list of DACs that are known or not known to work in exclusive mode?


1 Like

Hello @Chad_Fagin & @SNMoore,

At this time, we are not aware of this issue effecting any other USB DAC in “Exclusive mode” with advertised MacOS compatibility.

Another option instead of switching on-and-off sample rate conversion in the Roon DSP Engine is to just leave upsampling on all of the time. In my testing, the TEAC UD-501 responds to requests to increase it’s sample rate just fine, it’s decreasing the sample rate that it refuses to do and prevents playback. If you leave sample rate conversion on and set to “Max PCM Rate (Power of 2)”, the device seems to be able to switch sample rates between 352.8 kHz and 384 kHz without issue.


1 Like

Bought an UD-501 yesterday and… just found about this very issue :neutral_face:

though… looks the issue is indeed with just Roon as, among different things I tried to make it work… I launched Audirvana+ and found it consistently works if “Integer Mode” is disabled
In fact when I want to play from Roon I must first start playback from Audirvana then stop it and finally play from Roon instead

so… Audirvana only works if “Integer Mode” is disabled. Once set this way it always works fine and changes resolution up and down accordingly to track’s
Roon can’t lock the signal with “Integer” either enabled or disabled but once the DAC has locked the signal (using A+) Roon works no matter how “Integer” is set 'till… a track is lower resolution than last played one and at this point Roon chokes

(btw… it was many, many months since last time I even just touched A+ :roll_eyes:)

Please @support have a further look into this
thanks :slight_smile:

Hello @pl_svn,

Thank you for the report. I will be sure to pass along your findings to the development team. Some investigation work has been done regarding this issue, but unfortunately we do not have a timeline on when we can expect a fix just yet. It is on our radar and we hope to have more to share soon.


1 Like

Hello there

I have a similar DAC I think: Teac AI-503.

I’m not following what the issue here is: playing DSD files is not working?

Even with DSD over PCM mode?

Just trying to understand.

thank you very much @john :slight_smile:
hope developers come up to a fix: looks it’s something related to Integer Mode, not to Exclusive Access, as in Audirvana there’s no way to disable the latter

@Gigatoaster issue is that on Mac OS Roon can’t start playback to an UD-501 connected via USB: UD-501’s display keeps flashing “USB Ready” and nothing plays
Then, if by mean of some tinkering, you succeed at starting playback… Roon chokes again as soon as you try playing a track which is lower resolution than last successfully played one

Gotcha. Thanks for the explanation.
I am impacted by this bug.
I contacted Teac support more than 10 days ago but they haven’t answered yet. Have you tried contacting or calling them?
Is Teac referenced on Roon? Then they should talk to each other.

ooops: today can’t make playback start, whatever I try, even from Audirvana :rage:

@Gigatoaster let us, please, know it you get any answer from Teac
I’ll try contacting them too

Seeing as this thread is active again…

Teac UD-501, Roon and Mac OS X used to work fine on older versions, without these problems - this combination had been my main rig for many years now. I only encountered these problems when I changed my Mac to a newer Mac Mini, and in the process upgraded to Mac OS X High Sierra, version 10.13.3 and Roon version 1.4.

Sadly, I don’t have any records of exactly what version of Mac OS X was previously working fine - I have a feeling it was 10.9 Mavericks or 10.10 Yosemite.

seller just gave me a mail contact with a Teac representative here in Italy

he pointed me to the latest release of their HD Player (still have to give it try though… older ones I tried this morning do not work)

He also says UD-501, 503 and 505 are all compatible with Roon on macOS High Sierra. If one finds they are not… contact Roon :no_mouth:

So when I look at the Partner Matrix, I can see the UD-501 as “In House”, which means Roon has a relationship with them. Interestingly, only DSD128 is supported and I thought the UD-501 was able to support DSD512.

So Roon & Teac should talk to each other…

nope: UD-501 “only” goes up to DSD128
I actually managed to play both DS64 and DSD128, when doing my tests two days ago, from both Roon and Audirvana. but today… nothing no matter what I try :rage:

also tried a few minutes ago Teac Player’s latest version (link in my previous post) to no avail: DAC display keeps flashing “USB Ready” and the app freezes as soon as I hit play

think I’ll bring this thing back to seller and get something else :roll_eyes:

a never ending story: now I managed to make it work by setting, first, Audirvana to upsample 2x then switching to Roon :roll_eyes: