No local audio outputs on Mac used as Remote

Roon Core Machine

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i7BEH running Roon ROCK Version 1.0 (build 259) production

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
500/500 fiber → Firewalla Gold router → Ethernet Cable → Roon Core on ROCK on NUC

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

All music content files are on a 8 TB WD external HDD attached to NUC

Networking Gear & Setup Details

No VPN. Other networking info as above.

Connected Audio Devices

(1) Mac Studio M1 MacOS Ventura 13.5.2, running Roon app (Roon version 2.0 build 1311 production) as remote, via Roon Bridge (Version 1.8 (build 1125) stable.

(2) NUC → HDMI → Marantz AV7704.

Number of Tracks in Library

~30,000 tracks

Description of Issue

95% of my listening is (was) via Roon used as a Remote via Roon Bridge, playing to the System Ouput endpoint on a Mac Studio (Endpoint 1 listed above). Since July 28, I have been unable to see any System Ouput items on the Mac Studio (or for that matter on any Mac I own). I know it’s July 28 because that’s the last History entry I see that I know I played on the Mac Studio Roon app. I believe (but am not sure) that it was immediately after a Roon update that the System Output endpoint disappeared.

See screenshot: not a single local audio output visible on the Remote machine.

I have tried the solution given at:

but that did not fix the issue for me

And I have read as many of the similar posts that I could, but without any resolution:

Roon plays fine from the NUC → HDMI → Marantz that it’s connected to. And on an iPhone and iPad, I can use the Roon Remote app to play to those devices themselves as endpoints. It’s just Macs apparently that are missing as endpoints.

Any help appreciated – TIA

The firewall on a PC can prevent communication with the core to create the audio endpoints on that PC. As a test, turn off the firewall on that PC and see if the endpoints appear. If so, then add Raatserver.exe as a firewall exception. (also check that Roon.exe, roonappliance.exe are also exceptions.)

@otinkyad, I see you noted that you are running Roon Remote and Roon Bridge on your M1 Studio. Are these running simultaneously, or do you use Roon Bridge when you do not want to use the Remote GUI?

@Rugby and @Robert_F – many thanks for the suggestions!

@Rugby – unfortunately that did not change anything. But, that gave me the idea to try a different basic thing: Reboot! On my Mac laptop (M1 Macbook Air), rebooting resulted in rediscovery of the System Output. No such luck yet on the Mac Studio, though – i.e., rebooting has not helped. (I had alrady tried that previously, just yesterday). I do have a couple of other ideas now, though, for the Mac Studio, given that I’ve been able to get the laptop to work… will report back…

@Robert_F – Roon Remote and Roon Bridge run simultaneously, or rather, I start Roon Bridge first, and then Remote. My understanding had always been that to use the Roon app as a remote on a PC (Windows/Mac), Roon Bridge had to be running first. Is that not correct? (Or, has that changed in the last year or so…?) Interested to hear back on this.

Roon Bridge is not needed if you are running Roon Remote (Remote also acts as a bridge but includes the user interface). I run Bridge on a PC I use to connect other endpoints, but do not need the user interface. You don’t need to run both on the same Mac or PC.

What if you reboot and run only Roon Remote without activating Bridge on the Studio?

Hmm… well, a second reboot solved the Mac Studio… I assume that this is a combination of having applied the RAATServer fix and then rebooted some magic number of times… I had certainly rebooted enough times to no avail before applying the RAATServer fix…

Regarding Roon Bridge, as you said, @Robert_F : Remote works either with or without Roon Bridge running. I really thought that in the past Remote didn’t work without Roon Bridge…

Thank you both again!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.