No system output in Mac OS 11.6.3

Roon Core Machine

Macbook pro 2018 running Mac Os big sur 11.6.3 (20G415) running latest version of Roon

Networking Gear & Setup Details

Connected Audio Devices

System output

Number of Tracks in Library

11450

Description of Issue

There are no system outputs available in settings/audio (external output, loudspeakers, system default, etc).

I tried restarting both roon and the macbook pro. Maybe once out of 5 attempts every now and then, I get them to show.

Hi @Ezequiel_Kinigsberg ,

Can you please check to see if Roon build 918 has helped with this issue on your end? You can confirm what version you’re under in Roon Settings → About.

Hello @noris, sorry for the delay. Build 918 hasn’t solved the issue. I have no idea why it happens sometimes and not others, seems random on my end.

Ezequiel, have you restarted your Core, or rebooted your Mac and then start Roon? Does this change anything? Very odd that System Output does not appear for your Mac.

Yes, tried everything, even re-installing roon.

@noris and the Roon team may need to look at your logs.

Here they are. I reinstalled a few days ago, so 5 log files only. Right now Roon is unusable with local outputs, would be great to find a solution because I rarely use Roon with other audio outputs.

Let’s see if @support can help after the weekend.

Hi @Ezequiel_Kinigsberg ,

Thanks for letting us know that the issue is still the same. Can we please ask that you open Console.app, reproduce the issue by navigating to the Audio page on the affected Mac and then upload the log generated here and let us know?

https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external

As another test you can also perform a RAATServer refresh. You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

I didn’t know how to use the console, but fyi I started recording activity while on the my MBP device section, went to the audio tab in roon and then stopped recording. Logs already uploaded with my email on the name.

Regarding the RAATServer refresh, didn’t work. BTW, I didn’t see a new RAATServer folder being created after opening roon, is that normal? (I renamed this folder located in /Users/elece/Library/RAATServer_old).

Make sure you rename the folder on the drive where you’re Core is running (not the Client on a separate machine like I did). This fixed my issue with connected devices on the Core also.

1 Like

Hi @Ezequiel_Kinigsberg ,

Did you manage to resolve this issue? I was looking over your system diagnostics and I noticed that your audio devices are showing up ok, if you still have issues here, do let us know, thanks!

I did a fresh intall of the operating system for other reasons and for the time being, it is working fine. I’ll re-ask if I see the problem again.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.