No MQA playback in grouped zones possible, when one zone is 'mono'

I have one zone that I have set up with ‘procedural eq’ on mono (as described here Can you get Roon to merge the stereo channels into mono?). MQA content can be played here without any problems. But as soon as this zone is included in a group, it no longer works. Error:

Unexpected error communicating with audio device

and

Too many failures. Stopping playback

Does anyone know the problem and can it be solved?

What else are you grouping it with?

For Testing just 2 Zones:
Zone 1 and Zone 2 (Mono zone) are both:

  • Raspberry Pi 2 Model B Rev 1.2
  • HifiBerry Amp2
  • RoPiee 4.020

Originally both from above plus

  • NAD M10 (v. 3.18.7)

Hi @gbff ,

Thanks for reaching out! Apologies for the delay in getting back to you here, I thought I responded to your thread earlier, but it appears I didn’t press send.

If you try to group both of these Mono zones, do they work as expected? What does the Signal Path look like when you are playing the Mono zone? Can you share a screenshot? How is MQA playback configured in Device Setup?

Similarly, what does the NAD signal path look like when you have it playing just by itself? What does device setup show for MQA Playback?

Can you let us know the exact local time + date when you next encounter this issue? We can enable diagnositcs to see if logs provide further clues.

Hi Noris

Thank you for your reply.
OK, I’m one step further.
I wasn’t quite clear what the setup is.
Zone 1 and Zone 2 are both the same technology (RaspberryPi with HifiBerry Amp2). One of them normal, and one as MONO configuration in Roon. The 3rd zone is a NAD M10.
I have now tried something else. I discovered that if I group the 3 zones in such a way that the NAD M10 is defined as the base, then it doesn’t work. If I take one of the other zones as the base, then it works.

Here are the signal paths of the three zones individually, ungrouped (Zone “Bath GF” is the mono zone)



1 Like