No progress on rescanning files with software 1.1 installed

I have a Macbook pro, late 2008,
2.53 GHz and 4GB memory with 2,5 GB SSD HD.
The music is stored on a connected USB drive and runs before without problems.
Software is OSX Yosemite version 10.10.3

Yesterday i installed the new 1.1 version.The first three points are done
-File exporter/file copying(for import)/Adding Music to library-
but then it sticks since HOURS on the fourth point “rescanning files”.
I stick at track2 of 2983…
Close soon and open up again doesn’t help,no error message appear and in
“settings” and then further in “setup” the “audio analyses speed…” and “Memory…” are set to maximum.

1)What happens here and how i can solve that ?
2)What about the point(also in setup) “library maintenance” - “clean up library” ?
Should i try that out, what does it do, and it is recommended or helpful ?

Thanks Robert from austria

Similar problem with an iMac and MBP. I’ve posted in another thread my experience Roon 1.1 updated but now no music appears and audio device not shown. Hopefully this is a bug that will get sorted soon.

Same problem. It scanned ~20,000 tracks and the just stopped. It’s been stuck at the same place (see image) for the past day or so, across several cycles of quitting and reopening the app.

Hey guys, @amg, @robtodd @RobertW

Sorry for the trouble here. We’re going to get in touch with each of you by PM, and we’ll figure out what’s going on.

Stand by!

Not sure if this is the same problem or not, but since upgrading to version 1.1, I’ve been trying to add my main home volume of music to my Roon library without luck. Previously (using version 1.0, I was able to add the volume of music in my office (stored on a Synology NAS) and locally on my laptop (stored on the internal SSD of a Macbook Air) without incident. Now I am trying to add a volume of music stored at home on an external USB drive attached to a Mac Mini that is used as a file server. Roon is running on the same Macbook Air that successfully imported the other volumes mentioned above, and I have pointed Roon toward the USB drive via SMB (not AFP). After aborting several attempts that never got beyond “0 added, 0 identified” at the “Adding Music to Library” stage, I left it running all night long, but still no success.

Any help would be gratefully received!

Hey @StuartB – we’re looking into this issue, but I’d like to get a little more information from you. I’m going to send you a PM and we’ll figure out what’s going on.

Sorry for the trouble!

@Mike, thanks very much for the help! I’ve separately sent you the logs and other requested information.

Very impressed with your quick help!

Hello all,

Mike mailed me that the problem is related to my itunes XML files in the iTunes library and it should be fixed today :)))) I couldn’t wait and disabled the Itunes storage in ROON.Now its analyzing my music, its looks good at the moment.The ID40 isn’t show up, but i will report asap as the analyzing is finished what is going on

Thanks Mike


All tracks are imported and scanned/identified now :-)))
Only the ID40 had/have made problems as ROON can’t find it.I had to change the ID40 to a static dress,
no logic for me,but its work now.

Will test how everything is going on


1 Like

Thanks for the report, @RobertW. I also had an iTunes library that had been scanned by noon, so I tried disabling the iTunes library and re-scanning my main library on the network, but no joy so far.

@mike, any thoughts would be very welcome.


Stuart, interesting.I disabled the itunes library on “preference” -“storage”-“watched folders”-.After that i “remove” the standard music library.The i add it again.It starts import and scanning and after some start/ckose of the Roon application its working now.

Thanks, Robert. I tried this also, but it still won’t add the songs from the networked drive. I’ll try a few more experiments…

Hmm, tried attached the HDD containing the main library to my laptop (on which Roon is running) directly via USB, and then adding it as a new folder, but to no avail; as before, it will not “add” or “identify” any files. Also tried pointing Roon at a sub-folder, rather than the top volume of the drive, also with no luck. I am running out of ideas of things to try.

Hey @StuartB – I have some logs from you that I’m looking over. Sorry for the delay here. I should have more feedback for you by tomorrow, and we’ll get this working for you.

Appreciate your patience here!

Thanks, @mike!

Stuck on rescanning files - build 102, Windows 10 64bit.

  • What is the best way to troubleshoot? Send in the logs - to whom?
  • Can we perhaps ask for an enhancement on the status screen where Roon shows the current track that is being scanned? That would allow us to remove the offending (?) piece of music.
  • Or perhaps even have a button “skip current track/album/folder” if Roon appears to be stuck?
  • Or a piece of clever software logic that decides to call it a day on a particular file if no progress in scanning is achieved after 10(?) minutes?