No remote access after setting Mac to rest

Unfortunately it seems that I have the same problem. Works fine until set to rest for a couple of hours then no remote access. I used to have Roon on my iMac and all worked fine but on the Mac mini M1 I have not managed to get it working. Is there a solution to the problem? Is it Mac OS Monterey on Mac mini M1 or is it Roon that causes the problem?

Hey @Arne_Jonsson,

I have created a new thread out of your post, so we can focus on your issue alone. Would you please be so kind as to share the details below:

Roon Core Machine

Include your operating system and machine info (Model, CPU, RAM)

Networking Gear & Setup Details

Your network gear (model of routers/switches) and if on WiFi/Ethernet

Connected Audio Devices

Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)

Number of Tracks in Library

Tell us how large your music library is, eg. “30,000 tracks”

Description of Issue

Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!

The problem has actually changed, to the worse. It was not a wake up issue. In fact the Roon server caused my Macs to crash. I realised it when I moved the Roon server from my iMac to the Mac mini. All of a sudden it was not the iMac that crashed but the Mac mini. It happens over night, never when I play. The Mac reports an unusual event that forced the Mac to restart. And it happens randomly, at least have I not yet spotted a pattern. Some mornings it works perfect but some it has crashed. And it can happen during the day as well if I have not played for a couple of hours.

The first machine was a 2020 iMac 3,8Ghz 8-core Intel i7 with 32GB RAM and 4TB SSD and the second is a brand new Mac mini M1 with 16GB RAM and 2TB SSD. Both running Monterey 12.1. My network is a Linksys mesh with three nodes but both machines are Ethernet cable connected, I only use wireless for the iPhones, google nests etc. I also have an ARCAM SA30 that I use, cable connected. I have 18000 tracks in my library. Use mainly Tidal. The Mac mini Roon server used the backup from the iMac, i.e. I never configured it from scratch.

Hey @Arne_Jonsson,

I am sorry to hear, but I am grateful you’ve shared the details. You mentioned moving Roon Server from your iMac to the Mac Mini. Have you downloaded the latest RoonServer build from our website, or did you use an installer you already had?

Either way, would you please grab a set of logs and upload them to our drive? We’d love to take a look and see if the cause is visible there.

I use 1.8 (build 884) on both machines.

1 Like

I just sent the latest log file and, if it helps the crash report comes here:

Attempting to forcibly halt cpu 0
cpu 0 failed to halt with error -5: halt not supported for this configuration
Debugger synchronization timed out; waited 240000 nanoseconds
panic(cpu 1 caller 0xfffffe0013ebc708): thread_call group 'high' reached max thread cap (500): active: 1, blocked: 499, idle: 0 @thread_call.c:409
Debugger message: panic
Memory ID: 0x6
OS release type: User
OS version: 21C52
Kernel version: Darwin Kernel Version 21.2.0: Sun Nov 28 20:29:10 PST 2021; root:xnu-8019.61.5~1/RELEASE_ARM64_T8101
Fileset Kernelcache UUID: 0BB1D99520DD8B6DD172990B62E25173
Kernel UUID: 45FC3A32-3BC5-3F88-9300-71FBEF05D092
iBoot version: iBoot-7429.61.2
secure boot?: YES
Paniclog version: 13
KernelCache slide: 0x000000000c500000
KernelCache base:  0xfffffe0013504000
Kernel slide:      0x000000000cd2c000
Kernel text base:  0xfffffe0013d30000
Kernel text exec slide: 0x000000000ce14000
Kernel text exec base:  0xfffffe0013e18000
mach_absolute_time: 0x5e4555f11d6
Epoch Time:        sec       usec
  Boot    : 0x61e643e5 0x000bf3ff
  Sleep   : 0x00000000 0x00000000
  Wake    : 0x00000000 0x00000000
  Calendar: 0x61ea6240 0x000581cd

Zone info:
Foreign   : 0xfffffe001a850000 - 0xfffffe001a864000
Native    : 0xfffffe10003c0000 - 0xfffffe30003c0000
Readonly  : 0xfffffe14cd08c000 - 0xfffffe1666a20000
Metadata  : 0xfffffe8bab818000 - 0xfffffe8bb77b0000
Bitmaps   : 0xfffffe8bb77b0000 - 0xfffffe8bbd2b0000
CORE 0 recently retired instr at 0xfffffe0013e84560
CORE 1 recently retired instr at 0xfffffe0013fa20d8
CORE 2 recently retired instr at 0xfffffe0013fa36c4
CORE 3 recently retired instr at 0xfffffe0013fa36c4
CORE 4 recently retired instr at 0xfffffe0013fa36c8
CORE 5 recently retired instr at 0xfffffe0013fa36c8
CORE 6 recently retired instr at 0xfffffe0013fa36c8
CORE 7 recently retired instr at 0xfffffe0013fa36c8
CORE 0 PVH locks held: None
CORE 1 PVH locks held: None
CORE 2 PVH locks held: None
CORE 3 PVH locks held: None
CORE 4 PVH locks held: None
CORE 5 PVH locks held: None
CORE 6 PVH locks held: None
CORE 7 PVH locks held: None
CORE 0: PC=0x000000019dce1a64, LR=0x000000019db97ec0, FP=0x000000016b319bd0
CORE 1 is the one that panicked. Check the full backtrace for details.
CORE 2: PC=0xfffffe00145fb70c, LR=0xfffffe0015b9ff5c, FP=0xfffffe6fe83cb670
CORE 3: PC=0xfffffe0013f98cd0, LR=0xfffffe0013f98cf0, FP=0xfffffe6fe835bd20
CORE 4: PC=0xfffffe0013e9ee00, LR=0xfffffe0013e9ee00, FP=0xfffffe6fe831bef0
CORE 5: PC=0xfffffe0013e9ee00, LR=0xfffffe0013e9ee00, FP=0xfffffe6fe818bef0
CORE 6: PC=0xfffffe0013e9ee00, LR=0xfffffe0013e9ee00, FP=0xfffffe6fe819bef0
CORE 7: PC=0xfffffe0013e9ee00, LR=0xfffffe0013e9ee00, FP=0xfffffe6fe73abef0
Panicked task 0xfffffe20005b0678: 0 pages, 973 threads: pid 0: kernel_task
Panicked thread: 0xfffffe20002638e0, backtrace: 0xfffffe6fe83eb790, tid: 107
		  lr: 0xfffffe0013e6a4c0  fp: 0xfffffe6fe83eb800
		  lr: 0xfffffe0013e6a190  fp: 0xfffffe6fe83eb870
		  lr: 0xfffffe0013fa973c  fp: 0xfffffe6fe83eb890
		  lr: 0xfffffe0013f9c024  fp: 0xfffffe6fe83eb910
		  lr: 0xfffffe0013f99a74  fp: 0xfffffe6fe83eb9d0
		  lr: 0xfffffe0013e1f7f8  fp: 0xfffffe6fe83eb9e0
		  lr: 0xfffffe0013e69e08  fp: 0xfffffe6fe83ebd80
		  lr: 0xfffffe0013e69e08  fp: 0xfffffe6fe83ebdf0
		  lr: 0xfffffe001467ef9c  fp: 0xfffffe6fe83ebe10
		  lr: 0xfffffe0013ebc708  fp: 0xfffffe6fe83ebf20
		  lr: 0xfffffe0013e28e78  fp: 0x0000000000000000

last started kext at 2877157809:	4.0 (addr 0xfffffe0013d14760, size 64483)
loaded kexts:	4.0	5020.1	3.0	1.14.1	20.036.15	1	1	493.0.0	493.0.0	493.0.0	493.0.0	100.1	1	1933.61.1	1	11.0.0	161.0.0	5.0.0	4.0.3	3.0.1	1.9	1	1	1	1	1.0.0	582.60.2	1	40	1.0.0	1.0.0d1	1	1	520.5	1.0.1	520.5	1	1	100.51	520.21.1	416	1	140.0	4.7.9	187.59	1	1	1	1	1	1	1.0.0d1	1.0.0d1	1.0.0d1	1.0.0d1	1	1.0.0d1	1	1	1	1.0.0d2	1	1.0.1	1	1	1	126.60.3	2.0.0	402	1	1	1010.2	6.0.0	228	1010.2	1000.11	1.1.0	5430.1	5430.1	5400.30	5020.1	9.0.0	1.0	100.99	1	493.0.0	102.2	3	1	1	1.0.1	1	1.2	1	1	1	1	1.0.1	5.0.0	1.0.4	4.1.1	8.5.1	8.5.1	1.0.0	1	1.9	187.59	187.59	3	1	1.0.0	1	2.1.0	1.0.0	1.0.0	3.4.4	520.5	1.0.1	520.5	100.1	1	1	1.0	1.0	2.0.0	1	1.2	1	1.2	1.2	1.0.1	343.0.0	343.0.0	5.34.0	1	1	35.11	600.95	100.9.1	1	1	3.0	1	1	1.0	1.0.0	1	7.2.8	1	9.3.3	1	1	1	1	1.0.0	1200.12.2b1	1.0.0	1	1.0.4	1

Hey @Arne_Jonsson,

Thanks for sharing all of that — as it seems like you might have discovered yourself, this is a kernel panic error.

I can’t explain it better than our COO does here:

Would you please take a moment to read his explanation?

Ok. As for the iMac there man be other causes, but the Mac mini was bought for running Roon and Lightroom. I do not use it. I have only installed adobe lightroom, Dropbox, iCloud and Roon. Have not even configured email or OneDrive. It is brand new.

It is monitored by my university. But I am an administrator.

Hey @Arne_Jonsson,

If I recall correctly, running Roon on the iMac worked well (I used to have Roon on my iMac and all worked fine), so it is the Mac Mini M1 that there are issues with.

Are there any firewalls or antiviruses enabled on it? If so, could you please disable them?

Sorry for the confusion. I thought that the problem was the wake up on the Mac mini, but I realised that the new Mac mini had the same problem that the iMac had. They both crash when Roon is running. Now, when I use the Mac mini for Roon the iMac does not crash any more. Instead it is the mini that crashes, as I run Roon on it. So the comment “all worked fine” was before I understood that it was Roon that made my machines crash.

Both machines run Microsoft Defender ATP. Required by the university. Not sure if I can disable it. Nothing happens when I click quit.

Hey @Arne_Jonsson,

Thanks for clarifying :relieved:

It’s important to note that Roon itself cannot crash your computer, be it the Mac Mini or iMac — Roon does not function at a low enough level to do this. However, Roon might for example be using a driver that is corrupt and then everything crashes; in this case, Roon is simply trying to use a driver that is not functioning properly.

While it might be the Microsoft Defender ATP at play, we won’t know for sure unless we take a look at the system logs (the MacOS logs). Then we can make suggestions accordingly.

After a crash like this, please, mark down the local date and time to share with us. Then, could you please get the Console logs, zip up the entire folder and upload it here.

To get the Console logs, you can follow these steps:

Open (this is part of mac os x. You can command-spacebar and then type “console” to find it).

Then go into the “User Reports” section, and see if you can find any Roon crashes in there.

For any crashes, paste the contents into a text doc and then send that file over to use so we can take a look.


Many thanks :pray:

I hope I uploaded the correct file. In Monterey console looks different but this was the only file I found searching for Roon.

1 Like

Thanks @Arne_Jonsson — I appreciate you getting it done, despite the slightly different instructions :pray:

Your data is now with our technical team. I’ll follow up as soon as I hear back.

Any progress? Roon is rather useless for me now as I have to log in to the computer when it crashes, which it does too often.

Hey @Arne_Jonsson,

Thank you so much for your patience :pray:

Our technical team has found some errors in the logs that should be cleared by a database reset on your computer (the one that crashes). Instructions are below:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location (on the crashing PC)
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Thank you very much for trying :pray:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.