No Roon Radio after track / no recommendations

Core Machine
Audio-Linux [custom ARCH build / PC / Roon 1.7 Build 528 Core / Control via iPad 1.7 Build)**

Network Details
WiFi at 250 mbps DL/UL

Audio Devices
USB to Topping D70

Description Of Issue
I have just started with a Roon trial and listened to about 10 albums so far (a few streamed through Tidal, a few in my “library” through Tidal and one local album ripped from a CD).

One thing I was excited for was Roon Radio kicking in after albums ended with random songs. Another thing was for Roon’s recommendations.

Unfortunately, neither work at this time. When albums end, I get a “unexpected error; playing from local library” instead of Roon Radio. I’ve seen others post about this error but it seems it got fixed in a patch around April 2019.

Please advise of any insight. Thanks!

Hi @ScornDefeat87,

Can you elaborate on your network setup? What router are you using? Is your Core machine connected via WiFi? Is there any change if you connect via Ethernet?

Absolutely, no problem.

I am using a Verizon FIOS router model G3100. Both my Core machine and Roon Remote (iPad) are connected via WiFi through this router. I connect the Core through WiFi because there is no easy ethernet access where my audio rack is; I use the Core PC as both the core and streamer and, as such, keep it in my living room.

Thanks for your help!

Thanks for the details, @ScornDefeat87.

As noted in our Networking Guide we always recommend that your Core machine be connected via Ethernet whenever possible. I know in this case it sounds like it’s not possible, at least regularly, but if you could even as a quick test to see if there is any change that would be very helpful!

If you start Roon Radio manually instead, is there any change? You can start Radio manually by going to an album, choosing the arrow next to Play, and choosing Roon Radio:


Engaging play via the “Roon Radio” doesn’t change anything: first error message is “Nothing Similar Found.” If I then play the song anyway, back to the other error message described above.

I tried using the Core through ethernet but now its giving me an Authorizations issue, forcing me to unathorize my Core. Its the same Core, just now plugged into Ethernet, so not sure why this is occurring.



Ok, so I unauthorized my Core and re-authorized it via Ethernet. Still, no Roon Radio, no recommendations. Same errors as on WiFi as on Ethernet.

Thanks, @ScornDefeat87,

Here’s what I’m hoping you can do next:

  • Reboot the Core machine
  • Try to start Roon Radio manually — Make a note of the album you start this on and the time in your local timezone that you try to start
  • Next, use the directions found here and send us over a set of logs using a shared Dropbox link
  • Respond here with the album, time, and link to the logs and I’ll have the team take a look



Absolutely, please see as follows:

-Reboot confirmed
-Started Roon manually and played the following:
Through Tidal:
Steely Dan - Two Against Nature at 21:54
Through Local:
Iluvatar - Children at 21:55
-Google Drive shared link:

Thank you for your help and hoping this gets resolved shortly!


Thanks for sharing that, @ScornDefeat87! I’ll get this to the team for analysis and will follow up soon.


Any update on this? Eager to get this resolved before my trial runs out in order to proceed accordingly with re-upping or not.


Hi @ScornDefeat87,

Apologies for the delay here. I met with the team to discuss this this morning and have some next steps here.

It appears that your machine is having trouble communicating with our servers based on what we are seeing in the logs you’ve shared. Moving forward, we’re running some diagnostics on our servers so we can see what happens on our end when this happens to you. The next time you reproduce this can you please let me know here and tag @support and we will have the team take a look?


Thank you @dylan for continuing to assist and troubleshoot this!

I have tried twice again and received the same set of errors. Hoping @support can assist by looking at the logs on the backend.

Through Tidal:
Dua Lipa - Future Nostalgia at 23:48 GMT

Through Local:
Iluvatar - Children at 23:50 GMT



Just wanted to follow-up for any updates as a week has elapsed. Let me know. Thanks!

Hi @ScornDefeat87,

Our team is currently investigating this and we have a meeting scheduled with our senior development team to discuss tomorrow.

In the meantime, if you’re interested in helping us better understand why this only affects a small number of customers, I’m hoping you might be able to try a test for us.

If you connect your Core machine via USB tethering or hotspot to a mobile device, does the same issue occur? While this is not an ideal network setup for Roon long-term, this is an easy way to test this behavior on a completely different network.


Hi @ScornDefeat87,

We’ve made an update to our servers that we believe will help improve this. Can you give this another try and let us know if things are working for you now?

Your patience as we’ve looked into this has been greatly appreciated — Thanks!

The Roon Support Team


I just gave it a try and looks like its working; i was able to get a Roon Radio track to kick in after playing a song, as well as the new addition of “new releases for you” in my overview screen.

Really appreciate your efforts to get this fixed and look forward to being a Roon user for years to come.

Thanks again!!!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.