No signal received on AVR via HDMI From Nucleus

I am a bit bewildered as I cannot play from my Nucleus via HDMI.
However, via AirPlay it works.
My set-up is Roon Nucleus with FlashDrive using internal storage to Denon AVR X4000 as Core and Apple iPad (or iPhone) as remote.
Playback via HDMI (not working) respectively via Airplay (working) and via Apple TV (working).
I tried several HDMI inputs on the AVR, did not work.
I changed the HDMI cable, did not work.
I used so far unused HDMI input on front of AVR, did not work.
I have activated the zones A & B, I have tried both outputs A&B.
Can I check whether the HDMI outputs are dead? Is this a configuration matter?
What can I do to find the error and resolve?
Sorry, was so far happy but now I spent hours on the bug and cannot resolve it.
Asking for help
Thank you and kind regards


Add images

In that second screenshot, your Nucleus is just showing two audio devices (which you’ve labelled Nucleus and Roon Nucleus).

When I look at my ROCK/NUC - I’m seeing 6 devices (the Denon device has been renamed from the default “HDA Intel PCH HDMI 0” device)…

Now it may well be that Roon Labs have disabled the extra HDMI channels in the Nucleus BIOS, so let’s wait until the official Support team weighs in.

In your third screenshot, you have DSD Playback Strategy set to use DSD over PCM. I’m not sure that this works for Denon devices - you could try setting to “Convert to PCM” to see it that works for you.

Also, the Denon AVR X4000 has no MQA capabilities, so that should certainly be set to “No MQA Support”.

You could also try adjusting the advanced settings. Here’s what I have for my Denon 3800 (an older model, but these settings work for it):

Also - do you have a TV attached to the Denon? If all else fails - what happens if you disconnect the HDMI cable between the Denon and the TV? Does the Nucleus then give audio output?

Hi @Norman_Stuertz,

Can you please try plugging in the HDMI to a TV or Monitor and verify if there is sound output without the AVR involved? Have you tried a different HDMI cable as well?

Yes, this is expected behavior, extra HDMI ports are hidden on Nucleus. The two Nucleus and Roon Nucleus ports are indeed the HDMI ports as well, you can rename these to HDMI 1 and HDMI 2 if you’d like.

Thank you all - as I am in Europe we will have time lags inbetween. Will try today evening - your morning - and revert with feedback.

1 Like

Also in the avr setup you have to assign the avr hdmi port to an input, such as media player = hdmi2, or cd player = hdmi3 or whatever. Then select that device for playback on the avr.

Step 1:
Performed configuration of HDMI B according to Geoff’s hints („Convert to PCM”, set to “No MQA Support”.)

Step 2:
Also followed Geoff’s device set-up example.

Step 3:
Connected HDMI B output then to Front HDMI input (checked assignment in AVR), selected zone HDMI B as device in Roon, selected file on internal nucleus drive to play: no signal, no sound

Step 4:
Took alternative cable HDMI cable that is being used to connect Apple TV to AVR (so I am sure that this cable works for picture and music), connected this very cable to HDMI B output on Nucleus and MediaPlayer HDMI Input on AVR (works with AppleTV), selected HDMI B zone, selected file on internal nucleus drive to play: no signal, no sound.

Step 5:
Reconnected Apple TV, checked, audio & video signal arrives AVR back to TV (LG)

Step 6:
Took out TV HDMI cable from AVR as advised (note: TV HDMI is connected to ARC HDMI on AVR). Selected HDMI B zone in Roon GUI, connected from B to Aux 2 input HDMI, selected file on internal nucleus drive to play: no signal, no sound.

Step 7:
Changed to HDMI Output A on Nucleus, left on Aux 2 Input.Selected file on internal nucleus drive to play: no signal, no sound.

Step 8:
Went into Nucleus Set-Up in Browser. Used upper right hand software button to re-boot Nucleus (not the „Restart Server Software“

Step 9
After successful reboot, stayed on HDMI A output, stayed on AUX2 input on AV, selected file on internal nucleus drive to play, no signal, no sound. Went to AVR to cross-check cable inputs and outputs to make sure input is selected. All correct, walked back to laptop, suddenly with a delay of approx. 15 seconds music started to play.
Checked in ROON GUI, yes, the selected track is playing.
Suddenly hickups. Went away.

Step 10
Plugged in TV HDMI cable into ARC HDMI of AVR to see if sound signal keeps coming. Small hick-up, but continued.
Continued to listen to over several tracks, no more hick-ups.

Step 11
Switched to Tuner and other sources and back. Works. Switched back to AUX 2 using remote works - did not work with 3rd party app - but Nucleus signal is available.
Issue resolved

Only point is the audio return channel is now not working anymore but I think I can manage that, maybe that is the config item that creates the dependency.

Probably I could have re-booted after having followed Geoff’s hints.

For me this thread is closed now as Nucleus plays back via HDMI.

Geoff, Noris, R_Neal thank you for your support.
Have a good day.

1 Like

Hi @Norman_Stuertz,

Thanks for letting us know that the issue is resolved on your end, do let us know if you run into any further difficulties and we can take another look if so!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.