None of my Airplay devices work

None of my Airplay devices work.

Sonos One´s and HomePod is avalible as Zones, but when i try playing to the devices, the music don´t start, it shows the track, but the the statusbar don´t move at all.

If I play to the Sonos One´s via Sonos protocol, it works.

My HomePod have never worked, even back with 1.7.

I have 2 Airport Extreems(6.th gen) and and Airport Express (AC 2.th gen)

Other devices, 2 Bluesound Node2 works fine, and Sonos network via Boost works fine too.

It´s only Airplay that don´t work at all.

Hi @Jesper_Haastrup3

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

It sounds like the Sonos devices worked with Airplay previously, correct? Was there any change around the time that this started happening?

I haven´t been using Airplay before i got my HomePod.
I didn´t work with the HomePod, then I tried to Airplay to Sonos, and it didn´t work either.
And then I gave up on Airplay, and just played to Sonos via Sonos network.
And didn´t use my HomePod at all.
So Airplay have not worked from start.

Roon Core is running on my Dell Laptop (Latitude 5400, Intel® Core™ i5-8265U CPU @ 1.60GHz/1.80 GHz, 8GB RAM.)
Sometime direct connect via Lan to the first router, and other times via Wifi.
Roon 1.8 (783) 64bit.

Remotes are IOS devices iPhone 11 Pro and iPad Pro 12,9 (2. gen), latest version of Roon 1.8(783), and IOS 14.4.2.

Network is Fiber 500/500.
Fiber modem is in Bridge mode.
Router is Airport Extreme (6.th gen), extendet by another Airport Extreme (6.th gen) and a Airport Express (AC model 2.th gen).
Not in any way spotty wifi, 1 plan house 1442 square feet.

I have 2 Sonos One´s and 1 HomePod im trying to use via Airplay.

I have 2 Sonos Play1 and 1 Sonos Play3, since they are not Airplay devices, i use them via Sonos net.
I have a Sonos Boost to my Sonos net.

I have 1 Bluesound Node2, and 1 Bluesound Node2i, using RAAT.

I have no local library, I only streaming using Tidal and Qobuz.
I have no major problems with dropouts on my devices, most of the time it works.

It is “only” AirPlay that don´t work.

I have been trying disabling IGMP, didn´t change anything.

I have no problem using Airplay direct from my IOS devices to any of speakers, it is only via Roon it don´t work.

Did this just get ignored after the first response? Pretty much exactly describes my situation. I have a bunch of HomePod and HomePod minis. Roon recognises them all and lets me enable them but won’t play through any either grouped or ungrouped? Is this normal? I know there’s no Airplay 2 support but given it recognises/enables the devices I guess it’s expected they will work?

I have tried re-starting the HomePods, restarting the room core and restarting the Mac mini it’s running on. No luck.

I got no further support on this issue.

Unfortunately It is not unusual that support requests don’t get handled, I have see plenty cases where theres no further follow up by official Roon support.

But luckily other forum members are very helpful.

As I remember it, I never got my HomePod problem fixed, and I ended up selling it.

But my others AirPlay devices are working fine by now, but I can’t remember what I did different, I don’t recall any major tweaking of my setup.

This thread might help:

Thanks Dave, although it is not exactly clear to mean what it means to ‘group’ HomePods in this context. You can assign them to a zone, you can assign two to a stereo pair or you can create ad-hoc groups via the Airplay menu at playback time. There is not, as far as I know, formal grouping in the way you have with Google Home devices unless zones which are I suppose functionally equivalent is what’s meant. I do have zones so I can try and see what happens if I remove those.

I don’t have any HomePods, so can’t check, but my reading of the post I linked was that you need to remove any groupings (or zones) you created via the apple app then set up groups in Roon instead.

Are you using any of them as a stereo pair? If so, that’s more of a pain to deal with, but I think there’s a thread somewhere on the forum about how to get round the issue in Roon. I’ll find it again if you need it.

Might have been a bit of a doofus here. Had HomeKit settings for speakers set to “only people sharing this home” changing it to “anyone on this network” seems to have solved it.

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.