Not getting Artist Search results

NUC Rock, Roon v1.7, Build 555 Stable

Ethernet to NUC and Mytek Brooklyn Bridge, wifi to iPad

When I search for an artist, I only get results if the artist is in my library. Otherwise I get random albums that happen to have the artist’s name in the title. I’m sure this didn’t used to happen, and must be a filter I’ve set somewhere. As an example, I search for Kelly Clarkson and get a track as the too hit, and even when I click show all artists, still don’t get a hit. Then if I search for a particular song All works fine, and then when I click on the artists name from the track, the full Kelly Clarkson profile page appears.

Appreciate it if people can point out what I’m missing :slight_smile:


That makes no sense. She’s not in my library but she still pops up as the top result, and the first in the list of artists.

Does she appear as a composer?

Silly question - have you rebooted?

No, she doesn’t appear as a composer either.

I’ve not rebooted in case anyone wanted to complete any further tests or look at active logs. Probably reboot will fix, it works for 99% of tech issues :slight_smile:

I’ve not used roon for a while because the search had been too slow and the android phone app is terrible.

I decided to boot up my Nuc (running ROCK) today to see if the search time had improved. It updated and rebooted. I then searched an artist name :face_with_symbols_over_mouth: same issue as Nick_Tyson.

Search Pink Floyd: Top result is the album “Echoes by Pink Floyd” then artist list doesn’t contain Pink Floyd, but all other artists containing Pink Floyd in their name and the Album list is a complete jumble.

Have tried with both Tidal and Qobuz with the same results.

Come on roon! This is ridiculous. For such an expensive service to get the basics of searching an artist name wrong is unacceptable.

Back to using Squeezebox Server or Tidal app and casting to device.

I want to love roon but it just doesn’t function as well as it should. The developers need to pull their fingers out! Does roon have QA engineers?

As a work around you can select the top result (assuming it’s the correct artist) then select the artist highlighted in blue to get to where you want to be. It really shouldn’t have to be such a long process to get to an artist library though.

I get Pink Floyd as the top artist result, but I have them in my local library. If I search for Cage the Elephant then the top artist result is Cage the Olyphant.

It’s a repeatable bug and seems to be directly linked to whether the artist is in my local (nas server) library. I have both Qobuz and Tidal services.

I’m not currently using a local library at all with roon at the moment. Just Tidal, Qobuz and Live Radio. If I were happy with roon I would move my local library to it.

Can’t find the artists “The Streets” at all:


For the last few weeks the search function has been behaving oddly in that it will not find artists directly. When I search for Pink Floyd, Lou Reed, Leonard Cohen or the Sex Pistols, to take a few examples, one of their albums will be a ’Top result’ but they will not be listed in the ’Artists’ section. To find all their albums I have to choose the ’Top result’ then the artist. When I search for The Damned, an Iron Maiden track is ’Top result’ and again there is no listing of The Damned in the ’Artists’ section. I found them by searching for one of their tracks (Neat Neat Neat) which pops up as a ’Top result’ then clicking the artist name under the track. This is more cumbersome than it used to be or should be.

Is this a settings issue?

Thankful for help.



Where are you starting your search from?

I just went to the Overview page and searched for Pink Floyd and the search returned them ( as artist ) as the Top Result. I’m in the US and use Tidal.


Tried again starting from Overview - same result-


A post was merged into an existing topic: Artist search confusion

@Hans_Wikse Exactly the behaviour I see. However say I search for Nevermind the Bullocks, and find the album, don’t even click sex pistols as the artist, just open the album, click the three dots, choose add to library, then search for sex pistols, appears top of the list as artist.

Try that for any obscure artist, certainly for me, anyone not in my library cannot be searched for as an artist. But adding them to my library, not actually having them in my music share, is enough for artist search to work for that particular artist.

Here’s an example using an artist called Diplo and his new album Chapter 1:Snake Oil. Seemed appropriate for an audiophile forum :slight_smile: hopefully no one is triggered.

  1. search for diplo - nothing
  2. search for the album title - album found
  3. open album and add to library
  4. search for diplo - diplo found, full artist page displayed including all albums, not just the one in my library.


Hi Tim, thanks for helping. Do you have Pink Floyd in your library? If you do, could you search for someone not in your library, such as Diplo in my last example?

Thanks for the tip. I have also been able to work around the issue by picking the ’Top results’ album and then the artist or searching for a specific track.

This is however not the reason I subscribed to Roon (and purchased a Nucleus). It worked much better until a few weeks ago. It is very unsatisfactory.



I do have two Pink Floyd albums in my library.

I searched for Diplo and got an album not an artist as Top Result.

When I clicked on View All results I did not see a Diplo but I did see a D.I.P.L.O but searching for that returned an album as well.

I don’t have any albums in my library with an artist named Diplo or D.I.P.L.O


Thanks Tim,

From our small sample of 3 or 4 people, it seems none of us can search for an artist unless that artist is in our library. Feels like a bug, perhaps as simple as an AND statement instead of an OR somewhere in the code.

Hopefully we’ll hear back from Roon engineers to see if the problem is reproducible in their labs and when we might get a fix.

Hi everyone,

Our QA team has investigated these reports and we are seeing this issue as well. We have a ticket open with our developers and we’ll keep you all in the loop once we have a solution.

We appreciate the reports, and you have our apologies for the inconvenience here.