Now I need to reboot DAC on every startup

@support I hope you can help; this problem is frustrating.

I’ve been away for 1.5 months, and I likely let Roon update when I returned. I now have a problem where I never had one before my return.

I’m running Roon 1.5, Build 334. Roon Core runs on a Mojo-modified headless Mac Mini running 10.13.6 with 4TB external HDD, USB out to a PS Audio Directstream DAC. Roon Server runs on any of a number of devices – iPads, iPhones, MacBook Pro, iMac27.

Previously I’ve never had a problem on startup – I’d power everything up, and start playing without an issue.

Now, every time that I plug in and re-start the system (frequent lightning here), when I start Roon Server it asks that I Select An Audio Zone. Previously, Roon always defaulted to my usual, last-played zone. Now this prompt happens on every startup, no matter which Roon Server app I’m using, as though Core just doesn’t keep track of my last-played zone or ‘default’ zone.

So, I choose that audio zone and select music from Roon. Everything looks good, but no sound comes out of the speakers, although everything appears to be okay. Roon shows my selected Audio Zone, the track playing, the scrubber and graphic display moving, etc. Just no sound.

To fix this problem, I turn off the power switch on the DAC, give it a few seconds, and restart. After that second boot of the DAC, I’m prompted by Roon to Select An Audio Zone (as before), I select a track or playlist, and this time I get sound. I’ve tried bringing components up in various combinations, but the result is still the same: Every time, I have to boot the DAC twice in order to get it recognized by Roon.

At least it works this way consistently, but it is a pain.

Nothing has changed in my hardware config, nor in the DAC’s firmware. The only difference between now and then is a likely update to Roon… I can’t recall if I updated Mac OS when I returned.

I have screen shots if that would be helpful.


Thanks for sharing your report with us, @Rob_Hanson!

So we can better understand the behavior you’re experiencing, please verify the following:

  • Can you confirm that the PS Audio Directstream DAC is on the latest firmware version?
  • Can you confirm that all of your remote devices you are using are also up to date?
  • Does this behavior happen with other endpoints, or just the PS Audio DAC?



Thanks for the quick reply.

1 - Yes, RedCloud 207. I believe this to be the latest.
2 - Umm, nope. Updating now and will post results when done.
3 - My only endpoint is the PS Audio DAC.

Additional: This happened on my iMac27, which HAS been updated.


Okay, all devices have been updated to the latest software. The Mac Mini (Core) was fine, as was a Mac27 (Server). iPads and iPhones have all been updated.

Same pathology, exactly. I have to boot the DAC twice on every startup.

One possible clue: The DAC displays the sample rate of the incoming USB connection. Usually, before I play something, it shows up as PCM 44.1K, 16 bit, and changes to a higher sampling rate when I feed it a signal from Roon with DSP.

On the first boot of the DAC, although everything appears to in working order, there is no sound, and the sample rate remains at 44.1/16 on the display… as though it’s not receiving any signal from Roon off the Mini. After I boot the DAC for a second time (without touching any other equipment), when I start Roon, the sample rate changes and sound emanates from the speakers.

I have even tried various combinations of bringing up the gear… DAC first, Mini first. Makes no difference.

At least this issue is perfectly repeatable.

Please let me know if I can provide more info.

Thanks for the details here, @Rob_Hanson!

I’d like to get another piece of information here that should help further narrow this down.

Can you try using the System Output on one of your remote devices after rebooting? When doing so does it exhibit the same behavior as the DAC?



Okay, I set the endpoint to the headphones on my iMac27, verifying that music played through from the Mac Mini. All good.

I shut down both the DAC and the Mini, then restarted them.

Roon came up “defaulting” to the headphones endpoint, and started playing music through the headphones as soon as I hit Play. However, the PS Audio endpoint failed to play.

I’ve worked this experiment several times, each time with the same result:

  • The headphones zone will play on the first try, every time.
  • The PS Audio DAC requires a reboot (takes about 1+ minute), then it will play.
  • Once both outputs are playing, I can switch back and forth freely, or play both simultaneously without issues.

I’ve done the experiment both with shutting down the Mini and the DAC, and also leaving everything up except the DAC for its reboot cycle. Consistent results.

Bottom line is that for the PS Audio DAC to play, I have to boot it twice. Once I do, everything is fine.



Thanks for giving that a try, @Rob_Hanson!

Next, I’d like to propose a test:

When the DAC is in this state where you cannot play to it from Roon, are you able to play to it from outside of Roon, using other applications?


Interesting question, @dylan

I’ll give it a go as soon as it stops thundering.

1 Like


The answer is “yes”, I am able to play from outside of Roon on the first try.

I started everything up from cold, and fired up PureMusic/iTunes. Immediate success.

After confirming this, I started Roon and pointed to the PS Audio DAC. No sound.

I rebooted the DAC, sound.

Thanks for confirming that for me, @Rob_Hanson!

Moving forward, I think we should try using this DAC with a fresh RAATServer folder. Please see the steps below:

  1. Create a backup of your Roon database
  2. Shutdown Roon
  3. Locate your Roon database according to these instructions
  4. Rename the entire RAATServer folder to RAATServer_Old
  5. Relaunch Roon

Try to replicate this behavior after this and let me know if you see any change.



Working on it.

[Edited] I did find a RAATServer folder on one of my Server machines, the iMac27. Only RoonServer on the Core Mac Mini, though.

However, I don’t have a RAATServer folder. I do have a RoonServer folder, though.

Should I rename that one as per your instructions?


Okay, I changed the name of the RAATServer folder on the iMac27, and did not change the RoonServer folder on the Core Mac Mini.

Initial results seem good.

When I started up the DAC, it immediately showed the higher sampling rate, not the 44.1/16 that I had been seeing. Music played on the first attempt, although I did have to select the PS Audio DAC Audio Zone.

I’ll next try this a number of times to see if the behavior is consistent.

I’m working on the assumption that I’ll have to rename the RAATServer folder on each server device. Is that correct? I’m not sure how that might be done on iOS devices, though. But, I can change the folder name on the MacBook Pro as well as the iMac.


Update: Initially I thought I had a good result, but having tried the renaming of the RAATServer folder a couple of times, it still hasn’t solved the problem.

Earlier, I think I had a good result because I didn’t necessarily power everything down. Either that, or the folder renaming worked the first time, but not on other power-down/power-up cycles. I’d have to double-check that.

In repeated testing, if I bring the system up from cold (i.e., reboot the Mac Mini, reboot the DAC), the DAC will only work when it is restarted twice.

So I’m pretty much in the same boat as before: If I power up the system, I always have to start the DAC twice to get any sound output, which, from yesterday, we know is only when playing Roon, not PureMusic/iTunes.

Hey @Rob_Hanson,

Thank you for giving that a try, I appreciate it!

Just to clarify, did you change the RAATServer folder on the Core machine (the Mac Mini)? This is the only machine where this would need to be changed.

In order to better understand the root of this issue, I’d like to propose a couple of tests. These tests will give us some great data about what exactly is happening here.

Test 1: DAC connected to a remote

In your initial post:

Just to clarify, the Mac Mini is your Core machine running RoonServer, and the other devices are just remotes that connect to your Core, correct?

If you connect the DAC to one of the other devices, like the MacBook Pro, are you able to replicate the same behavior with the DAC? This test will allow us to know if this only occurs when connected to the Core machine, or if this behavior happens on all machines.

Test 2: DAC on new Core

If you’re able to replicate the behavior in Test 1, then I’d like to propose another test. Temporarily use one of the remote devices as a Roon Core. Connect the DAC to this device and try to replicate the behavior. Does this behavior still occur even with a new Roon Core?



The test I did earlier may be null and void. As mentioned a few posts above, I could not find a RAATServer folder on the Core machine. I only see a ROONServer folder in Library on the Core machine.

My question is/was: Should I try deleting that? And why is there no RAATServer folder on the Mac Mini?

I only renamed the RAATServer folder on the iMac27, which is NOT the Core machine.

Let me know if deleting the Core’s ROONServer folder would do anything. If so, I’ll re-run the tests before diving into your new tests.



To clarify – and I may be victim of terminology here – the Mac Mini is the Core machine. All other devices are just remotes that connect to the Core.

Hey @Rob_Hanson,

The RAATServer folder should be located in the same directory as the RoonServer folder on the Core machine. You should be able to find it by doing the following:

  • Open Finder and click “Go” in the top bar.
  • Hold down the Alt key to unhide the “Library” folder.
  • Click the Library folder.
  • Find and rename, RAATServer folder.

Are you not seeing the RAATServer folder anywhere in your Library directory?



Get ready to hear the sound of a double forehead palm smack…

I was not previously able to find the RAATServer folder on the Mac Mini, because:

  1. Normally I have folders arranged by name automatically. Evidently, not in this case. I found it out-of-order, and it fell into place when I did View > Arrange By Name, and

  2. It didn’t show up in a Spotlight search because (drumroll please…) I turned Spotlight off in order to reduce system overhead.

Folder renamed, and will post the results shortly. Tttthhhwack!


Sadly, renaming the RAATServer folder on the Core machine did not work. The system still has the same pathology.

It will take me a day or so to get to work on your other two tests.

I’m not 100% clear on the request, though. In Test 1, if I wanted to connect the USB-out to the MacBook Pro, wouldn’t I need to be running Core on that MacBook Pro? Or, can I set the output from the Mac Mini (running Core) to go through the MacBook, somehow? We know that if I connected the DAC to the MBP and played something like iTunes, it would work, so Roon does have to be involved.

As for Test 2, that would require that I install Core on the MBP, correct? Perhaps that’s not too involved if I don’t have to scan my library.

Thanks for trying, @Rob_Hanson.

You can play to the devices connected to remotes. Take a look at my screenshot below. I’m using a PC as a remote, but my Core is a ROCK device. I can still play to the devices connected to my PC even though it’s not the Core.

For this you shouldn’t need to install anything. Since you already have the application installed you can go to Settings > General > Disconnect and choose to run that Mac as a Core instead of using it as a remote. You can then use a small sample of local content instead of importing your entire library so you don’t have to go through full analysis.