Nuc+ won't boot consistently

Roon Core Machine

Nucleus+ running OS 1.0 Build 227

Networking Gear & Setup Details

Ethernet plugged directly into Linksys 1900AC router
Previously had it routed through a Netgear GS105 switch to the router

Connected Audio Devices

USB to Auralic DAC

Number of Tracks in Library

1500 tracks

Description of Issue

I had my stereo shut down for the last month. Today I tried to bring up the NUC but I could not connect. I put a monitor into the HDMI port and after several manual reboots, I did get it to show up.

I started up Roon but got a message that “there was an issue loading the database”. I tried to reboot from the Web UI but it failed to reboot. I have tried several more manual reboots but no connection.

I have noticed the power LED flashes off after I reboot between a few second to almost a minute. I have also seen it flash off sporadically. I measured the (stock) power supply, it was 19.5V.

Hi @rcaudio ,

Errors like the one you’ve seen now are signs of low level corruption in the database. This means that the records Roon is reading from your database are different from what was originally written. This can happen for a number of reasons, like failing hard drives or an unstable power source (frequent outages, hard power cuts, etc).

We’re sorry you’re experiencing this extremely rare error: not only is our database infrastructure designed specifically to prevent this type of corruption, but starting with Build 880, Roon detects database corruption “on the fly”. So if corruption is detected during a backup or during normal use of Roon, you’ll be immediately prompted to restore from a backup.

What’s Next?

Install Roon fresh on your Core machine and rolling back to one of your older backups. You can use these instructions to do so:

  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Core” and connect to the new database
  • (Optional) - Restore your database from a Backup prior to the issue starting

If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

If you do not have any backups, unfortunately, the only other solution is to start with a fresh database. If you live in an area prone to power outages, it is also strongly suggested to use a UPS supply to prevent power outages from affecting the Nucleus functionality.

I managed to get access to my NUC+,re-installed Roonserver and connected to a new database. It immediately rebuilt my library and is now analyzing the tracks. Couldn’t quite figure out how restore an old database. It looks the only thing I may need to do is set up scheduled backups again. It kept my import settings, though I’ve cleaned up some album and track associations over the years, not sure if they’re intact.

@noris

Well drats. I shut the unit down from the web console, it ran for 22+ hours. I moved it back into my system and now can’t get access. I put a monitor on it and it doesn’t see a signal. I tried several manual reboots. I guess this is pointing to a hardware issue?

I unplugged the unit, let it sit, plugged it back in and pressed reset. Then I let it sit for several minutes and now it’s running. How long does it take to boot up? I thought it was pretty fast. Given the state of things, are there any diagnostics to see what the health is?

Hi @rcaudio ,

Sorry for the slow response here, things have been a bit hectic with the 2.0 release. I am looking over diagnostics and I see that you’ve updated as well, has there been an improvement in behavior since you’ve taken the update? I looked over your Nucleus system logs and I’m not seeing any significant errors. Do you live in an area prone to power outages or something similar? In any case, do let us know if you encounter further issues.

Hi @noris, Everything updated without a hitch and is running solid. We don’t get many power outages here and if the weather looks like a big storm coming, I usually shut everything down and disconnect the power from my stereo. I am thinking maybe when I did that earlier this summer that it got corrupted somehow.

How long should it take (approx.) when you restart the unit to boot up and be running? It seemed to take much longer last time I started it than I remember it used to.

1 Like

Hi @rcaudio ,

Glad to hear there was an improvement! Roughly 30s - 1min is the typical boot time for my medium-size library.