Nucleus and Drobo


(lancestern) #1

I will be switching over from a Mac Mini to a Nucleus+. I currently use an older 2012 Drobo DRDR5-A running version 2.5.2 as my NAS, will that be compatible with the Nucleus?

Thanks!


Nucleus storage options and SQ
(simon arnold) #2

As long as it’s shared over smb then it will be fine.


(lancestern) #3

Please forgive my ignorance, what is SMB. I just plugged the Drobo into the Nucleus+ via USB 3.1 cable as the only other port out of the Drobo is a Thunderbolt (which the Nucleus doesn’t have).However, I can’t get the Nucleus to see the Drobo. Please advise.


(simon arnold) #4

Drobo is not a NAS but raided storage so very unlikely this will work being plugged in as Nucleus does not support RAID discs to my knowledge. A NAS storage is connected to via a computer network, hence the name NAS (Network Attached Storage). SMB is the file protocol used by most NAS devices to share the storage over a network… Most devices support smb to some extent.Nucleus supports plug and play USB discs and Network storage, To make this work you would need it attached to you mac mini still and shared over the network.


(lancestern) #5

Thanks for responding, So I plugged that into my iMac and tried to SMB to it. Having problems. I tried to find a network folder in Roon and typed smb://iMacipaddress/Drobo but Roon doesn’t find it. Suggestions?

Thanks


(simon arnold) #6

Have you shared it in macos? Sorry I don’t use Mac’s so no idea how you make it a shared folder.


(lancestern) #7

Thanks Simon,

I wonder if there is someone from Roon who can help with this? I’m kinda stuck here.


(simon arnold) #8

On the nucleus you’ll likely need to use this method \\ipaddresofmac\ followed by the shared folder . You need to enable samba shares on the folder itself in macos. A quick Google reveals this https://support.apple.com/kb/PH25346?locale=en_US


(Mike) #9

Hey @lancestern – long time no speak! Hope all is well with you.

I know @steve has spoken with GTT about this issue, so I’ve split your post off here, and I’m going to make sure someone from @support gets this resolved for you.

Sorry for the trouble Lance!


(lancestern) #10

Thanks Mike, Great to hear from you! yes, it’s been a very long time.
Please let me know if you need me to do anything.

LS


(Noris) #11

Hello @lancestern,

Thanks for contacting support, I’d be happy to assist here. Does the Drobo show up at all when trying to find it in Roon Settings -> Storage -> Add Folder -> Sidebar? I would check here first before pursuing the other options of adding it to the system:

If it does not show up there, can you please let me know the model/manufacturer of router you are using in your setup? Does it by any chance have a USB port that you could attach the Drobo to?

Thanks,
Noris


(lancestern) #13

H

ello Norris,

The sidebar is empty when it when I select add folder.

I am using an older Apple AirPort Express Base Station Model A 1264
And yes it has a USB port.

Thanks

LS


(lancestern) #14

Norris,

I have plugged the Drobo directly into the AirPort and nothing changed.

Thanks again,
LS


(Noris) #15

Hello @lancestern,

Thanks for providing the screenshot and letting me know that it does not show up when connected directly to the Nucleus. We generally recommend against using Airport models for mounting external Hard Drives in Roon since we have often seen instability when mounting through them using SMB.

Would you by any chance have another “always-on” computer that you would be able to leave the Drobo connected to such as the original Mac Mini? If you are able to leave the Mac Mini connected and online to access to your Drobo when you use Roon, then you can follow these instructions as to set it up as an SMB share.

I can walk you through the steps if you need clarification, just let me know if this solution is suitable.

Thanks,
Noris


#16

Drobos are a bit wonky (the non-Ethernet variant, anyway). They present themselves to the host OS as a USB mass storage device. However, they only support two filesystems: NTFS and HFS+. This is because they ‘snoop’ the filesystem metadata to determine what blocks are in use for their logical to physical mapping layer. They don’t support Linux filesystems like the various versions of ext, or xfs, etc. (Maybe they’ve added that in newer versions – I haven’t checked. But they are sold as consumer RAID units targeted at Windows/Mac users, so I wouldn’t place my bets here…)

Depending on what filesystem drivers the Nucleus has installed, you MIGHT try formatting the Drobo as NTFS using a Windows system and then connecting it to the Nucleus’ USB port. I believe the Linux NTFS driver supports read/write. The Linux HFS+ filesystem driver is read only, or at least it was last time I looked into it (years ago).


(lancestern) #17

Noris I connected the Drobo to my iMac which is my always on computer the next room to the Nucleus+ I followed the instructions and it tells me “can not connect to share: Unauthorized”

I await further instruction. Perhaps we need to spark about my wireless set up…

Thanks

LS


(lancestern) #18

OK Noris, I was able to add the Drobo file to the Nucleus, it is scanning “as we speak.”
I assume this will take some time, as in 1/2 an hour it’s only imported 12 tracks and scanned 600, does that sound right?

Thanks again for your help.

Lance Stern


(Noris) #19

Hello @lancestern,

Glad to hear that you’re up and running with the Drobo on your Nucleus (although it is still importing files).

We have previously seen some underwhelming performance with Drobo devices and Brian mentions this in one of his posts:

I would leave it overnight to see if it successfully completes the import, although you may want to upgrade from the Drobo if you’re looking for better performance here and have a large music library.

Thanks,
Noris


(lancestern) #20

Thanks again, I agree this is crazy, I’ll have to figure out another storage option. It’s been over an hour and it’s transfer 135 Tracks… it’ll take a year at this rate.
Thanks again for the support


(system) #21

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.