Nucleus and USB DAC problem?

Hello @Woo,

Thanks for your patience here. I had a meeting with the team today to discuss your report and wanted to reach out with their feedback. The team has been investigating the Linux support of this DAC and are hoping you could perform a test to see if there is any change in behavior here. Can you try limiting bit depth to 16 bits + sample rate to 1x and see if there is any change?

Thanks!

Thanks for getting back @dylan

Not sure I understand. Do you want me to change the settings in Audio devices in Roon’s menu?

In the menu I can see ‘Max Bits Per Sample (PCM)’ where I could change it to 16 bit. It’s currently on 32 bit.

Not sure what you mean by 1x sampling rate. Can’t see that option on the Roon menu.

Please advise.

Your issue sounds the same as I had with my Allo USBridge and Arcam Dac, it would crash the dac when switching to 44.1/24 from all other sources especially if it was a lowres aac being upsampled by Roon.

The way I got around it was to have upsampling enabled in DSP settings, so all material was upsampled to the same bit depth and frequency. i choose Max PCM Rate (power of 2) as I don’t have DSD files. But if you do you could try upsampling all to DSD rate that will fix the switching issue but you might not like all files being upsampled.

Support still have still not worked out the issue for me as it is Roon related as did not have the same issue using MPD on the same system. I.ve given up with USB all together now as its just to problematic on linux.

@CrystalGipsy

That’s funny, because I thought that by using USB I’d be avoiding any network related issues. And with my Nucleus wired directly to the router I thought I must have the simplest and therefore least problematic setup.

I do play a lot of DSD files because I was a big enthusiast for SACD for many years and recently learnt how to rip them. It was doing that which made Roon am option for me.

My Sony DAC has a lot of upsampling options, including DSD256. But if I set Roon to output only DSD I’ll end up remodulating my DSD64 files to DSD256 so as to retain native playback of my DSD256 downloads. I’ll have a look in the menus and see what happens.

Its nothing to do with network, its likely linux drivers for your dac are not fully developed, the Nucleus is Linux based so dependant on what Sony do in the drivers for Linux. I bet its far more stable on Windows than Linux.
You can configure upsampling to not upsample DSD at all and leave them as is. So just set it to upsample PCM to DSD and DSD as passthrough examples below and see if it makes it more stable.

1 Like

@CrystalGipsy

Thanks Simon, great tips there and fascinating to learn more about the DSP settings! I’ve now set all PCM to output at DSD64, and left my DSD files to play unadulterated in their native format. Thank you. Maybe this will work and no more crashes?

I didn’t mean to suggest that there was a network issue here, I was trying to indicate that by using USB I knew I’d be sidestepping any possible network issues. What I hadn’t considered was the possibility of USB issues! :grinning:

It’s a bit of a shame to not use my Sony DAC for the PCM > DSD conversion as that’s how I have done things up to now. I previously had my Sony set to upsample PCM to DSD256 as its made to do that job. Will my Nucleus be up to the task in terms of computational power? I noticed it said on the Singal Path screen that during playback of 16/44 files it was working at 1.3 processing speed when upsampling to DSD256.

If your only running one zone upsampling then you should be fine as long as it’s over 1. If you find it has issues then try at 128. DSD upsampling intensive. Other option could be to set it to max pcm rate so for 44.1 that would be 352.4 for 48 then 384 depending its a floating point or integer to start with. This doesn’t require as much processing.

What model is your DAC by the way?

Sony TA-ZH1ES.

Just noticed a weird issue that’s happened twice today, for the first time ever.

When I wake up the iPad after having played quite a few songs, instead of showing the current playing track, it shows the one that was playing the last time I had the iPad on, then suddenly races through the tracks that have been played since then. You can see the red line racing through the frequency waveform, then onto the next track, then the next etc. Ultimately it arrives at the current track. Throughout this process the music plays as normal. This has never happened before.

Is that since you started with upsampling?

No, happened both before and after trying the up sampling.

Ok it’s not that then. Likely a glitch that’s not updating to ipad for some reason. I had my ROCK pc do something similar the other day. I.played some music and it appeared to play fine but It was not updating now playing. It was displaying music i played the last time I used it and the controls where greyed out as if it was not playing. I ended up restarting the Roon server via the webgui. Been fine since. Perhaps try this

Also another thing for upsampling try experimenting with the filters it uses to see if you prefer one of the other. You can also parrelize the sigma Delta processing used for DSD which will use both cores of the Nucleus, it’s useful if you have only one endpoint running at time and will up the processing speed abit.

@Woo just wondering if things are working better for you with upsampling?

18 posts were split to a new topic: Question about Dropbox backups

A post was merged into an existing topic: Question about Dropbox backups

I USE THIS DAC too, also still no driver on linux… only can use dop…