Nucleus cannot locate iTunes after moving to a new location

Core Machine (Operating system/System info/Roon build number)
Nucleus OS 10.14.6
Roon Version 1.7
Build 528 stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Pakedge RK-1 Router and Pakedge SX-24P Switch Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
iTunes stored in Drobo 5N2 NAS

Description Of Issue
My iTunes library was stored on an external device, but it was pointed there from my home folder. The folder, with Apple’s help, was moved to the Drobo 5N2. There is an.itl file located there. The old file name was \MIKESiMAC.local. The new network share name is /Volumes/Drobo5N2/dra171802300186/1/iTunes/iTunes/iTunes/iTunes Music.

When I try to add a new network share in Edit Storage Location / Choose Music Storage @ Network Share Location I receive a message: There was an unexpected error: UnexpectedError

Hi @Mike_Crosby,

Welcome to the forum!

Is the Drobo attached via USB to your iMac? If so, you’ll want to use this guide to set up a Mac share over the network to add to the Nucleus.

Hi - no - it is connected via ethernet.

Hi @Mike_Crosby,

Thanks for confirming how the Drobo is connected. In this case, you need to specify the SMB address in Roon. It looks like you might have the Drobo mounted as a share on your Mac. You can add the Drobo by finding it’s SMB address and then following the convention listed in our Add Folders By Path guide:

Content Stored On a NAS Drive

  • To add network storage, we recommend using your NAS drive’s hostname, such as \\DISKSTATION or smb://MyNASDrive . You can usually find this information by logging into your NAS., and examples are below.
  • You can also use your NAS drive’s IP address, but note that this can change, depending on your network’s settings.
  • Note : AFP Share are not supported, you must use SMB or hostname to connect to the NAS share. You can find more information about why AFP is not supported here.
  • If you are still having issues with setting up the NAS share, further suggestions can be found in our NAS Troubleshooting FAQ


  • If your Roon Core is running on Windows, the path to your networked folder might look like this:


  • If your Roon Core is running on Mac or Linux, the path to your networked folder might look like this:


  • After you’ve entered the network path in Roon, enter the credentials required to access your NAS. If a username, password, or workgroup isn’t required to access your NAS, just leave the relevant fields blank and click Add Folder

Hi, I spoke to Drobo - they wanted me to use a .atp link rather than smb. I tried that - it didn’t work - so I substituted smb and it seems to be working. This is what I am using: smb://iTunes/share.local
At least, Roon is indicating that I am adding my files I see Adding…with the Roon symbol beneath it moving to indicate progress…
Here’s my question: I have around 1TB - 48,000 songs. Using my ethernet connection, how long should it take to link my iTunes library to Roon? Assuming the link is actually happening?

Hi @Mike_Crosby,

Can you share a screenshot of your Roon Settings -> Storage tab? As far as I know, smb://iTunes/share.local is not a valid SMB address. Roon should the amount of tracks imported in the Storage tab.

Hi @Mike_Crosby,

Thanks for the screenshot. It says that the directory is not available, can you let me know how you had this working previously?

AFP shares are not supported in Roon,’m_having_trouble_setting_up_my_NAS:

Regardless of what kind of device you’re using, you’ll want to make sure that the following is true:

  • The folder is allowed to be accessed via SMB
  • Your username and password should not contain any special characters
  • Use SMBv3 when possible. Failing that, SMBv2 should also be ok, but do not use smb2 with large mtu as it has known compatibility issues with Roon. If you’re using a Synology NAS and running your Roon Core on OSX, you can find some more information about fine tuning your setup here.
  • Don’t enable AFP or Timemachine if possible – some users may need this functionality for other applications, but they’re not needed for Roon. You can find more information about why AFP is not supported here.

You should locate the SMB address for the Dropbox, typically it looks like the IP address of it and the folder name like so smb:// and enter this in Roon.

Hi Noris, First - here is the actual, current location of my iTunes library (iTunes Media folder location):

/Volumes/Drobo5N2/dra171802300186/1/iTunes/iTunes/iTunes/iTunes Music

In the past, the library was located in an external library - but it was pointed to that location from the main system - that is the location you see (again, not the actual location where my home theater company set my system up. I have now moved the entire library to the Drobo 5N2 for many reasons. It is a NAS, of course. Hope this helps.

Hi Noris, Here is a screen shot of the advanced info from iTunes. You can see that I have checked "share iTunes library XML with other applications

Hi @Mike_Crosby,

How is the Drobo communicating with your Mac? This part is still not clear. On the Drobo itself, do you have the USB port connected to the PC or only the Ethernet cable?

Are you mounting the Drobo location as a virtual drive in your MacOS? If you are mounting it as a virtual drive, you may want to look over this guide.

Hi Noris Drobo is a network device. It connects to my iMac via ethernet. As you can see, my system see it on my network, just as it sees nucleus.

Hi @Mike_Crosby,

Thanks for the screenshot. It looks like the iTunes is a mounted folder, if your right click on it under “Locations” do you see any additional information about the share? You will need to find out the SMB mount address for it and add that to Roon. Or you could use the guide I mentioned in my last post to share the Drobo via your Mac, but it would require your Mac to be powered on for the Nucleus to access the location.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.