Nucleus: Connection lost! ... a Roon server issue?


no matter how I try to connect to my Nucleus, after a short short time I get a “Connection lost!”. The music stops playing and the remote software stops working or even crashes.
I’ve tried this with several iPads, an Amazon Fire Tablet 10 and 2 Macs, via WLAN and hardwired.
Connecting the Nucleus directly to my router (I usually have a switch in between) leads to the same results.

Yes, I turned everything off and on again (the Nucleus, my router, my iPads, the Mac etc.)…no change.

The System Status Website shows me that everything is okay…BUT: there seems to be an issue with the Roon server. While the Operating System and the Roon Software are running for more than an hour now (since I last rebooted the Nucleus), the Roon Server shows something like 30 seconds. If I reload the website after a few minutes (without touching the Nucleus) I get a running-time like 20 or 40 seconds, as if the server restarts constantly.

So I stopped and restarted the server and reinstalled the software…no change.

Any idea what I can do???


Updating to 1.8 (build 911) didn‘t help. The Roon server software still seems to crash and restart. I think I need help from @support.

So Roon Server is restarting frequently.

How is your music stored locally?

When did the issue start?

Have you made any additions or changes to music stored locally?

This issue can sometime be caused by a corrupted jpg, playlist or music file that Roon Server chokes on. Did you add anything just before the problem started?

Roon will need to look at your logs to determine the cause of the issue.

1 Like

My music is stored internally on an SSD. All I changed during the last days was adding some Qobuz albums to the Nucleus. Everything seemed to be alright. I‘m not using the Nucleus daily, so it’s hard to say when the error occured.

Hey @MatDe,

Thanks so much for getting in touch to let us know of the issue, as well as the many steps you’ve already tried to remedy the issue — we’re grateful :pray:

If we may ask a few questions:

  • During this time when it is restarting are you able to access the Nucleus Web Administration Interface ?
  • Are you using the standard power supply that came with the Nucleus or something else?
  • Is the Nucleus in a well-ventilated place?
  • As a test, could you please log out of Qobuz and see if the issue occurs without the Qobuz service enabled?

Thanks :pray:

Hey @beka

thanks for your help. Here are my answers:

In general I can use the Web Admin Interface. The restarting of the server seems to happen very quickly. When I’m using the remote software and get a “Connection lost” warning I immediately go to the Web GUI and reload the site. Then I can see, that only the server software is running for just a few seconds.
If I leave everything as it is and come back later the Nucleus already shut down. This is new.

I’m using the standard power supply that came with the Nucleus.

The Nucleus is in an absolute well-ventilated place.

I logged out of Qobuz. About half a minute later I had another “Connection lost” warning.

Hope this is helpful.

Hey @MatDe,

Thanks a lot for sharing answers to all of my questions :bowing_woman: .

It looks like since you post until now, your Nucleus isn’t reaching our servers, so as much as we wanted to, we couldn’t grab logs to see what might be happening.

Could you please help us out instead? Would you please:

  • reproduce the behavior and write down the local date and time when the Nucleus restarts
  • get a set of logs, zip up the entire logs folder and upload it here

Many thanks :pray:

Hey @beka,

the last time I lost connection to Roon (and the Roon Server restarted) was 3rd March at 3.36 p.m. UTC+1 (I live in Germany).

I uploaded the logfiles (the entire logs-folder). Thank you for providing the link.

Meanwhile everything is updated to “build 913”, but the problem persists. I’ll try to keep the Nucleus online, just in case you need more data, but I can’t promises it stays like this, as the Nucleus is shutting down after a while.


1 Like

2 posts were merged into an existing topic: Roon Server crashing repeatedly

Hey @beka

more than a week has passed and I haven’t heard from you or @support. Are there any new insights that could make my Nucleus useable again?
Thank you!

Hey @MatDe,

I’m really grateful that you’ve followed up — right in time, as I just heard back from our technicians. Thank you for your patience :pray:

The logs you’ve sent us have confirmed one thing: crashes are happening. However, they are not conclusive as to why.

I wonder, could you please help us continue the investigation by turning on the Nucleus and leaving it on for a couple of hours. If it connects to our servers (:crossed_fingers:) we can obtain more specific information about the cause of the crashes :nerd_face:

Hey @beka

I turned the Nucleus on and will keep it on until at least tomorrow. I have to check from time to time because the Nucleus seems to turn off after a while.


Hi @MatDe ,

I can confirm logs came in from the Nucleus, you don’t need to leave it on longer for the time being. Our QA team will look over the logs and we will get back to you once we have more info, thanks!

1 Like

Hey @noris,

okay.Thank you.


Hello @MatDe ,

Thank you for your patience while I had a chance to consult with the team regarding your case. It looks like your Nucleus is running out of available memory, but it is not clear as to the reason why.

If you temporarily disable all your local storage locations under Roon Settings → Storage, can you please confirm if the same behavior occurs with only TIDAL/Qobuz content enabled?

Please let us know when you have a chance, thank you!

1 Like

Hello @noris

I just tested it. Unfortunately the problem persists.

I disabled local storage, which is just my internal SSD, and streamed my Qobuz content…after less than 10 seconds: connection lost.

Then I rebooted the Nucleus and tried the same again (still with disabled storage). Same result.


Hi @MatDe ,

Thank you for confirming the issue still occurs without the storage active. I would like to kindly request your Roon database so that we can test it further in the QA lab, can you please use these instructions to upload a .zip/archive of your entire Nucleus RoonServer folder? You can locate instructions on how to achieve this here:

Please upload the archive to this folder and let me know once uploaded, thank you!

Hi @noris ,

I just uploaded the file. Thank your for your support!

1 Like

Hi @MatDe ,

Thanks for sending the database over, I’ve forwarded it on to QA for closer inspection! We will let you know as we have more info to share, thanks for your patience while we look into this.


@MatDe, we have a theory as to what is going on here and would like you to try something if you are willing. This won’t impact your library in any way or otherwise make a bad situation worse.

  1. Go to the Nucleus admin webpage and stop RoonServer
  2. Connect to the database storage on your Nucleus by connecting to \\NUCLEUS\Data (windows) or smb://NUCLEUS/Data (mac)
  3. Navigate to RoonServer -> Database -> Orbit
  4. In that folder you will find three subfolders. Delete the one named orbit_v3.db
  5. Start RoonServer back up via the admin webpage

This will reset an internal housekeeping system which may be misbehaving.

Please try the above and let us know if it makes an improvement.