Nucleus+ is visible on network only via USB-Ethernet adapter

Hi everyone (@support)!
I’ve got an issue when I connect LAN wire from Nucleus+ ethernet port to ethernet port on my switch or Apple TimeCapsule. Nucleus+ is invisible on network, I can’t go on web interface or connect it via Roon APP, but when I use ethernet to USB adapter it works fine.
I use SET of Satechi USB TypeC to Ethernet adapter and USB TypeC to USB2.0 adapter
When it connected through this SET it gets these settings

My network setup:
internet goes to apartments to local provider OEM Router, then goes to Apple Time Capsule (which use only for WiFi) then goes to the switch TP-Link 8 ports (unmanageable).
Nucleus+ doesn’t work if I connect it ethernet to ethernet in both ways: to Time Capsule or to the TP-Link switch.
Nucleus+ works only with SET.

when Nucleus+ is connected to router via LAN it works and have DHCP IP, I don’t need to use SET
BUT I need my Nucleus+ near HiFi installation place (AV receiver, DAC etc).
I tried to reboot switch, OEM router, Time Capsule, Nucleus+ (except Roon Database & Settings on Nucleus+ web interface) but no result.

Serial #94C691158CD

I purchased it in Switzerland

music is stored on Nucleus+ I use SSD 2TB. It’s 86% empty. I have reservation copy on another disk.
I use Roon app on Mac mini (Mojahe 10.4) and iOS devices

Hello @Vladimir_Tereshchenk,

Thanks for contacting support, I’d be happy to assist here. I have a few questions starting off:

  • Can you please let me know how your Roon Remotes are connected in this setup?

  • Which device is providing the WiFi for the Roon Remote, the Apple Time Capsule or the OEM Router?

  • Do you by any chance have the same WiFi name on the OEM Router and the Time Capsule Router and the Remotes are possibly connecting to the OEM Router?

  • How is your Ethernet 1 settings set up? Are you using DHCP or Static IP? Is the interface enabled? Can you please provide a screenshot of the Ethernet 1 settings?

  • If you connect both your Mac Mini Remote and the Nucleus to the same TP-Link switch, is the Nucleus visible and the Web Interface page is accessible?

Please let me know your response to the above questions when possible and we can continue from there.


Dear noris
thank you

I use Roon Remotes on my MacMini, which is connected to OEM Router by LAN through the Netgear switch, other Roon Remotes I use on my iOS devices via WiFi, covered by Time Capsule

Apple Time Capsule provides 2,4 & 5 Hz WiFi in my home

WiFi on OEM Router is turned off

Ethernet 1 is using DHCP but not working. Earlier I used Static IP on Ethernet 1, which caused web interface to disappear. After that I knew about Ethernet-USB adapter, which I call SET in my case.

the key thing of Roon is that I can use Roon Remotes on any devices in one network and manage my nucleus+. Thats why it doesn’t matter if nucleus and Mac mini are connected to the TP-Link switch. It works on every device(when I connect nucleus+ via SET) or it doesn’t works at all(when I use LAN connection)
But I can’t test it because Mac mini is located in one place and nucleus/TimeCapsule/T-Link are located in another (Hi-Fi zone)

Vladimir, set Static IP for Ethernet:
IP address:
DNS Server:

Dear Sergey
I’m afraid that I repeat the fault, described in my previous topic ( Reset Roon Nucleus+ without web interface when I changed to and web interface was disappeared.
I started to experiment to solve the problem when I couldn’t access to Nucleus+ with LAN connection in HiFi zone. Firstly I used static IP. Secondly I knew about Ethernet-USB adapter, which helps me to see Nucleus+ in HiFi zone. Now I want connect it in proper way via the LAN, not via SET

which static IP is correct?
maybe is using by another device

Well. Run a local network analyzer, for example Fing, and select a free ip from the subnet 192.168.1…

Hello @Vladimir_Tereshchenk,

Have you been able to get the Nucleus’ Ethernet adapter working by setting the static IP? I agree with @Katun, this seems like something else is using that IP address and would suggest checking with an IP scanner for a free IP address. Alternatively, you can also reserve this IP address in your Router settings by using DHCP IP Address Reservation if your router supports this feature. Please let me know if the primary Ethernet adapter is working now.


Dear Katun, Dear Noris
Thank you for your replies
Unfortunately, the problem didn’t solve
I tried to used Static IP which isn’t used by other devices (checked by Fing). Nucleus+ wasn’t seen in web interface. I also used alternative way via reservation Nucleus+ IP (in my case it was in my OEM Router. Ethernet adapter doesn’t work.
Works only via SET
Do you have any ideas?

Hello @Vladimir_Tereshchenk,

Sorry to hear that the issue has not been resolved. Since this issue is affecting your static IP, I would like to get our Hardware Team’s feedback regarding this issue as to how to best proceed here.

I have submitted a request for the Hardware Team to take a look at this case and I will be sure to let you know their thoughts on this matter. Just so you are aware though, it may take a few days for this to reach their queue and I would suggest using the Ethernet adapter in the meantime until I hear back.

I will be sure to update you once I receive the report from the hardware team regarding this case.


My network setup:
internet goes to apartments to local provider OEM Router, then goes to Apple Time Capsule (which use only for WiFi) then goes to the switch TP-Link 8 ports (unmanageable).
Nucleus+ doesn’t work if I connect it ethernet to ethernet in both ways: to Time Capsule or to the TP-Link switch.
Nucleus+ works only with SET.
when Nucleus+ is connected to router via LAN it works [!] and have DHCP IP, I don’t need to use SET

It would be nice if you painted the topology of your local network. In this way I will suggest you try to connect the switch directly to the router and check the operation of all devices with such a connection.
If the switch is already connected directly to the router, then try replacing it with any other one because it turns out that it is not working properly.

Dear Noris
thank your, I’m waiting feedback from engeneers

Dear Katun
Ok, I’ll send you my network topology

It’s strange that many other network devices (all wired by LAN) are working well in HiFi zone (Apple TV, Oppo, TV, AV receiver), but Nucleus doesn’t.

One important thing. It happened when I disconnected all the devices in HiFi zone from the power and network, changed some of them in places, put things in order and connected everything again

One good thing. I disconnected all network devices: two switches, TimeCapsule, OEM router and Nucleus+. Then connected again. All Roon apps saw Nucleus+(N+). BINGO! I thought that finally everything was fine. I made the IP reservation on OEM router, it was But after an hour all Roon apps lost connection with N+. However music was still playing!!!
Fing app showed
I deleted IP reservation on OEM router - no connection to web interface, all Roon apps didn’t work
I turned off N+ and turned on again. no connection to web interface, all Roon apps didn’t work
I connected N+ firstly to Netgear switch - no connection; secondly to OEM router - no connection.

When I connected my SET everything Is ok.

P.S. When I had my Roon data on MacMini this problem has never shown

Hello @Vladimir_Tereshchenk,

Thank you for posting your findings. I had a meeting with the team today regarding your case and they have noted the following possibilities based on your report:

  • This behavior seems consistent with a bad Ethernet cable or a bad port on the switch. If you have not yet tried another Ethernet cable or another port on the switch then this is a good test to rule that out. If one of the cable twisted pairs inside the Ethernet cable that connects to the Nucleus is damaged then it could cause similar behavior.

  • Something on the network is causing interference in your IP addresses. As a test, I would temporarily disconnect everything from that TP-Link switch except for the Nucleus. After disconnecting everything, I would power everything off and then turn on the Router, then the switch and then the Nucleus (in that order). Does it stay online and accessible?

Please let me know if you are able to run the above tests and let me know your findings when possible.


Dear Noris
I tried the both, but there was no result. Ethernet cables are fine. I made full steps by disconnecting and powering on/off right to your instructions. As I mentioned earlier all my LAN devices are working. The ethernet connection N+ to TP-Link/Netgear/OEM Router wasn’t solve the problem. Roon Remotes didn’t recognize the N+

Now I’m using SET to play music from N+

Do you recommend more? Maybe LAN port on N+ is not working?
Could I connect it at another place, for example, at my neighbor? Could I see the web interface of N+ with my account or should I create the new one?

The final step: I have 1 year hardware guarantee. What is the way to send N+ for repair? I live in Moscow (Russia)

What does this mean? This means that the Nucleus native ethernet port / controller is healthy. Look for a fault in your local network.

Dear Katun, Dear Noris

Now I connect N+ to Netgear Switch and web interface of N+ is alive again.

The left of Ethernet port on N+ is solid orange, the right one is blinking green (if this information matters)

I don’t know how long it will be visible. IP is Last time it worked about an hour

What do you recommend to do?

I have some approaches:
1 Make Reset of Roon Database & Settings on N+ web interface. Is it helpful in my case or not? should I preliminary inject my SSD or not?

2 One more try to use Static IP on web interface of N+ (should I use the same IP= on the screenshot below, which is now alive or should I put exotic? Your recommend for example

3 Reserve IP of N+ in OEM Router settings when current IP is alive

4 Go to my work and try to connect N+ in new network and test it. Should I create the new Roon account in trial mode? I can’t use my own

Hello @Vladimir_Tereshchenk,

Thank you for posting your findings so far. Can you explain a little bit more about what you’re hoping to accomplish here? If the Nucleus is now stable, you shouldn’t need to follow any of these steps, and I would recommend being careful before setting a static address again. Has the Nucleus disappeared again since your last post or is it still visible and working? Please let me know and we can try to figure out what’s going on here.


Dear Noris
I went to my neigbour and connected N+ to his network by LAN. I tried to see web interface, but it was too diffucult (need to install Roon core, need to sign in etc). Than I returned home and connected N+ again to Netgear Switch by LAN. It worked. than I connected N+ by LAN to HiFi zone and it worked! Without SET!
Just worked when I first connected it after purchase. I testes the connection some days by switching on/off the N+. I worked.
I don’t understand why it happened. I had a big problem but now it worked. Without IP reservation on OEM router, without Static IP, without reset of Database & Settings.
I didn’t answer several days because I was testing that everything was fine.

Dear Noris, Dear Katan
Thank you for your help!

I have two questions. Should I asm here or need to open new topics?

  1. When I’m listening stereo by USB and try to play multichannel via HDMI I have to turn off and turn on the N+ every time when I want to switch between stereo (USB) and multichannel (HDMI)
    What do you recommend to solve this problem?
  2. When I play multichannel WAV Roon shows me only 2 channel source

but I hear the truly 5.1 sound. I mean that Roon shows 2 channel incorrect format but plays correct 5.1 format