Nucleus+ issues as core - solved when switched core

Dear all,

I’ve read numerous posts regarding slower response of Roon including: errors of slow performance, pressing on play on a track and nothing happens, or with substantial delay, artist information not appearing when due but sometimes later or not at all. I have the impression that these issues rose to prominence with previous updates, but who knows.
People have suggested all kind of things, from trying to pin-point a faulty endpoint, network wiring, and obscure network settings beyond comprehension of many.

I have all these issues, and I’ve found for me a possible cause but no solution. In short it goes like this:

  • I have a nucleus+ as core. The unit works fine, no issue with its core functionality.
  • However, as mentioned, I have all mentioned issues of occasionally (but not always) slow performance, track playing after a few seconds or sometimes longer, and so on.
  • So, I just have switched my Nucleus core duties to my Mac as new core, and all these issues have vanished! Everything super fast responsive, instant search results, everything works as expected (and beyond).
  • Switched back to Nucleus+ core and the trouble starts again

*A few facts: I’ve tried rebooting the Nucleus core+, sometimes it seems to help, but as the problems are intermittent, who knows what the effect of rebooting actually is. Definitely not a permanent solution.

  • I have the impression that later at night, when less network traffic is present, problems are less so (but have not disappeared, mind you).
  • I have a very decent wired and wireless network, no issues with slow traffic

My network setup:

  • ISP router to Netgear Orbi (set to AP mode)
  • Nucleus+ connected to Netgear Orbi router through ethernet cable
  • Two Orbi satellites in house for wireless network.
  • Devolo magic 2 powerline adapters: one connected to the Orbi router, 3 others as access points to PC’s in the house.
  • Have connected Nucleus+ to alternatively both router and satellite through ethernet cable, no difference (at first I thought that direct connection to router seemed a bit better, but no it doesn’t).
  • Have resetted the Orbi (what did you think) and satellites , no effect
  • the Mac (who works perfectly as core) is connected through a cheap Netgear switch to one of the Devolo powerline access points
  • I have Qobuz, recently added Tidal to see if this matters: it doesn’t.
  • Everthing that I stream outside of Tidal/Qobuz works immediately (stored on an SSD in the Nucleus+)

Any suggestions?

All the best and thanks!!


Hi @Rodrigo_Salgado,

Thanks for reaching out and for providing the troubleshooting you have done so far.

As a starting point, I would try connecting the Nucleus back to the router for the simplest network setup configuration and verify if the same issue occurs when you try to output to the Nucleus “HDMI Output” port.

Even if there is nothing connected to the HDMI port, it would be a great data point to know if you have playback delays there (the progress bar should provide this clue).

Also, can you please provide the following additional details?

  1. What kind of audio endpoint are you using to connect to the Nucleus? What is it’s model/manufacturer? Does this same behavior occur for multiple zones?

  2. When you performed the test on your Mac Core, did you have the same DAC connected to the Mac or were you using another zone for the testing?

  3. How large is your Nucleus library? What is the amount of tracks/albums listed under your Overview tab?

  4. You mentioned you have a Mac controlling the Nucleus, but does the delay of artist information only occur there or on multiple remotes?

These questions should help get the ball rolling towards troubleshooting this further, so do let me know your results when possible!

Hi @Rodrigo_Salgado.
Two questions: Why do you need the powerline adaptors for the satellites ?
I also have a Orbi system, running in AP mode. Have you turned off the wireless on your ISP router?

Dear Larry,

I forgot to specificy this. The Devils Powerline adaptors are not for the satellites. The ISP router enters my house in the garage. In order to have a stable connection to the farthest points in my house that require a fixed access point (desk computers for work), I originally installed these Powerline’s. They provide a very stable connection.
In the past, I used to bridge the distance between my garage and the living room with a Powerline adapter, plug in my Orbi router to a Powerline access point in the living room and wireless distribute the signal from there. Afterwards a figured that it wasn’t necessary by optimising the position of the satellites.


Dear Noris,

Thank you for your speedy reply.

  1. Do you mean connecting the Nucleus to the ISP router or to the Orbi router (connected immediately after this in AP mode)? If I connect it to the ISP router it will be on a different network than the rest of the house. The Mac is connected to the Orbi network.
  2. I will try the HDMI output en get back to you on this after I return from work.
  3. Endpoints are a:
    Sonos Bridge: wireless connection
    Naim Atom: wired connection to a Orbi satellite
    IPad Pro (last generation): wireless
    Mac Mini (just for testing) and its Apple Display (connected through Thunderbolt, also for just testing), and a Sonore Ultrarendu: all these connections through a cheap Netgear switch to a Devolo Powerline access point
  4. Yes, same DAC: an Auralic VEGA connected through the before mentioned Ultrarendu

I don’t have the impression that the endpoint does make a difference, but I will triple check and get back to you.

  1. 460 albums with about 4600 tracks, the vast majority (90%) coming from Qobuz

  2. The delays are universal, independent which device I use to control Roon.

As said, I will get back to you as soon as possible regarding the HDMI question and the endpoints. The difference in performance when switching cores is striking. What I also could do is plug the Nucleus to the same switch as the Mac and then see what the performance is. That way both cores would be on the sample location in the network. What do you think?

Thanks for your help,


Also one addition, also replied to Larry: the Devolo Powerline are all connected to the Orbi network.

Try turning the WiFi off on your ISP. You might be running into interference between the ISP and Orbi channels.

Hi Larry,

Not impossible but very unlikely I think. The Naim Atom, Sonore Ultrarendu as well as the Nucleus are through a wired connection. Also, when I switch cores all problems go away. Every other device in the house works fine, just the Nucleus+ is stubborn. Will give it a try though, and get back to you. It shouldn’t be so that I have to switch off the wireless signal of the ISP just to get a singular device to work fine, while all other devices are unaffected.
Thanks for your your help, and will give it a try anyway.


Dear Noris,

Again, thank you for your support. I’ve done the following tests as you also suggested:

  1. Endpoints are
  • Sonore Ultrarendu (connected through a cheap Netgear switch to a Devolo powerline endpoint)
  • Mac Mini and Apple Display (same connections as Sonore Ultrarendu, mostly used for testing)
  • Naim Atom connected through ethernet to an Orbi satellite
  • Apple iPad Pro who also serves as an endpoint, Orbi wireless network

All these devices are connected, as the Nucleus+, to the Orbi network

  1. Behaviour, as long as the Nucleus+ is the core, affects all zones and endpoints. Also when using different devices to control Roon, it does not matter. What is striking is that Roon can work perfectly for a few moments, and then suddenly things go south. A exemplary error is the following: I press on a track to play, nothing happens, a press again, and still nothing. Then suddenly I get an error that Qobuz can’t stream that file, or that there is a network error. When I press again, the track magically start playing again. Sometimes it just skips the track, and goes to the next track on an album. By the way, sometimes I get a network error for no reason. I click it away and then proceed as usual.

  2. All these errors, and I mean all of them, disappear when I switch to the Mac Mini as core. After work, I connected the Nucleus+ to the same switch as the Mac Mini, so that they would be on the same place in the network. The Nucleus stubbornly persist in its eccentricities, no solution. Also, as you suggested, it does not make a difference if I connect the Nucleus to the Orbi router (instead of a satellite, never have done that).

  3. Nucleus library as stated: about 460 albums, the vast majority from Qobuz

  4. the intermittent faulty performance is independent on the device I use to control Roon. Also the other way around: when I use the Mac Mini as core, all devices can control Roon without any problems, with almost instant response to any action I undertake. When switching back to Nucleus, things start slowing down.

  5. streaming to the HDMI output of the Nucleus does not make any difference, also using any device as remote control

In conclusion:

  • All my problems would go away if I just used the Mac Mini as core. This is obviously not the intention.
  • It seems clearly related on how the Nucleus integrates itself on the network. Very frustrating, as I love the Nucleus+ but for the moment it just seems like a very expensive piece of gear who hardly justifies its price. Sorry for this…

Hope you can help me,

All the best,


Hi @Rodrigo_Salgado,

Thanks for checking the behavior further. Since this issue is affecting multiple endpoints and when the Nucleus+ is connected either to the switch or to the router directly, I would advise performing an OS reinstall on the Nucleus to see if that will help.

To do so, you should first create a Backup of your current Roon database (just as a precaution) and then open the Nucleus Web UI and press the “Reinstall Operating System” button like so:

Can you let me know if this helps with the issues?

Dear Noris,

Thank for your suggestion. I tried this, and will see how it now behaves during the day. I’ll get back to you later on.

All the best,


Dear Noris,

I’m sorry to say that this didn’t make much of a difference. The error and less performance are still there. What could be important is the following:

  • I disabled Tidal & Qobuz. Everything is super fast, no lag, no problems. I enabled both services again and the problems reappear. Also to note that the Mac Mini as core poses no problem, including with active Tidal/Qobuz services.
  • I have the impression that everything is delayed significantly. One example: I click on a track, and nothing happens, after a few seconds the symbol next to the track indicating the signal path appears, and sometimes after that the track starts playing. However, I postulate that if the delay is too much, Roon reacts with the error message of unavailable track, no screen info, and so on. Here I post a few screenshots of typical errors. I also need to mention that I get random messages of network failure, that almost instantly disappear.

Finally, and this is something I recently remarked: sometimes I have a track that is highlighted for no reason (as the track King Kutner in the following screenshot).

So, in conclusion:

  • Reinstalling Nucleus+ OS didn’t make a difference
  • Disabling Tidal/Qobuz does
  • Feeling of slow performance and hence networking errors

For the record, I can enjoy Roon with Nucleus for hours at end. It’s just frustrating to have buggy system having a Nucleus which was bought explicitly to have a no-hassle experience.

All the best and thanks again for your help,


Hi @Rodrigo_Salgado,

I propose we next test what the behavior is like on this Nucleus with a fresh database in place. Can you please use these instructions to set the current database aside and verify if the Nucleus performs the same way with the fresh database and just TIDAL + Qobuz?

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • Verify what the behavior is like without the old database restored and just TIDAL + Qobuz tracks

Dear Noris,

Thank you for your suggestion. Well, this seems to have done something right. I implemented it very late yesterday and saw a clear improvement in performance, Roon was a real pleasure to use. I stress-tested the system and got only one brief “network error”.

This morning during breakfast I also played around and found to obvious performance issues. Especially the overview and the discover features are much quicker and consistent now. Also, so far, no issues ion playing tracks. Most of them start instantaneously, some after a brief moment, but no errors so far.

I have to say that your previous suggestion to restart the Roon OS also seemed to improve performance, but didn’t get rid of the several errors I mentioned in my previous post.

What I will do is the following:

  • I will test this new setup for a few days, and see if the newly acquired performance remains. I will not add any music besides the Tidal/Qobuz services that I’m using now. Just to be cautious, as the performance issues as previously explained were intermittent, so I need a few days to see you things are really working out.
  • I will then get back to you.

Thank you,


1 Like

Sounds like a plan @Rodrigo_Salgado, do let me know how testing goes!

Dear Noris,

Sadly, things still aren’t solved. While i have the impression that since performed a reset overal speed has gone up, I still have networks errors. In short, I have the distinct feeling that at given moments the Roon system/network connection/whatever can’t make a proper connection for a few seconds and start generating errors. More often than not (indeed, not always), after a few seconds the selected songs starts to play even with the original error message still on screen. In a similar fashion, when I look at the Tidal and Qobuz tabs (so no my content library but the welcome screens of those services with their playlists and so on), the first time it can take a while to fill-in the content (with error messages sometimes). If I repeat this action after a minute or so it shows everything as it should be at a normal speed.

I repeat, all of these problems (all of them) disappear when I switch to my Mac mini as core.

I have my Netgear Orbi router in AP mode after my ISP router, so the ISP router distributes the IP addresses. Would it be worthwhile to switch the Orbi to router mode? Or to connect the Nucleus to the ISP router and see if on that network (which I don’t use) the problem persists? Again, the Mac mini on the Orbi network gives me flawless performance as core. Also, the Nucleus is the only network device that is giving me problems on the Orbi network.

Finally, I’m willing to do a complete reset of the Nucleus if you think that could be useful. I don’t have so many custom playlist, so I would be totally fine with that.

Please your advice, and appreciating your continuous support!


@Rodrigo_Salgado. The first thing to try would be connecting the Nucleus directly to the router.

Hi @Rodrigo_Salgado,

We have already done a complete reset of the Nucleus with the OS reinstall and setting the database aside, so this behavior is likely due to something else such as the network setup.

I would not use an ISP-provided router to perform the management of your network. Instead, I would change the ISP router/modem combo into Bridge Mode (which essentially turns it into just a modem), disable the WiFi on the ISP router and have Orbi handle the IP routing.

Before you make these network changes though, you may want to try bypassing the Orbi router and connect the Nucleus directly to the ISP one just as a test, as this would be easier than re-configuring the network as the starting point.

Yes that was what I was suggesting. My set up is having the ISP router with the wireless off and the Orbi in AP mode. Nucleus connect CAT6 into the ISP

Dear Noris,
Dear Larry,

First thank you so much for all your help and suggestions, which unfortunately have not brought a solution. I’ve also think that the last proposals of switching router modes or connecting the Nucleus+ to the ISP modem make sense, and I will certainly try this, but not now.

I’ve decided to temporary stop searching for a solution for the mentioned network problems. As mentioned, I can enjoy Roon despite the technical issues and will temporarily accept these quirks.
But mostly, I think that it shouldn’t be this hard to get this system running without issues. The Nucleus+ is the only networked device I have that gives me problems. ALL my other devices work perfectly and live happy in my Orbi-generated network. So to go through all these changes just to get one device (the Nucleus+) running smoothly while all the rest poses no problems is just wrong in my humble opinion. I know that these issues didn’t exist when the Nucleus was first bought, so maybe between then and now something has changed (I seem to remember this appearing after an update). But who knows? For the moment, I give up and will enjoy Roon and Nucleus as always, but it’s fair to say that I wish things would have been different.

Thank you again and all the best,