Nucleus plus not connecting

NUCLEUSPLUS not connecting to my Ethernet. Static IP Address not showing on my Fing desktop app. Tried rebooting everything. Tried usb keyboard and hdmi monitor to reset IP address but no luck. Before it worked great connected via cable directly to my Deco. But after every blackout it’s always hard to reconnect and now it seems it’s dead. I was told to find a solution here before I am allowed to send in for repair or replacement. Less then two years old. I can use my laptop as core to run Roon just fine. But now I may build my own Intel NUC.

Thank you very much.

If it is truly under 2 years old then it could be covered under warranty.
Where did you purchase it, from Roon directly or from a dealer.

Hello Ace and Thanks!!

I bought it straight from Roon online.

Then let’s page @support for you to get them to start an RMA with you to get this fixed.
Please be patient until they can get to you but hopefully that will be relatively soon.

Sounds good to me, sir.

Thanks to you it works for all of us.

1 Like

Hey @Kenneth_Johnston,

Ben here with the support team (thanks for the ping @AceRimmer!) I’ll follow up via PM to get an RMA started for you. :+1:

Hi Sir Ben!

Thank you very much for your support.
See you soon.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.