Nucleus/ROCK CD ripping locks up sometimes [Solved with RoonOS Build 254]

FAO EV, DD, & RD at Roon,
Definitely need stable CD ripping/archiving function.–
Just tried a first time CD rip using personal Apple SuperDrive & Nucleus+… the latter, OS: Version 1.0 (build 227) stable / Roon Server Softie: Version 1.8 (build 913) stable.
Successful first CD rip, but zero success whatsoever thereafter, including attempts post N+ reboot.
FYI through,… tried same thing a few years back ~Feb 2020 on behalf of Another, including with same personal Apple SuperDrive on a Nucleus/or N+ (can’t recall exactly), which worked seamlessly disc after disc.
Just adding a little personal feedback to you all specifically to help contribute/move this important feature forward


CD Ripping with Apple Super Drive still not working at all anymore since almost 1 year! Now on version 1.8 BUILD 923. OS Version 1.0 Build 227 on Intel NUC i3.


I could never get it to work on my Nucleus with numerous external CD drives, it just locks the system!

I gave up and bought DBPoweramp, I have ripped my entire cd collection now and have no need to rip anymore CDs.

It’s frustrating when something is supposed to work and it doesn’t :confused:

Exactly the same. here and ROON support team (if it exists at all) really really sucks. I didn’t get any answer since months! This is so annoying and I have to say, the worst customer experience ever for me, compared quite a few other suppliers offering online support, which has been responsive and helpful to me.


@noris replied in this thread last September to say that the issue is known and is in the queue to be fixed.

It lies in Roon OS, not in the Roon software itself, and version 2.0 of Roon OS has been a long time coming, but not yet ready for release apparently.

1 Like

Thanks for the feedback - since September last year??? This is 7 months ago and still no date for a fix for a major feature advertised by Roon.

This is not a „nice to have UX issue“. In my tech world this is category 1 issue which needs to be addressed and fixed asap: in days not in months ahead. What a bad joke.

Wow, still horrible. I am really starting to question my commitment to Roon. I built a dedicated NUC core with one of the main objectives to be finally ripping my Cd collection. So far, this has been beyond painful. Initially I thought there must be something wrong with my hardware - but no, the glitchy Ripping function that works only occasionally is a known problem that no one at Roon seems to care about. It really seems unforgiveable on their part. Either say - no Roon has no ripping capabilities, or, make it work!!!

I’ve never ripped anything, but if I did, I would use dBpoweramp and rip to my computer. I would then copy those ripped files to my Roon watched folder. Also, copy the files to a music backup location. I would not rip directly to Roon.


Jim is absolutely spot on with his comments.
The software you are complaining about would be functionally awful even if it worked as advertised.

Just buy dbPoweramp and move to a happier world of CD ripping.

1 Like

So, the consensus is, if you want to rip CDs to a Roon core you need to buy another piece of software and do it on another computer and then let ROCK detect them? Yikes, why doesn’t Roon address this?

Yes. That’s what many, if not most, users do.

Absolutely yes.
It seems to be of little interest to Roon sadly

If you were to rip directly to your Roon watched folder, how would you, or could you, use those files with another player or on another platform, etc? IDK.

So, I am on ROCK 2.0, Build 1132 and I have the same issue described here. Ripping works after reboot and if I am ripping CD after CD, but once I take a break, I have to reboot again. This feels like it can’t be too complicated to solve, so it is really quite frustrating that Roon doesn’t, given how essential it is for users.

As I recall, the ripping issue started after the last Roon OS update - Version 1.0 (build 227), not the Roon server software.

Hopefully the next Roon OS update will fix the problem.

The general recommendation from the community is to forget about using Roon for ripping CD’s and do it on another device using something like dbPoweramp where you can get proper the Metadata and images in the files and then use something to sync it to Roon so you have multiple copies of your library.
This has been an issue for a long time and Roon does not appear to have put any effort into fixing it, and even if they did it is nowhere near as functional as a proper CD ripper and tagging tool.

1 Like

Hello All,

I wanted to touch base with some great news! Yesterday, we released RoonOS build 254 which should help with this CD Ripping issue. I know this was a long-standing issue for many, and we appreciate your patience here as we worked on this. If you were seeing this issue, please try to upgrade to the latest RoonOS release and give it another go. Full release notes below:

Thanks everyone!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.