Nucleus/ROCK CD ripping locks up sometimes [Solved with RoonOS Build 254]

To the Roon team

I treated myself to a - not cheap - Nucleus + in November 2020. This also includes a monthly fee for the software - not cheap.

Then you can expect that the teething troubles have been resolved.

I have 400 CDs that I want to rip with Roon and Nucleaus in high quality and store them in my database.

So get an external CD drive and connect it, insert the CD and everything was wonderful and worked. The next day the next CD’s and the next day a couple of CD’s. So far everything is good. After a week nothing worked. The last ripped CD was displayed on the system page.

There was a little update.

Then the red button with “Reboot” or “Power Off” no longer works either. Why is the button even visible when it doesn’t work - the programmer’s beginner’s mistake?

Then searched the community and found the hint that I am not the only one and the error is already known - but it will not be fixed - and we should now pay diligently for it every month? The Roon team should urgently give some thought and finally tackle the problem.

If I rip a CD and then immediately - within a minute - insert the next CD, then the next CD is ripped. When I’m done I have to unplug the CD drive immediately - again within a minute. Then I can continue the next day. If I miss the time slot - you know - pure frustration. And then turn the Nucleus off and on again using the power switch.

That can’t be the solution!

And now came 1.8. Hope it’s resolved.

Disenchantment - not better, rather worse.

So Roon Team - how do you see that?

I am a paying customer of yours.

Sorry for the trouble here, @Patrick_Rausch

What kind of CD drive are you using?

First I used my apple superdrive. At first it worked fine. Then there were the first problems, the system hung up and I thought the CD drive was defective. The CD didn’t come out either and the EJECT button didn’t work anymore. Then I got myself a new Noname USB drive (UJDA 770 DVD / CDRW (Indio Corporation)). That worked then. Here I can eject the CD by pressing a button on the drive. If it works, then fine. But if the system blocks again, it’s over and I have to start again.
Over the past few days I’ve been ripping CDs. The error repeats itself. If I am too slow to switch or to unplug the drive, then I hang the part on the CD drive and only a restart helps.

Patrick, - I fully share your frustration and opinion. It can’t be, that this well knowned problem isn’t fixed at all. I have the same problem with my Nucleus Model B bought two weeks ago. I thought it would be a problem with my two disc-drives and now I stumbled over this discussion. It’s quite annoying to restart the nucleus even not knowing if it will rip the next CD or not. Moreover I have to make a hard shutdown because one short press on the powerbutton did it once and since then there is no reaction on a short press.

Spending in a lifetime license I hope it will be fixed before I die :rofl:

Best regards


This is a known issue, and has been known to Roon Labs since at least last September (and there’s a ticket in to fix it, I believe). The issue lies in the Roon OS, not the Roon software itself. So it shows itself on the Nucleus/Nucleus+ models and NUCs running ROCK.

Three things appear to be associated with the issue when it occurs:

  • The CD Ripper stops working
  • The Web Administration page stops working properly, e.g. the Eject button no longer works and a Reboot says that the system has successfully rebooted, when in fact nothing has happened.
  • On the Nucleus/Nucleus+ and NUCs, pressing the power button briefly no longer shuts them down - a forced reboot is the only option (holding in the power button for 5 seconds)

One possible workaround I’ve seen posted is that temporarily disconnecting the CD Drive and then reconnecting it may clear the issue, but I haven’t tested this for myself.

@dylan - now that the furore over 1.8 may be dying down, any chance that this ticket is getting near the head of the queue for investigation? Thanks.


Thank you Geoff for your immediate reply. I’ve tried the disconnecting and the reconnecting thing. Sometime it helps, mostly not. But it’s good to know Roon is working in near future on that issue.

Best regards - Detlef

I have exactly the same problem. I bought a Nucleus plus because it’s supposed to be able to multi task - every time I try and rip cds it does a couple maybe three then won’t respond. I have to power off unplug and start again. I’ve tried three CD roms and they all do the same thing! I want to rip all my cds to the SSD I’ve installed in the Nucleus + and this is proving very tiresome!
You’d think for £2,500 it would be able to rip and play at the same time - in fact it should come with a cd drive built in for that very purpose!

The problem still lives in 1.8. I have purchased 3 cd drives all with the same result. With 1.7 a cold reboot would resolve the problem…at least long enough to rip. With 1.8 I can’t get the first cd ripped. Bought the Roon Nucleus believing it would be a better and more reliable investment than others that use different hardware. I’m now close to 2 years in ROON with the problem growing. I have not been able to rip a CD since 1.8. I bought a lifetime license. Sure do wish I had a do over…Beginning to wonder how long ROON will be in business. They must be losing sales, particularly with all the 1.8 fiasco…Geez get it together ROON!

Core Machine (Operating system/System info/Roon build number)

Rock OS Version 1.0 (build 227) stable
Version 1.8 (build 778) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Not important

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Not important

Description Of Issue

Because I have issues with hanging remotes, content not loading, i wanted to reboot my Rock Nuc. But it does not work. It tells me it’s rebooted in a few milliseconds but i did not reboot. I tried it many times, remotes still work, uptime is still on 34 days. After this, I tried to power off the machine and turn it back on. This does not work either. It does not power off. I used the options on the ip of the device where a small micro http server is running.

It is a known issue, not a problem playing music and apparently not a priority to fix. I tend to forget about it until I need to use the functions that don’t work.

Last night was one of those times. I wanted to rip a new cd.

The CD was not recognized in the reader. Removed and reconnected the USB cable which has started the process working again but not this time.

So I tried the WEB UI power down button. That didn’t work either.

Single press of the power button did not work for shutdown.

Had to hold the power button for about 5 seconds then the NUC powered down.

Removed the USB cable to the reader. Powered the NUC back up. Reconnected the USB cable and this time the ripper worked. Seems to take a different workaround each time. Lot of trouble to rip 1 cd.

I’ve decommissioned my desktop with dbpoweramp. Need to add that to my laptop and start using it again with drag and drop.

Hope they get around to working on the OS issues soon.

1 Like

The same issue for me, just started ripping my collection, only a few hundred to go so would really like this to be looked at sooner rather than later. I really feel sorry for those who bought the nucleus and have this issue.

Here’s another person with the same problem.

Bit surprised, to say the least, that a known problem with such a key feature of the Nucleus (being able to rip and store my CDs on it as well was one of the main reasons I bought one with an internal SSD) still hasn’t been solved after so much time has passed.

Yes, indeed. It sounds very frustrating. Just read the official documentation on ripping with roon. And there are so many limitations. I’d rather never try to rip with roon at all. I use a dedicated ripping software on a Mac. And from there storing the files to the NAS which holds the roon library.
The only reason for this mess I could understand is roon’s believe that CD ripping is not that important for most of their customers. Or that most rippers use a different software anyway.
I stay with my current solution. It works pretty well. And I can make changes to the tagging or cover art to my personal taste. I don’t know of any automatic tagging that works 100 percent. And sometimes, you have to step in right before the ripping. And that’s good.

Hello All,

Thank you for the additional feedback here. We are aware of an issue here regarding CD-ripping and we are working to resolve it.

As per policy, we cannot specify a specific timeline of when this issue will be fully resolved, but it is in our development queue. Thank you in advance for your patience here!

1 Like

Same problem here. verbatim USB2.0 external drive on NUC 7i/ROCK>
After several rips nothing works, admin page doesn’t work for reboot and eject and shows last rip.

Not having a specific timeline for a fix is a big problem, since the payments do have a specific timeline.

Same here. Disconnecting Superdrive did not help, using another USB Port did not help, rebooting did not help. CD still stuck in Drive.
ROON: Come on, we need a solution NOW!

1 Like

I’m experiencing the same thing. Ripping works for a while. A bunch of CDs and then it stops and I have to reboot the NUC. It’s broken and should be fixed.

Worth noting is that reboot from the web-GUI does not work when the CD ripper has failed. I have to use the physical button to reboot.

1 Like

Just re-flagging this issue. It hasn’t been solved by the latest update either. Also, like Martin says: I have to restart the Nucleus physically for the ripping to start working again.

I suspect the issue is related to the Roon OS not the Server software. Thinking the problem started after an update to the OS and there hasn’t been another OS update since then. Hopefully the next OS update will correct it.

1 Like

As Mike says, this is an issue with Roon OS 1.0 build 227. We have to wait for a future build to fix this.

1 Like