Ripping problem using Melco D100

No, I mean the Linux in the Nucleus (or any Linux system).

A good test to conduct would also be to see if the rips came out identical byte for byte or if there were differences… and then to see if others with other D100 or Superdrives had matching or unmatching bytes.

If the bytes are diff, the sound may be different (not the flac, but the embedded PCM). If the bytes were not different, then claiming SQ differences would be comparable to comparing SQ from copies of the same files.

Danny,

Now I’m super confused: how does a super hot CD-ROM drive affect the Linux Kernel in the (in my case) Intel NUC i7 running RoonOS 1 build 227.

As far as the sound quality stuff, I’ve found over the years it’s best to keep an open mind and if there is a sound quality difference, when logically there shouldn’t be, to continue to investigate. Given that the rips from a Rock are without metadata (if I remember correctly) it would be most useful if these were available in .wav format to remove another variable.

My CDROM stops working after every rip and the whole thing locks up, power control on rock UI stops working only a reboot brings it back and then one rip.back to square one. Used to work fine only started doing this after the last Rock update. Others have had similar issues. @danny is this being looked at at all. I have had to give up using Rock for this now.

Simon

Yep, same symptoms here. Only thing I can’t confirm is whether the problem started after the last update. Good to know I’m not alone.

I tried it again tonight and I successfully ripped 4 CDs using an Apple SuperDrive and 3 using my Melco. Odd considering it didn’t work - locking up after the first CD every time I tried it the last few times. I need to check the updates dates of the Rock to see if that might identify the possible reason for the change.

The problem now is a lack of confidence.

Something definitely changed in Rock at some point I have had this issue definitely since the last update it may have been one previous as I had not ripped anything for a while. Same drive rips fine using EAC on windows so it’s not the drive and it worked flawlessly before with it.

Simon

Maybe worth trying again after a reboot of everything as mine seems to be OK now.

Done that too many times. Rocks not been updated recently so I cant see how it can be fixed.

A new CD arrived today so I tried to rip it using the Melco D-100 connected to the Rock. The bloody problem is back again. A Rock reboot was required before the first CD would rip. After that nothing with out another reboot of Rock.

I tried using an Apple SuperDrive and everything worked as it should every time.

Unfortunately both Melco and Roon seem to - deny the problem/blame the other side/don’t care - Strike out as you choose to apportion blame.

@CrystalGipsy, @danny - Which USB drives were you using when you were able to reproduce this issue? Were you using the same drive as @Stephen_Harris?

Thanks

Phil (posting as a representative of Melco Support)

Mines just a cheapy no name drive from Amazon nothing special. It worked fine until the update that broke the whole ripping thing happens.

@CrystalGipsy - thank you for the info Simon.

Phil (posting as a representative of Melco Support)

some no-name drive… nothing worthy of note.

Danny

In my case the ‘lock-up’ problem occurs with the Melco D-100 drive but doesn’t using an Apple SuperDrive.

Let me see if someone here has a superdrive to test with… I didn’t have one when i added support for it, but @crieke did and helped me test it.

Danny

Testing with a SuperDrive will hopefully prove it works as I think it does.

The question is why it doesn’t seem to work with a Melco D-100 which is a high-end drive specifically designed for such use.

Danny

I see that you mention fixing CD Ripping as a possible target for OS2

Does this mean you admit there is a current problem? I still have one ripping with my Melco CD100.

The CD ripping issue has been acknowledged since last September. However, it would seem that Roon Labs are dealing with other priority bug fixes ATM.

Geoff

Thanks, it may have been a known issue to a few but not to me and I have been complaining about this for months. Your explanation is clear why 1.8 didn’t help. I had been hoping.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.