Nucleus suddenly thinks 75% of my library is corrupt

After happily running Roon on a laptop for several months, I took the plunge and bought a Nucleus. It arrived last week and I copied my library of 1500 albums to a Samsung ssd I had installed in the Nucleus. Everything ran perfectly for the past week and I spent many hours listening to discs I had long forgotten about. Nice!

Until today. I had recently ripped a few CDs, copied them over, and was trying to understand why Roon wasn’t reading the mp3 tags like I expected. At some point I did “Clean up library” in the hopes that the tags would get sorted out better. Instead, an enormous list of allegedly “corrupt” files was generated (around 25,000) and when I agreed to “clean up,” I discovered that of my library of 1500 discs, only 400 are now recognized.

Here’s what I’ve tried so far:

  1. Force rescan [Nucleus internal storage]
  2. Disable/enable [Nucleus internal storage]
  3. Power down/restart
  4. Compare selected wma files side-by-side (found no differences)
  5. Checked total storage used on the ssd; it corresponds to my full library

Now I’m stumped. I can always start over and recopy all my music over. But I prefer to believe there’s a more efficient solution. Anyone?

[One hour later] After some poking around the Roon guides I noticed this instruction, “If you are accessing or copying your Roon database, you must first stop Roon Server via Roon OS’s web interface.” I certainly did not stop the Roon server before copying those ripped CDs last night. Did I mess up Roon’s brain by blithely assuming it could handle this without shutting down?

No you did not mess anything up. Since Roon does not touch your music files, the database is basically everything except the actual music files. You can definitely add music to the NUC without shutting anything down. I do it all the time.
As to why Roon is seeing the files as corrupt, I don’t have an answer as to why that happened. One potential reason and fix is talked about here Files showing as corrupt in Roon but work elsewhere - #12

What are you ripping your CDs with and what do you use to tag the files? Do you have other applications using the music on your NUC?

Thanks for responding. To be clear, I’m not worried about the music files being corrupted. In fact they are not: I can even play them directly from the SSD through the network share on my laptop. I have no idea why Roon thinks they’re corrupt. And remember, they all worked just fine on the Nucleus until today.

I suspect I simply need to rebuild Roon’s database, which presumably includes a listing of which files it thinks are playable. I would have thought that was the purpose of “force rescan” but apparently not, since that didn’t change anything. I haven’t found any instructions for “rebuild database” but I’m sure I can do this manually. It just seemed worth asking the community first.

The ripped CDs are a side issue: I only ripped three of them using dBpoweramp. One of them I tagged manually and the other two were tagged automatically. But the 1400 other discs that are the main issue here are many years old and have been played many, many times by many different players. Even Roon played them fine, both on my laptop and on the Nucleus, until today.

Right, the files are perfectly fine but Roon is indicating they are corrupted. When I had a similar issue Roon would not identify “corrupt” tracks right away. Sometimes the files would have been imported months prior and only showed up as corrupted when I went to play them.
The best way to rebuild your database is from a backup. If not, then you will probably have to do it manually by starting fresh. Sorry this happened man, I know it is a pain in the ass

If you want to reset your Roon Database, and start over, then you can do this by using the Nucleus’ Web Administration Interface…

If this were my new shiny Nucleus (it isn’t), I would want to know why Roon thinks the files are corrupt, especially given the scale of the corruption indication. As the device is new there is a possibility of a hardware fault? I would ask Roon to take a look at the logs rather than just resetting the database and hoping it won’t happen again.
Has the OP removed the covers and checked that all components are securely seated/connected (RAM and SSD mainly)? Something may have come adrift slightly in transit or the SSD may not be pushed fully home in the socket?

Thanks for your help, Geoff. Unfortunately hitting that Reset Roon Database and Settings gives this error

Error: Settings and databses [sic] could not be reset. Please try again, or contact support. {“status”:“Failure”,“exitcode”:2}

I did try again and got the same error. Now what?

OK, something seriously wrong here. Might be an idea to first follow Tony’s idea of checking that the hardware is properly seated (if you feel confident in opening up your Nucleus).

Then, the next step would be to reinstall the Operating System - the button is on the Web Administration Page.

Something is indeed wrong. Despite that error message, the database was reset and I was logged out. Once I got back in, I watched as albums were rapidly added to the database from the SSD. The number grew quickly to 400 then stopped cold.

I can certainly check connections (I had installed the SSD). And I’ll reinstall the OS.

I just reinstalled the OS and reset the database and restarted. Nothing has changed; only 400 discs are recognized. What do you recommend next?

What format did you rip your CDs to? And what ripper did you use?

They are mostly mp3 with a smaller number of wma.

Btw, what is the meaning of the guide instruction “If you are accessing or copying your Roon database, you must first stop Roon Server via Roon OS’s web interface.” That seems very strange. Is it true?

Followup: the three discs I ripped and copied just before this problem started were ripped using dBpoweramp.

That is when you are poking around in the operating system files using network access (e.g. using Windows File Explorer to copy logs or the database).

Well, that is indeed how I copied the three newly ripped discs over. Could that have created this problem?

copying three newly ripped discs != copying the the roon database

I think they mean if you are using third party software to backup (e.g.) or do other operations on Roon’s library. Notice it says ‘copying your Roon database’, not ‘copying to your Roon database’.

1 Like

OK - MP3 files are often troublesome, but more importantly: WMA files are not supported.

Use dBpoweramp to batch convert them into FLAC…

1 Like

Geoff: interesting. How about this plan? Reformat the SSD and convert/copy only flac. Think that will do the trick?

Sounds like a plan to me…

1 Like