Nucleus unallocated storage remaining on cloned Samsung SSD

I’ve have an extra Samsung 970 EVO Plus 500GB NVMe M.2 SSD that I’m trying to swap with the installed 128GB Transcend M.2 SSD.

I’ve successfully cloned the Transcend to the Samsung and have gotten my Roon Nucleus Ver B to boot.

My question concerns the unallocated storage remaining on the Samsung SSD - since I cloned from a 128 Gb to the 500GB. I’ve attempted to use various programs, utilities, including Disk Management to merge the unallocated memory but have not had any success.

Has anyone successfully merged the unallocated storage on a cloned SSD M.2?

The clone has 4 sections and then the unallocated section. Which of those should the unallocated storage be merged with 2.15GB, 10.5MB, 2.15GB, 123.73 GB?


Welcome to the forum.

Do you have a database backup? Then you can simply insert the new SSD, install ROCK on it, ask Roon here on the forum in Nucleus Support to remotely enable the special Nucleus software, and restore the backup.

If you have to merge the unallocated space because you don’t have a backup and can’t make one for some reason, then I guess you will need software that understands Linux file systems, because this is what Roon OS uses. I doubt Disk Management can do it, but something like this should:

Thanks, this is a new Roon so I haven’t anything in the database. Thanks for the link in regards to the Rock software. I’ll proceed down this route - I was just hoping to avoid it.

Now gotta ask some friends who use PCs to borrow their computer for a bit. I’m a Mac user.

Expanding the unallocated section hasn’t worked. I’ve tried several utilities and Disk Manager.

I tried the Rock installation on USB, several times - Etcher (Mac & PC) & Rufus and when I boot with the USB stick inserted - Holding the F10 key - it sees both the USB and SSD. But, after selecting the USB to boot from it fails to boot up.

I even tried to Boot with only the USB stick and no SSD installed in the M.2 slot. All I got was a msg on the TV screen that Roon couldn’t find an OS. This leads me to believe it’s a problem getting the Rock OS on the USB stick. Even though Etcher and Rufus were completed and validated.

I formatted the USB stick as FAT 32, GUID Partition, NTSF. All have failed.

I can’t find a way to boot from the USB in which I installed the Rock OS on. UNIX problem?

Is it possible that the Rock OS isn’t compatible with the Roon Nucleus Ver B?

Any help would be appreciated.

Like I said, Windows can’t deal with Linux file systems, so I doubt Disk Manager can. Don’t know which else you tried.

As for the ROCK install, people do that all the time in support cases e.g. after their SSD broke, so surely somehow it has to work. But I don’t have a Nucleus, so no idea about details, sorry. Forum search should turn up something

It seems more people had success with Rufus instead of Etcher. See if you can get into the BIOS, and recheck the necessary BIOS settings for ROCK like this:

1 Like

I’m not sure why you went any further than this. You probably were not close to even using the 128 of the Transcend and you cannot use the OS drive for anything else with ROCK or a Nucleus. So, if you had gotten the cloned drive to work, you were done, imho.

I was able to get Rock Installed on my Nucleus. Now I just need to have someone from support update it to the Nucleus OS.

I can’t get the Rock OS or the BIOS (F7) to see the SSD connected to the SATA. I know the Rock/Nucleus needs to format the SSD, but it doesn’t see it. Is there a particular setting in the BIOS that I need to select?

My current BIOS version is 86A - NUC7i3DNB. Searching for any updates had proved fruitless. I only find updates for other versions of the NUC, on both Intel and the Asus web site.


I learned that the Samsung 970 EVO Plus is not only m.2 but also NMVe. Which will work in the m.2 slot for the OS but not as the internal SATA SSD. I tried a sled/adaptor which would allow the m.2 to attach to the SATA connector but that did not solve the NMVe - a learning experience. So, I just installed a Samsung 870 EVP SATA internal SSD drive.

So everything is up and running. Just need someone from Roon to contact me to get the OS from ROCK to Nucleus.

Thanks to all who provided suggestions.

Probably best to open a new post in Nucleus Support and ask for that

how? I am struggling like you described it in the beginning

It was a UNIX problem on the USB stick. I had to format the USB stick to be able to read UNIX. I downloaded a trial version on my Mac which had a 7 day free trial. Afterwards I was able to use Etcher to get the Rock installer onto the USB stick then I just followed the Rock installer instructions.