Nucleus won’t see/reconnect to NAS

#1

My Nucleus easily connected to my NAS when I set it up a few weeks ago. Yesterday I powered down the Nucleus to change power outlets. On restart, the Nucleus no longer recognizes the NAS. My separate Sonos system still recognizes the NAS, FWIW. Not sure the next step…delete the existing paths and then try to re-establish them? Here’s screen shots of what I’m getting from Roon:

#2

I should add that my DSL line goes to a Century Link modem. The NAS connects to the modem. The modem extends to an Apple Extreme base station. The Nucleus connects to the apple base station.

Also, just before I discovered this issue, Roon said an update was available, which I proceeded with.

I’ve since deleted the music storage folders, but Roon still cannot find the NAS. Hope that helps.

(Geoff Coupe) #4

Have you, by any chance, got a Synology NAS? If so, there may have been a recent update on that, and this may be causing the issue. See:

1 Like
(Dylan Caudill) #5

Hi @Bmoze,

When you changed power outlets did you also change anything about the way that your Nucleus was connected to the network?

In the thread that Geoff linked to above (thanks Geoff!), some Synology users have found that, since a recent Synology update, they’ve had trouble connecting like normal. Using the IP address of the Synology appears to work, so if your device uses a static IP try entering that into Roon instead.

1 Like
#6

The NAS is a Buffalo Linkstation Pro. Nothing has changed in the configuration since I installed the Nucleus.

Thanks for the help. Any suggestions?

#7

So, I powered down/on the Nucleus again, powered down/on the NAS, and restarted my desktop Mac. The Nucleus still won’t connect to the NAS, but it sees it and I get a different error message:

Also, I have a Seagate USB backup drive connected to the NAS. I connected to the Nucleus, but the Nucleus does’t recognize it, which I thought was strange. I believe it’s Mac formatted, so I thought it would see it but be read only.

(Noris) #8

Hi @Bmoze,

Can you please try connecting via IP address instead of hostname and see if that has any change? You can typically find the IP address of the share in your router web interface and would follow the same path except instead of smb://LS-VL330 it would be listed as smb://192.168.X.YYY.

If this ends up working, I would also suggest adding the NAS as a Reserved IP Address in your router settings, to ensure that your router always provides the same IP address to this NAS.

Does this USB drive by any chance have a different share name? If so, you would need to find the share name, and add it similar to the music share. E.g. smb://IP_ADDRESS_OF_NAS/NAME_OF_USB_SHARE.

Do the above suggestion help resolve the issue?

#9

I tried via the IP address (two ways) and here’s what I got:

(Noris) #10

Hi @Bmoze,

Can you please try the full path link instead?
E.g. smb://192.168.0.2/Music/Bs itunes/Music?

#11

Noris, thank you, that worked. Roon now connects to the NAS and it’s backed-up. I appreciate your assistance and patience.

I’ve used a Mac since '84 so my networking knowledge is basically zip. So, I’m not sure how to add the NAS as a Reserved IP Address. I can muck around in two places: Apple OS/System Preferences/Network/Advanced, or the NAS software. Attached are two related screenshots, if they’re helpful.

One more question, and this fully exposes my ignorance. I was connecting the USB drive via cable to the Nucleus. I still need to specify the share name per your guidance?


(Noris) #12

Hi @Bmoze,

Glad to hear that the IP address worked for the NAS connection!

Address reservation is a feature you typically set in router software. For example, if you have a TP-Link router, these instructions would be used to set address reservation. I would double check with your router manufacturer’s site on how to perform this, as it would ensure that your NAS’s IP address doesn’t change when the lease expires (typically leases are 24hrs) and would help ensure that your NAS remains at the same IP address and accessible via Roon.

If you are connecting via USB directly to the Nucleus, the drive should show up in the sidebar in Choose your music folder (same as the screenshot from post #7) and you will not need to add it manually since it is not a network share.

#13

Yeah, that’s what I thought, but the USB Drive doesn’t show up in the Choose Music Folder. It’s connected now via USB. I know you have a lot to do, so please troubleshoot this when you have time.

#14

Noris, I have three usb drives. Roon sees two of them, but not the first one I tried. That’s good enough for me. Thanks, we can close this thread.

1 Like
(Noris) #15

Hi @Bmoze,

Glad to hear that the other two USB drives are working properly with the Nucleus.

I am wondering if perhaps the USB drive that does not work does not have Linux support or is using a strange drive format, as Nucleus only supports the following: EXT2/3/4 VFAT/FAT32/FAT16/EXFAT/NTFS/HFSPLUS/HFS

If you would like to get the 3rd USB drive to work, I would double check to make sure that it is formatted in one of the above file system formats.

I am going to go ahead and close out this thread as you requested, and if there is anything else you need assistance with, please do feel free to reach out to us again!

(system) closed #16

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.