Nucleus Won't Upgrade to Roon 2.0

Roon Nucleus
RoonOS Version 1.0 (build 227) stable

Roon Labs Software
Version 1.0 (build 12) stable.

Roon Server Software
Version 1.8 (build 1105) stable

I too have had an issue upgrading to Roon 2.0. I successfully and without issue updated my remotes - iPhone (iOS 16) and iPad (iOS 16).

When I went back to update the Core, I get the “Choose your Roon Core” screen showing that an update is required for for the Nucleus with a green indicator with “Update required” to the left.

Clicking on “Connect” brings me to the “Time for an upgrade” screen which shows the Nucleus “Checking for an update” with the spinning indicator over and over again. It appears like it’s trying to find it, but can’t for some reason.


images

I’ve rebooted my router and my management console shows all systems are go for the network. I also rebooted the Nucleus and restarted the server software. No change.

I’d be grateful for any help you can provide.

P.S. You guys rock! Roon is KILLER and I can’t wait to use ARC!

Thanks!

Go to the web interface to your nucleus roon settings, setup, find roon OS and do the update from there.

I run remote on Ipad and have a Nucleus core. Basically have a same issue as David does. I did what you just suggested and after I run the update from there, My Roon OS is still version 1.8. It just refused to update to version 2.0 somehow. Do you have any ideas? Thanks a lot for your help.

Same issues, I’ve spent hours and gotten absolutely nowhere…
I’m not tech savvy so I’m finding it very frustrating. All I’ve managed to do is stop my old Roon page from working at all. Also tried on my Samsung 22 to put the ARC and it keeps saying “No Roon Cores found”