Occasional one second dropouts

I’ve browsed through all the topics about dropouts but couldn’t find help, so here we go.

I have these occasional dropouts while playing music with Roon. Playback just stops for around one second and then continues. This can happen at any part of the track, beginning, middle or end. Now these dropouts are rare, but still annoying. It can happen like 1-2 times per evening if I listen to for 3-4 hours. Usually if dropouts occur, with other software, it’s like a crackling sound and very short one. With Roon, it’s always the same, like someone would press mute for once second and then the playback continues. It’s very weird. With the same system, I never have dropouts while using JRiver or any other player. No droputs with movies or video playback either. Buffer size is the same (default) in both apps and both output through WASAPI with quite identical settings. I run the latest version of Roon with full installation on my system because I browse on my computer also. I have all the latest drivers installed for all devices in the system, checked many times. I have Fidelizer Pro running in the background, but this shouldn’t cause it since there’s no problems with JRiver.

Here’s some background information of my system:

Operating System
Windows 10 Pro 64-bit (with all the latest updates installed)
AMD FX-6300 31 °C
Vishera 32nm Technology
16,0GB Dual-Channel DDR3 @ 803MHz (10-10-10-30)
Gigabyte Technology Co. Ltd. GA-78LMT-USB3 (Socket M2) 45 °C
4095MB NVIDIA GeForce GTX 1050 Ti (Gigabyte) 46 °C
2794GB Western Digital WDC WD30EFRX-68EUZN0 (SATA) 37 °C
119GB Crucial_CT128MX100SSD1 (SSD) 39 °C
Optical Drives
TeddyPardo XMOS XS1-L1

My computer is connected through USB-cable to TeddyPardo U2S USB bridge. There’s Intona USB Isolator and AudioQuest JitterBug in between. USB cables are Chord SilverPlus.

All my music is stored on the Western Digital 3TB internal HDD in one folder and the size of the library is around 1,16TB. All my music is on FLAC format. 34900 tracks according to Roon.

Background library analysis is fully done. I’ve tried to toggle this between fast and throttled but dropouts occur with both.

I’ve also run LatencyMon and it DOES show some processes causing some spikes with DPC/ISR but this isn’t a problem with any other software as described earlier. I’ve tried to troubleshoot these but can’t get rid of the latency.

So, any ideas? Please ask if you need more information of the system.

While you’re waiting for support - have you tried not using fidelizer or any of the USB enhancers just to rule it all out?

I know you say they don’t upset other packages but that’s not to say they won’t upset another streaming architecture. I’m not suggesting they’re the problem but at least you know for sure if you remove them. If it fixes the issue then both you and Roon know where to look in more detail.

Just an idea…

Thanks, these are good ideas. Though I can’t see how these would be the problem since others software works flawlessly. Also, I guess it’s not streaming when playing through USB?

Well I now disabled Fidelizer but it takes at least 24 hours to see if it had any effect.

Hi @patouskii ---- Thank you for the feedback and sharing your observations with us.

Based on your report, you’ve done a bit of research on the topic of “dropouts” by searching previously posted community threads :thumbsup: By chance have you checked out our knowledge base article on the best approach to troubleshooting dropouts? If not, may I kindly ask you to give it a read and let me know what you’ve tried so far?

Moving forward, I would recommend performing the following test:

  1. If the WIN10 device hosting your Roon core has internal speakers, during your troubleshooting have your tried playing back content through them thus, bypassing the other equipment? If so, what was the experience like?

  2. As @hifi_swlon has mentioned, shortening the chain of communication between your core and the DAC would be a good starting place (My computer is connected through USB-cable to TeddyPardo U2S USB bridge. There’s Intona USB Isolator and AudioQuest JitterBug in between. USB cables are Chord SilverPlus).


Hi Eric,

Thanks for a quick reply.

I’ve checked the knowledge base but couldn’t pinpoint the problem with the answers provided there. Of course this might be caused by some other application running on my computer but then again, it doesn’t happen with JRiver. Roon is much heavier to run than JRiver though. I’ve tried to raise the buffer size from 100ms to 250ms from WASAPI settings but this didn’t help. Usually raising the buffer solves dropout problems. Also I don’t feel comfortable to raise it too high, since everything works just fine with JRiver and with even lower buffer size. I run WASAPI in event driven mode. Resync Delay, by description, doesn’t seem to be the solution in my case.

My HDD is rather new WD Red with no problems whatsoever. I’ve tested with few different driver versions and that doesn’t help.

  1. Only other way of playing audio through my PC is through HDMi Audio. I have disabled HDMi audio from device manager since I don’t use it. I’ve disabled pretty much all unused devices there, like system speaker, unused USB ports etc. I haven’t tried if the problem occurs when playing through HDMi Audio though.

  2. I’ll start here and report if the problem is solved. Now playing with Fidelizer disabled and no dropout yet, but it’s only been 20 minutes or so.

I played two days without Fidelizer and couldn’t reproduce the problem. Now I have Fidelizer on again and no droputs yet. I did some small latency tweaks to my system according to instructions found through Google. LatencyMon showed ndis.sys to cause high DPC spikes but with few tweaks and driver updates, I think this problem is gone. I completely re-installed my network card driver (Realtek GBE series) while I usually have just updated on top of the old one. Of course there are other drivers like USBPORT.sys, dxgkrnl.sys and Wdf0100.sys causing high DPC but I’m pretty sure it’s impossible to kill the spiking completely. There’s always some driver by NVidia also causing DPC spiking, no matter how often you update to the newest driver. Mostly the latency is under 100us but spikes every now and then. This can’t be linked to the dropouts on Roon though, the dropouts are clearly more rare than the DPC spikes.

BUT, Wdf0100.sys (Kernel Mode Driver Framework Runtime) DPC latency is directly linked to Roon. It’s on top of my LatencyMon list, causing highest DPC and it stops completely when I close Roon.

DPC latency wasn’t the problem here though, it’s the dropouts. I understand my problem is extremely difficult to troubleshoot, since it happens so rarely. Let’s hope it doesn’t re-appear now. Four days without dropouts means it can almost be considered gone. I’ll write back if it re-appears.

1 Like

Well, I just had one dropout again. Super rare now but seems like it still happens. I have no clue what might cause this and I do understand that it’s nearly impossible for you guys troubleshoot either. Only chance would be if this has happened to someone else before. What puzzles me most is how the dropout sounds. It’s not the usual crackling sound with distortion or anything like that. It’s really just like someone would press mute for little over one second and then the music continues after. Very smooth dropout, sounds nothing like I’ve experienced before. I thought this was gone after the recent update but no.

Hi, as Steve and Eric mentioned, have you tried a direct USB connection from computer to your DAC?

Is it a USB DAC or does it only take optical or coax from the TeddyU2S?

If your DAC takes USB, try direct from computer to DAC with only 1 USB cable and no Intona and no Jitterbug. Then try the Intona on it’s own (in between computer and DAC) and then jitterbug on it’s own (again in between computer and DAC). Just to see if one of these is causing the dropouts.

If it’s super rare then you may need to try each of the above for a while to see (hear) which one is causing the issue.

I had issues with an Intona last year and had to return it.

But best to try one at a time to find which device is being naughty.

If you’ve already tried this, apologies. Maybe support can help.

Hi Sean,

I use Naim DAC, which doesn’t take USB directly from computer. It does have USB-input but it only plays with USB stick and external HDD. So USB bridge is necessary. No problems with U2S before and I’ve used it for many years already.

I now unplugged the JitterBug and will play like this for a while. Let’s see what happens. JitterBug is the least important part of the chain and makes barely audible difference. Intona makes a clear difference though and I wouldn’t want to part with it. I’ve had it for over six months already and no problems with it before either.

Hi, no problem and I know it will be painful to take the Intona out of the chain but it could be having a strange interaction with the other 2 devices and you won’t know until you try each individually and then the combinations later.

Personally I would start with taking both Intona and Jitterbug out - leave only the TeddyU2S.

Once you are 100% convinced that the TeddyU2S is fine alone, then I would add only the Intona. But since you said dropouts are rare, you might need to listen for a while with only the TeddyU2S and no Intona.

I know that will be hard to do because the Intona is brilliant.

But it might be the only way to troubleshoot this properly :cry:

I’ve had the same Chord USB cables as you before and they were great. I had other USB cables that didn’t like the Intona (don’t ask me why) but there have been a few people having compatibility issues with the Intona, on other forums. It might work 100% fine with one DAC but not work with another DAC and even a cable I found.

I wouldn’t be surprised if it’s the Intona’s interactions with both jitterbug and your TeddyU2S, even if the Intona is fine on it’s own, but I’m purely guessing - the only way to know for sure is to slowly try each thing individually.

Cheers, Sean

And what was the chain with the Intona when it was working fine for 6 months?

When you first noticed issues, was it around the time you added a new component? If so, which one?

Well everything here points to software issue this far. These dropouts never happened when playing through JRiver, as I told earlier. No dropouts with JRiver whatsoever. Also the nature of this dropout is so strange this time, so soft and like someone would be pressing mute for around 1-2 seconds and then back on again. The nature of the dropout is exactly the same every single time! Hardware dropouts are much shorter crackling/distortion like sounds and usually don’t sound the same every time, so nothing like this. Everything has always played perfectly fine through Intona so I really have hard time thinking the problem would be there.

I’ve read about the compatibility issues with Intona also. Usually it doesn’t work at all when that’s the case. I’ve had no problems with it this far.

The chain has been pretty much the same from the beginning. PC -> 0,75m SilverPlus USB -> Intona -> JitterBug -> 3.0m SilverPlus -> U2S. First I had 5.0m SilverPlus instead of 3.0m but I switched it to shorter one since I had no need for the extra two meters. I still have the 5.0m cable though so I can test with the straight connection from PC to U2S if needed.

I have also recently upgraded my storage HDD from Western Digital Green to WD Red 3.0TB. Could there be some problems with the Red then, who knows? When I first started to use Roon, I had many dropouts when Roon said that it can’t access the track etc. and just skipped to the next track. I thought that it probably had something to do with the first scan of my library which took ages since I have quite large library (over 35 000 tracks in FLAC). I haven’t had these problems since the very beginning of using Roon.

But I now started with taking out the JitterBug, let’s see if it helps. It now played around one week without it so this is really rare, but still annoying when it happens. It means there’s a small problem somewhere and as a perfectionist, I feel like I need to find it.

I’m having a similar(same) problem noted on another thread. My setup is different but the symptoms are the same. I first noticed the brief dropout with the latest build (234). I agree no real rhyme or rhythm to it. At first I thought it was every 5:00 but that’s not the case. It happened to me with both Tidal and Local content. Anyway I’ll continue to monitor this thread as well.

Just had the dropout and once again it was identical, little over one second mute-like break to the music. So JitterBug has nothing to do with it. To be honest, I don’t even want to unplug Intona since it will stay in my system anyway and has worked flawlessly with JRiver and everything else. I try to keep Process Explorer open in the background to see if there’s some spikes in CPU/HDD/IO activity when the dropout happens.

I’ve had this dropout issue with at least three latest releases.

Any recommendations to try in Roon app settings? Library scan is fully done so it shouldn’t affect here.

Does your Naim DAC support Asio drivers?

If so, can you have Roon use it’s Asio drivers?

And can you post screenshots of all your audio device settings (the 2 pages) and the signal path and DSP settings?

Hi @patouskii ----- Thank you for the continued feedback and more importantly your patience.

Moving forward, I would like to propose one more test to see if we can isolate another variable here. Being as you have already tried shortening the chain of communication between your core and the DAC I am curious to see how another device would handle this configuration.

As very simple (and temporary) test, I would like you to please try hosting Roon on another device. I would recommend copying a handful of albums that you’ve noticed this issue with to the local storage on the new device, set Roon up, point the application to the media, and confirm that you are still experiencing dropouts.

Note: Please make sure that when you are running this test that the other computer (which is currently hosting Roon) is not active and JUST for good measure, I would recommend making a back up of your current DB before starting this test.


Thanks for the recommendation and no problem, I understand how difficult this problem is to troubleshoot so patience is needed.


It’s the U2S which is connected to PC and yes, the drivers natively support ASIO also. I prefer to use WASAPI though and once again, no problems with WASAPI on JRiver. But I can try ASIO and see if the dropouts occur.

The settings in Roon are pretty much default for WASAPI but volume control is fixed. Event driven mode and Exclusive modes are on. Buffer 100ms (default). I tried to raise the buffer and it didn’t help this time. Usually upping the buffer always helps with dropouts but not this time.

DSP is fully disabled. I always aim for bitperfect output from PC so no tweaks on the way. So Roon’s signal path says: Lossless. Source (FLAC) - This PC (RAAT) - Output (ASIO or WASAPI).


I do have a laptop. I can try to install Roon and U2S drivers there and run it through. This is some work though so I try these smaller steps first to see if it’s any help. I’m also keeping process explorer on now to see if there’s spiking on any processes when the dropout happens.


Little update here:

After the last message, I’ve now used ASIO output on Roon with pretty much the default settings (which seemed to be just right) and haven’t been able to reproduce the one second dropout since that. I also tried to compare ASIO vs WASAPI outputs but seriously, couldn’t hear any difference between them. What surprises me though is that ASIO doesn’t take exclusive control of the palyback device. The other outputs in my computer are still accessible so I can just pause music on Roon to check a yotube video with sounds etc. If I want to do that while playing through WASAPI output, I need to completely stop the playback on Roon (by pushing the play/pause button around one second) and after that open the youtube and play.

1 Like


With ASIO I’ve now encountered this error twice: Transport: Roon has lost control of the audio device. I have no clue what causes this. I’ve had procexp64 process explorer opened and can’t find any spiking while this happens. It just randomly loses connection.

Now with ASIO the playback completely stops and doesn’t return unless I push play-button again.

Maybe it’s the same error with WASAPI also but Roon just somehow overcomes it and continues playback after around one second of stoppage?

Check the logs at the time of the stop :smiley: