Occasionally losing local audio devices until restart

Core Machine (Operating system/System info/Roon build number)
OS Name Microsoft Windows 10 Pro
Version 10.0.17763 Build 17763
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name PANTERA
System Manufacturer ASUS
System Model All Series
System Type x64-based PC
System SKU All
Processor Intel® Core™ i7-4790K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 2902, 8/27/2015
SMBIOS Version 2.8
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product MAXIMUS VII HERO
BaseBoard Version Rev 1.xx
Platform Role Desktop
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = “10.0.17763.831”
User Name Not Available
Time Zone Eastern Standard Time
Installed Physical Memory (RAM) 32.0 GB
Total Physical Memory 31.9 GB
Available Physical Memory 25.1 GB
Total Virtual Memory 36.7 GB
Available Virtual Memory 28.8 GB
Page File Space 4.75 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Running
Virtualization-based security Required Security Properties
Virtualization-based security Available Security Properties Base Virtualization Support
Virtualization-based security Services Configured
Virtualization-based security Services Running
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not InstantGo, Un-allowed DMA capable bus/device(s) detected, Disabled by policy, TPM is not usable
A hypervisor has been detected. Features required for Hyper-V will not be displayed.

Roon Version 1.7 (build 511) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Intel® Ethernet Connection (2) I218-V
PC is connected via wired ethernet to an eero Pro mesh network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
RealTek High Definition Audio, driver version

Description Of Issue
Following a reboot, I’ll occasionally but not always find that roon cannot see the local audio devices. Restarting the roon server consistently resolves the issue. I’m not sure it’s related, but this only started happening after the upgrade to 1.7, and no other applications seem to have issues seeing or using the local audio.

Hi @jasonheyd,

We have seen similar behavior surrounding Realtek drivers, can you please try uninstalling this driver? See this thread for more info:

Hi @noris. I did see the thread that you’ve referenced, but haven’t tried deleting the driver yet.

I reported a separate issue with Qobuz logins failing after my roon server reboots, and that seems to have been alleviated by delaying the roon server start for 5 minutes after a system restart. Strangely, this issue with my local audio device being lost seems also to have been resolved by delaying the roon server start.

I’m going to keep an eye on it for a few days to see whether I lose the local audio device again, and then I’ll report back. And if it does, I’ll try tinkering with the driver.

1 Like

Hi @noris,

I haven’t seen this issue crop up since I disabled auto-start and added the Task Scheduler job to start the roon server 5 minutes after system boot.

It looks to me like roon server version 1.7 has some problems with startup, as both this issue and the Qobuz log failure issue that I’ve reported separately are mitigated by my change. Neither issue happened with version 1.6 of roon server.

While the issues I’ve been experiencing seem to be mitigated (if not completely resolved, at least in the case of the Qobuz login failures that still happen from time to time), I don’t think my change is a “fix” — more of a “band-aid”, especially if the auto-start may be re-activated by a roon server update at some point.

Hi @jasonheyd,

Glad to hear that the Task Scheduler helped, but to me it sounds like this could be due to Roon trying to access the network when it’s not yet ready. Have you by any chance confirmed if your Intel Ethernet adapters are up to date?

Hi @noris,

That’s what @dylan had mentioned as well.

I just checked and there was indeed a driver update available. I’ve re-enabled the automatic start and disabled my Task Scheduler job. I’ll do some testing and report back as to whether the updated driver makes any difference.


1 Like

Hi @noris and @dylan,

Unfortunately, the driver update didn’t resolve either issue. This morning around 9:37 AM ET, when I tried to connect, I received the Qobuz login error and my local audio device is missing.

The problem with these gaming optimized mainboards is that they often come with specialized hardware, optimized for the intended use. AFAIK is the integrated sound adapter based on a RealTek chip but one can’t use the official drivers provided by RealTek. So either it works with the ASUS drivers or not. You can try to deinstall the drivers and use the generic Windows driver instead but should you have installed the accompanying ASUS sound related software too, you might have to deinstall it too.
If I remember correctly, other user have had success with just removing all additional software provided by ASUS because it contained an incompatible/problematic software module (somewhere).

Similar behaviour/problems might occur with the network adapter related additional software/drivers provided by ASUS.

Thanks @BlackJack, and understood. It’s just curious that two issues I’ve run into seemed to start with the 1.7 upgrade, and both seem to be (at least mostly) resolved by delaying the roon server startup by 5 minutes. I’d have to double-check but I think I’m actually using RealTek provided drivers.

It may be moot soon in any case, as I’m planning to migrate my core to a NUC this week.

Hi @jasonheyd,

I suspect if you were to use another network adapter (such as a USB -> Ethernet one) it would help with this issue, but since you are planning to move to the NUC it might be better to see if the issue is resolved after setting it up. Do let us know how it goes!

HI @noris,

I’m assuming the issues are pretty specific to something on my Windows system and (hopefully) won’t happen on the NUC.

Really, at this point, I’m just hoping to provide whatever data I can to help you all figure out what’s happening in case it happens to others. :slight_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.