On Screen Touch Keyboard won't pop up on a Microsoft surface [Resolved]

On Screen Touch Keyboard won’t pop up when :mag_right: searching for music even with the setting enabled in roon on a Microsoft surface.

Hi @Wh01sjongalt ----- Thank you for the report and sharing this observation you’ve made with, both are appreciated.

Can you confirm for me if this is the same behavior you are experiencing with the MS Surface?


1 Like

Um, Eric - the Surface is a Windows device, it’s not running Android…

1 Like

Thank you @Geoff_Coupe for pointing that out to me.

I understand that the Surface is a Windows device and not running Android. As we’ve not had any other reports outside of Android, I would like to make sure other platforms are not being affected by the same behavior.


1 Like

I would add that I have a Surface 3 running Roon, and I’m not seeing this issue. When in tablet mode, the onscreen keyboard pops up as expected when the search icon is selected.

@Wh01sjongalt - does the onscreen keyboard work as expected with other applications?


Actually yes. I tried to find a setting in ease of use, but no mas. I just got this tablet as a dedicated control device and hadn’t noticed it before in other apps because I havent used it for other stuff. I put it in Tablet mode to get it to ignore my keyboard/hardware mode that prevents it from popping up, but still it doesn’t pop up when searching for music. Weird.

Edit - OK, normal mode is that you have the keyboard icon in the Taskbar.Does it pop up when you click/touch that?

And when it’s in Tablet mode, and you click/touch the search icon to get the search field, nothing happens when you click/touch in the field?

1 Like

Sorry for delay, didn’t get a notification. The problem (don’t laugh) is the attached keyboard, apparently. Even in Tablet mode it appears windows sees the external keyboard and prevents the on screen keyboard from popping up when you attempt to search. I disconnected it for now and the touchscreen keyboard now pops up everytime. Guess it’s simply “user error”

That’s odd. On my Surface 3, provided I fold the keyboard back under the Surface, then the physical keyboard is disabled, the Surface goes into Tablet mode, and the on-screen keyboard will pop-up. Perhaps the sensor in your keyboard is bust?

1 Like

Bingo! Didn’t know you could do that! Thanks Geoff, et al for all the help!

If I hadn’t inherited this Surface 3 Pro, I might have actually known something about its operation. I’m sort of late to the party with regard to newer tablet devices. Roon was the first viable reason for me to consider using a newer one as a Roon Remote/and as a temporary USB interface for my Benchmark DAC2 HGC. Works very well. Very fast and quiet. I can’t be sure, but damn if 1s & 0s don’t seem to sound better than with my old Lenovo X201T tablet I was using. (That was partially meant as tongue in cheek) I’m very knowledgeable about the Lenovo as it’s a relic now as far as tablets go going on 6+ years old

Thanks Again you guys!

One other thing that might be new to you - if you don’t like the feel of having keys underneath the tablet when the keyboard is folded back, you can also detach the keyboard, turn it over and reattach it. That way, when the keyboard is folded over, the keys are on the inside of the sandwich…

1 Like

Oh okay cool :sunglasses:, thanks Geoff!