OPPO HA-2 native support

Please help. My OPPO HA-2 DAC is not recognized. Only purple point and “CoreAudio Exclusive Mode”

Hi @Alexander_Korovin ---- Thank you for the feedback and my apologies for the troubles here. In order to accurately evaluate this issue you are experiencing may I kindly ask you for the following information:

  1. A brief but accurate accurate description of your current setup as seen here. The more detailed you can be, the better.

  2. A description of your network configuration / topology, as well as some insight into any networking hardware you may be implementing in your setup. I want to get an idea of how your devices are communicating and what tools you are using to make those connections.


On the bottom of the HA-2 are two USB (A & B) inputs and an A-B-C switch. Make sure the switch is set to the input your’e using.

Mine won’t show up unless it is turned on and the switch is set to the corresponding input used.

Hope this helps.

I think mine needs to be set for B input (the mini USB) not the USB used for iOS devices, but the one you charge the HA-2 battery with. I had it running on my MAC like this… haven’t tried on the RPi platform yet though.

The volume / power switch must also be on

Make sure that you have the latest drivers from Oppo.

Also if you turn your PC off and do not turn off the Oppo, then the battery will go dead and when you later turn on your PC, the only way to get the Oppo back up is to unplug the Oppo USB and then plug it back up. Otherwise it will not work.

Manual Download link


Corresponding button settings for your device.

Hope this help.

Hi @Alexander_Korovin ----- Just wanted to touch base with you and see how things were going. Has any progress been made here? Let me know if further assistance is needed and I will gladly lend a hand.


Do I use the headphone jack on the Oppo or the Line out jack for my headphones when using Roon from my MacBook Pro?

I ask this because I get sound from both jacks, but the line out is stronger in terms of sound and the volume then is controlled by the Roon app.

And should I use high gain or low gain?

Listen to your ears…go with what ever sounds best.

I am a new Roon trial user, considering whether to purchase a lifetime subscription. I am requesting help from @support to get my Oppo HA-2 to work with Roon.

When I started Roon on my MacBook Pro with macOS v10.13.4, it detected a Roon Bridge endpoint on a RPi DigiOne player with DietPi v6.9 right away. That works. Unfortunately, the default settings for my direct Macbook Pro-connected Meridian Explorer2 and AudioQuest DragonFly Red were flaky. MQA would only work if the Device Volume was set at 100%. I’m not sure what fixed it, since I could find no obvious problem. With the Explorer2, switching Integer Mode off and back on again seemed to do the trick. After that, MQA decoding/ rendering started working correctly on both DACs at all volume levels (I hadn’t made any recent setting changes for the DragonFly Red).

Unfortunately, Roon won’t play through my MacBook-connected Oppo HA-2, and I haven’t found any settings that will fix it.

My Setup
Roon v1.5 (build 323) stable (64bit)
macOS 10.13.4
MacBook Pro late 2011 w/ 16GB 1333MHz DDR3, 2.4 GHz Core i5
Music 699 albums, 9054 tracks (currently on EVO 1TB SSD)

The Issue
Oppo HA-2 (firmware 6.79) is directly connected to MacBook Pro USB. It is not working for Roon Core playback. I enabled it in Preferences as an audio device, named it, and inspected the settings. I can select it as a Roon Zone, but the playback indicators are grayed out, and I cannot get playback to start. Other enabled audio devices are similarly grayed out and inaccessible for playback, including bcm2835 ALSA IEC958/HDMI.

250 Mbps Comcast

Trying Tidal FLAC 48kHz 24 bit, MQA 192kHz. Works fine for other DACs but not for Oppo HA-2 or for bcm2835 ALSA IEC958/HDMI.

Using HA-2 as Roon Zone (not System Output). It did work initially when I selected it in Audio MIDI Setup as the default sound output device.


Those settings look ok for the ha-2 and note that unless on windows or some specific Linux builds dsd128 is the max you will get.

Do make sure the firewall is off in security settings as I think I had an issue with this being on.

Thanks @wizardofoz. I thought the settings looked right too. I’m not sure why the HA-2 won’t work with Roon. It works perfectly with Tidal.

Are you switched to correct OPPO input I think for dac use you need to use the B setting. And of course you need to turn it on. And use the correct output jack.

Are you using any DSP settings?

Yes-- good suggestions-- sometimes easy to forget. I’m not using DSP at all. I have no DSP options selected, and I have the global switch turned off too.

Editing due to new user three post limit:
Good thought on the sample rate too. I tried this plus a large number of other sample rates and settings, but I can’t get it to work directly. The HA-2 still works fine when I make it the system default sound output device, and I select the System Output in Roon Zones. I just can’t select the HA-2 directly.

Can you clarify why you think I’m under minimum specs?

It looks like my MacBook Pro exceeds all minimum specs I can see at the official Roon page.

Try setting it to use max 192 or less.

Do note that your Mac is under the minimum spec for hardware, while this might not be your issue it will not be the best performance experience with Roon.

1 Like

This is how I’m connected. I use my iMac as the Roon Core.

I have my Oppo HA-2 connected out of the USB port of a MacBook Pro and into the B slot on the Oppo.

I have my headphones plugged into the headphone jack on the Oppo and the ABC switch set to B on the Oppo.

I open up Roon on my MacBook and it should find the core using “Oppo” as the name of the Zone.

I have a subscription to Tidal so Roon finds that as my music, as well as my personal library on my iMac.

Hope this helps.

1 Like

@support maybe the support guys will have some ideas or will get some remote diagnosis setup.

1 Like

Hello @Psychoakustik,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Hello @john,

I went online Wednesday evening and attempted playback for various audio devices, including the Oppo HA-2 and bcm2835 ALSA IEC958/HDMI. Those devices can be selected but remain grayed out, failing playback. Have your technical @support staff determined anything with the diagnostics report?

I look forward to your team’s input.