Overview and discover page slow to load


I was running a ROCK Roon core on Intel NUC i3 (813) with 8Gb of ram, system on 256gb SSD NVME, library on a 2tb SSD inside the NUC. I was Nothing to say; it was fast. But two days ago, I realized it was some “waist” to have a 24/24 home server running for only one application. Moreover, I was not using the 250gb of fast NVME inside.

So I wipe the nuc clear, install the last release of Ubuntu server (20.04 LTS), and followed the installation process for Linux. It was flawless and smooth.
I’ve installed on the side Plex server and Pi-Hole on the nuc, and that’s all. That was my motivation (to get pi-hole running and also to get my plex server running and using the 250gb to store movies).

So globally, I’m happy with the new setup. The only issue is that now the Discover page and Overview page or Roon takes about 15s to load. It was a few seconds before (1/2/3 seconds maybe). I’ve checked the CPU load; it’s not coming from pi-hole, and at the time, plex is not used. Moreover, checking with htop during opening overview page (or discovery), there is no CPU charge at all during 15s of wait, then some charge appears for 1-2 seconds when it finally displays the page at the end.

I should add a few things:

  • I have Qobuz integrated into Roon
  • My library is about 1030 albums (about 13000tracks) and is only stored on the internal SSD, so quite fast
  • My internet connection is excellent (950mbps down, 500mbps up)
  • I’ve changed the ulimit -n to 1048576 instead of default 1024 and reboot, no change in speed

Do you have any clue why it’s slower? Is it compatibility issue with 20.04 version, or anything else? I don’t see why it would be that slower, even more than other Roon pages (like albums, genre…) are as fast as before.

Thanks in advance for your help

1 Like

There have been reports of Plex using the same port as Roon and causing issues, perhaps try disabling plex and look at response times.

Just disabled plex, and indeed now discovery and overview are fast to load! Any solution to still run plex without this issue?

I’m just a user so not roon support :slight_smile:. I believe it is the DLNA server in Plex that uses 1900 so if you don’t need that you can turn it off inside plex.

Yep I tried, not working :D! Time to move from Plex to Emby and see if this work better with roon

I think emby has issues as well. The clip I postedis about emby.

Super strange! Indeed same issue with Emby… I tried to deactivate DLNA on Plex, no succes, try also to deactivate all DLNA on Emby, same, still slow. Not sure it’s DLNA only, but there is obviously something wrong with Emby/Plex and roon server

There are quite a few posts if you search the forum for Plex, emby.
I run a standalone ROCK server to isolate from issues such as this.

Damn… Know I’ve uninstalled both plex and emby, and it’s still slow… Wtf is going on

Put ROCK back on…

Damn this is disappointing! I don’t want to only use my nuc for only roon… For me this kind of lag only in overview in discovery is more the definition of badly implemented feature on roon server. Being force to only run it alone on ROCK is the pure definition of overkill or pure laziness… It should be able to work with Plex on side, or any other app

1 Like

Remember roon support proper hasn’t replied yet. I’ve just done a search on the forum for plex. I’d wait on the m first.

Update: With Qobuz disabled, it’s fast with and without plex.
For me the issue come from Qobuz more than Plex at the end

Hi @Arnaud_Plds,

We currently have an open investigation ticket regrading using Roon and Plex/Emby, we’re looking into to see what changes we can make, both Roon and Plex/Emby use port 1900 and this sometimes causes a port conflict.

As for the slowness issue, how do you have your DNS servers set up? Are you using the ISP default or Cloudflare/Google/Quad9? If you’re using the ISP default, can you see if there’s any change in behavior if you change the DNS servers?

1 Like


From my last investigation on the possible “slow down” cause, it appears that is is more Qobuz than Plex. If Plex is activated on the server, but I log out of Qobuz, it’s lightning-fast (less than 0.1~s to load anything). If I re-log on Qobuz, this time, it’s slow again for the overview page (the discovery page is fine now, I don’t know why). The rest of Roon is fast. Only the Overview page takes an average of 5s to load. On my iPhone, the Discover page open fast, but the “Qobuz” section on top is slow to load (5~s also). This is this observation that had to lead me to try to remove Qobuz.

As DNS, I use Google one through Pi-Hole running on the same nuc server. But I thought it might come from pi-hole (more than google), and I tried to deactivate pi-hole and switch back to my internet provider DNS (Orange, France), and it didn’t change, with Qobuz in, it was still slow.

Strangely, the Qobuz page in Roon only takes like 1s to load. Only the overview page is slow to load and enabling, or disabling Plex on nuc server doesn’t change a thing. The only thing that restores the fast experience is to log out from Qobuz.

1 Like

Hi @Arnaud_Plds,

Can you please reproduce this behavior and note the exact local time + date it occurs and access your Roon logs by using these instructions? I wonder if logs would show any additional info, worth a check.


Thanks for your help, please find this link to download my logs
I reproduce this:

07/05/2020:07:17: opening overview/discover/overview/discover/overview > with Qobuz loged-in
07/05/2020:07:19: log out Qobuz
07/05/2020:07:20: reboot of nuc
07/05/2020:07:21: opening overview/discover/overview/discover/overview > with Qobuz loged-out

Note that for both case, first “discover” opening took around 2-5 secondes, then fast to open (less than 1s) for both Qobuz in or out. But For loading Overview page, definitely it was always instant without Qobuz, and slow (2-5s) with Qobuz

Link to download logs

Thanks for your help :slight_smile:

1 Like

Thanks for sending those logs + timestamps over @Arnaud_Plds!
I have requested QA to review them and once I have further feedback from them, I’ll reach out again.
Thanks for your patience here!

No problem! I can live with this few seconds of loading ahah! And thank you so much for the help and investigation :slight_smile:


Hello @Arnaud_Plds,

I appreciate your patience while I had a chance to consult with QA regarding your report.

It does look like overview took ~5 seconds to load when you had Qobuz active and it looks like there were still some items being loaded on the Overview page which is what you have noticed.

We are still actively looking into ways to increase performance of the Overview tab, and we have even recently made a few minor improvements in this area. Your report is with QA to aid their investigation into further improvements, so if you notice even better performance here down the line, do let me know :slight_smile: