"Paste URL" for album art does not work with https URLs

@support – The “Paste URL from Clipboard” in the “Add an image” dialog box in the “Edit Album” tab of the Album Editor screen gives the error “Failed to load image from Clipboard” when the clipboard contains a URL beginning with https rather than http.

Deleting the “s” in the URL fixes the problem when the underlying site serves http; doesn’t fix the problem when the underlying site just redirects to a https URL.

Not super common, and work-around-able, but also definitely a bug, so letting you know.


Thanks for the report, @Joe_Gratz! We are going to take a look into this on our end, to see what we come up with.


Hi @Joe_Gratz ---- Thank you for your patience!

Moving forward, myself along with one of our QA techs tried to add the following images (see below) to a local album in Roon and had no issues.

Example #1

Example #2

In light of this, I wanted to see if it would be possible to provide us with an example you noticed this behavior with so we can test with the same materials.


This URL fails in Roon, but works in Chrome and with wget: https://f4.bcbits.com/img/a3738344692_10.jpg

I have confirmed that on the same setup, the example URLs you gave work.

The following URL works (not https):

2 posts were split to a new topic: Where are imported images saved?

Is this the same bug as

Artist image will not load [Ticket Open]

I get the same results as @Joe_Gratz


Hi @Joe_Gratz ---- Thank you for the follow up and providing the requested sample. Both are appreciated!

Moving forward, we have tried testing the above on a few different platforms and unfortunately are not running into the issue you’ve described. Screenshots highlighting one of the tests can be found below.

In light of this, can you please provide some insight into where you’re core is being ran, as well as verifying the make/model of the device you are trying to paste this URL on.

From my testing:


Interesting! It works on my iPad but fails on my Windows 10 computer. My core is on a Mac. Both core and Win10 are running 1.3 build 262 stable 64bit.

Hi @Joe_Gratz ---- Thank you for the follow up, and more importantly, thank you for the insight! This information is very appreciated!

Moving forward, I am going to be updating my report with your findings and will be passing it back to our techs for review/testing. Furthermore, I would like to grab some logs from the mentioned Win10 computer to add to my report, and will be contacting you momentarily via PM with instructions.


I don’t have the browse for an image option on my iPad and the copy and paste function doesn’t work either! My core is on an Innuos server.