Pioneer SC-LX87 Multichannel Stutters

(Jan Ekstrom) #1

I’ve setup Roon ROCK on the following configuration approx. a week ago:

  • Intel NUC NUC8I7BEH - Core i7-8559U
  • Kingston ValueRAM SO DDR4-2400 SC - 8GB
  • Samsung 970 EVO SSD M.2 2280 - 250GB

I didn’t have any issues installing ROCK following the instructions.
It performs very well and I have now imported 942 albums and 12.189 tracks into the library - it take some time to prepare the folder structure and folder names, when I want to add version information in the folder names for each album.

The NUC is connected to my Pioneer SC-LX87 through USB (as it has input to USB-DAC built in) and HDMI.
I primarily use the USB-DAC for stereo listening and HDMI for multi-channel.

Through the USB-DAC I’m able to play FLAC (up to 24 bit-192 kHz) and DSD (from DSF files up to 2.8 MHz aka DSD64) without conversion.
Through HDMI I’ve had some issues with FLAC files over 24 bit-96 kHz, even though both the NUC and the Pioneer are supposed to support up to 24-192 ?!?
So I’ve had to change the setting for that audio zone to limit up to 24-96.

I’m very happy with the new setup and are working to add many more tracks and albums going forward.
Even though the HDMI connection does not perform as expected, I’m still very satisfied, as I do listen to most music in stereo :wink:

Please let me know, If any of you have any ideas as to why the HDMI connection is not performing as expected…

Anyone get a NUC8 (Bean Canyon) yet?
(Peter Lie) #2

Try 24/192 in 2.0, 5.1 and 7.1 setting in Roon for HDMI.

I’ve checked the specs of SC-LX87 and do not see the HDMI sample rate capability. 192kHz is only mentioned in USB DAC input and upsampling.

(Jan Ekstrom) #3

Hi Peter, thanks for responding.

The manual tells me it should be able to handle up to 192 kHz in 8 channels:
HDMI_Support

And it works when I use my Oppo 203 as an end-point. I would however prefer to have the NUC/ROCK handling that without having to turn on the Oppo as well, since it should be supported.

My speaker setup is 5.1.

I’ve tried both 2.0 and 5.1 FLAC files, which plays fine when they are 26 bit/ =<96 kHz.
I’m experiencing stutter when going above 96 kHz, and that makes the listening unbearable.
Currently I’ve limited that audio zone to max 24 bit / 96 kHz which then implies a down conversion on the ROCK together with a 5.1 setup:

(Peter Lie) #4

When it stutters, let it continue to play. Switch the Pioneer to another input, then back to the HDMI input you were using. See if it still stutters.

(Jan Ekstrom) #5

Sorry for not replying before, but I’m traveling. I will check it tomorrow evening, when I’m back home.

(Jan Ekstrom) #6

I have now tested changing inputs on the Pioneer to e.g. USB-DAC and back again to the HDMI - but it continues stuttering.
I’ve tried using my Oppo 203 as Roon bridge and it plays flawlessly 24-192 in stereo over HDMI, hence this is why I suspect the HDMI driver on the NUC/ROCK to causing the issue…
If the Oppo 203 supported multi channel as roon bridge I would just have used that - but it doesn’t. I wonder if that is a limitation in the Oppo or the RAAT running on the Oppo?!

(Peter Lie) #7

Did you try setting the Channel Layout to 2.0 on the NUC and playing stereo 24/192?

(Jan Ekstrom) #8

No, I didn’t try that.
I want to use the HDMI for multi channel only, since I use USB => USB-DAC for all Stereo listening as it even support Native DSD.

(Peter Lie) #9

I suggest experimenting Channel Layout settings of 2.0 and 7.1.

(Jan Ekstrom) #10

Tried (I believe) all combinations of channel layout and down mixing or not - as long as I am above 96kHz I get stuttering - even if I change input channels on the Pioneer.
In a short moment it played 5.1 DSD converted to PCM 5.1. 176.kHz without stuttering after I disabled MQA support - but the stuttering came backwhen I changed to another track :frowning:

(Peter Lie) #11

What is the processing speed shown in the signal path when it stutters? It has to be larger than 1.3.

(Jan Ekstrom) #12

Between 2 and 6x depending of 5.1 or 2.0, so that should not be an issue at all when using a NUC8i7

(Peter Lie) #13

Flagging @support for your issue of NUC multichannel HDMI output to Pioneer SC-LX87.

(Jan Ekstrom) #14

Thank you for providing information about things to try out.

(Jan Ekstrom) #16

I have tried all the HDMI channels (0-4), but it is only HDMI 0 that provide some sound.
HDMI%20Core%20Channels

One thing that just popped up in my head:
When I initially installed the ROCK, the first thing I did was to connect it through an adapter to the VGA adapter to my PC monitor (that supports 1920x1200) which didn’t provide any information on the monitor.
Then I connected the NUC to the Pioneer SC-LX87 HDMI input - booted the NUC, but nothing was shown at my LG TV even though the LG input was set to HDMI from the Pioneer.
The first time I was able to see what the NUC was displaying via HDMI was when I connected it directly to my 4K LG TV.
I suspect the HDMI negotiation on the video signal resolution could interfere with the transport of the sound - i mean if it toggles quickly between connected/disconnected…

@support: Is there anyway to force the NUC into Full HD (1080p) resolution? - either in the BIOS (which I haven’t seen) or by the ROCK software?

(John) #17

Helll @Jan_Ekstrom,

Thanks for the clear report, I have passed this information on to the QA team for further investigation.

Do you have a TV connected to the Pioneer receiver? Can you tell us if you see any difference in behavior if you have the television turned on or off during HDMI playback to the Pioneer from the NUC?

-John

(Jan Ekstrom) #18

Hi @john

Same behavior no matter whether the TV is turned on or not.
I’ve documented the settings for the HDMI 1 limited to 96kHz with screen shots 01 - 04, and a short video demonstrating my experience.
Then screen shots 10-12 and the video 13 running with 192 kHz including the stuttering.

01%20-%20MCH%20HDMI%20Config


Hmm, this interface doesn’t support videos…

You can download 05 - MCH 96 kHz OK.MOV here:
https://ibm.box.com/shared/static/mopaw9b5qefztvgyf8bmrkw9fl672ah9.mov

and the other one, 13 - MCH 192kHz NOT OK.MOV here:
https://ibm.box.com/shared/static/h1lhq46x04xh8ncikd2hjqp5mj25ojaw.mov

I hope this helps.

(Jan Ekstrom) #19

Hi @john

My previous video links only gave you the sound, so I’ve shared the folder with you, so you should be able to download the 2 videos instead :wink:

  • and I also added 2 log files to the folder.

https://ibm.box.com/s/jw9ck6p5z9v5esso32mxhmde4kqmf4t7

I’ve also tried with different HDMI cables without any difference.

BR Jan

(John) #20

Hello @Jan_Ekstrom,

We’ve performed some extensive testing with a NUC running ROCK and we are unable to reproduce the symptoms you are seeing. We have been able to play 5.1 DSD files resampled to 176.4kHz as well as PCM 5.1 at 176.4/192kHz rates using the HDMI output without issue for many hours.

Looking at your RAATServer logs, it appears that the device is rapidly refreshing its HDMI EDID format support information and occasionally settling on an EDID with a max sample rate of 96kHz.

I will forward your inquiry about forcing the ROCK to output 1080P to the development team, if they have anything to add I will be sure to pass it on.

For the HDMI output zone on ROCK, have you tried increasing the buffer size in Device Setup?

-John

(Jan Ekstrom) #21

Hi @john

I can see that my buffer size is set to Default. What is the default value?
And what value would you suggest it to be set to?

An additional question: would it make any difference if I added a USB-C to HDMI adapter?

Br Jan