"Playback Interrupted Because a Track Failed to Load"--Ubiquitous Problem!

Core Machine (Operating system/System info/Roon build number)

NUCLEUS+ , OS Version 1.0 (build 227), Roon Server Software 1.7, Roon Labs Software 1.0, connected to router by ethernet cable.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Router: ATT Model 5031NV, connected by ethernet to Nuc+ and by separate ethernet cable to NAS
NAS: QNAP TBS-453D, connected to router by internet cable. All music is stored on the NAS in seven different folders, some big (100k+ files) some small (<1000 files).
End Point: BlueSound Node 2i, connected to router by WiFi. It is 15 ft away from the router
Network Type: DHCP

Other remotes: two LG Android phones.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various “zones.” One is my MacBook Pro (a remote device), connected by WiFi to Router. Another is my stereo. Amp (Peachtree) is attached to endpoint device by coaxial cable. But these are not the problem.

Description Of Issue

Until recently, I used my MacBook Pro as a core but my setup was otherwise the same (i.e., NAS ethernet to router, wifi connection with endpoint, coax cable to amp). It was painfully slow especially at rescanning folders, but everything played. So I bought a Nuc+ because I have nearly 200k music files. I moved my library by putting the most recent back up onto an external HD and plugged that into the Nuc+. There were no issues with this, and it worked smoothly.

Now about 1/3 of my albums will not play at all – they all played when I used the MacBook Pro as the core. I now get the orange message “Playback Interrupted Because a Track Failed to Load” followed quickly by the “Too Many Failures, Stopping Playback” message. I have noticed that the worst problems (that is, where it is most common) are with albums stored in the largest folders. But it isn’t universal, this is more of a statistical association. Some of the albums on my smallest folder won’t play, either.

The exact same albums/tracks won’t play no matter which remote (MacBook Pro, or 2 Android phones) I try.

I do not believe the problem is in any of the remotes (nor should it be). All the files on the NAS are accessible and playable elsewhere. It is not a problem on my NAS. I can use the endpoint for other purposes just like before. The only change to my system is the addition of the Nuc+ as a core, so the problem must rely either in the Nuc+ hardware, its software, or its ability to connect to my NAS and access files properly. Again, no problem with the MacBook Pro doing this task.

WHAT I HAVE TRIED TO FIX THIS:

First, I tried rescanning my music folders on the NAS. No change.

I then tried reloading the software on the Nuc+. I have tried rebooting the software. I have tried rebooting the Nuc+. I have tried a complete reboot of my system, starting with a shutdown of the Nuc+, then of my NAS, then of my router. I even turned off my computer remote, not that this should matter. After a few minutes, I slowly turned on each component in turn: first the router, then the NAS, then the computer, and finally the Nuc+. Same problem with no improvement. Next, I reloaded all the software on the Nuc+ again. Still no improvement. I rescanned all my folders again. No improvement.

NEW PROBLEM

This morning, I get a repeating “lost connection” message on my MacBook Pro when using Roon. It pops up and off and then on again about every five minutes. So the Nuc+ is having some sort of connectivity problem with the router. I just changed ethernet cable (Nuc+ to router), and that didn’t help, either.

Let me stress again that none of these problems existed when I used the MacBook Pro as the core! And that was using a WiFi connection of core to router rather than ethernet.

I want to be able to hear all of my music, not just 2/3s of it. What are your suggestions?

To add to this: could it be that I was sent a Nuc rather than a Nuc+, and therefore have run into a maximum file limit problem? I ask because:

(1) It came shipped in a box that said “Nucleus,” not “Nucleus+”;
(2) The physical computer does not have anything stamped on it to indicate one way or the other, it just says “Nucleus.”

However, there is a silver sticker on the bottom just added on that does say “Nucleus+ (Rev B).” The serial # on the sticker is: 54B2038D0D23.

Thanks, Norris. Any ideas on how to solve this or what is wrong with the Nuc+? It is faster than the Mac attached by WiFi, but the Nuc+ seems to do a heck of a lot less…

Hi @Geoffrey_Braswell,

I just checked your account and I am only seeing a Nucleus+ registered to it, so you indeed have a Nucleus+ in your possession.

What happens if you try to copy one of the directory giving you issues and put it on a USB drive and connect the drive to the Nucleus, are you then able to play it properly?

You should be aware that we have sometimes seen poor performance from ISP-provided networking gear such as your ATT router (as mentioned in our Networking Best Practices Guide). It is possible that a network is dropping out when trying to communicate with your NAS, and the USB test I mentioned above should help clarify.

Not familiar with what ATT is now using because I switched everyone away from them.
However when I was using them the first thing I did was put their router in bridge mode and then install my preferred router.

–MD

OK, some success. Here is what I did. I picked six albums from three folders/directories that were not playing properly. I copied them to a drive and connected it to the Nuc+ via the USB port. I disabled all the other directories and enabled the new one attached to the USB. So to be clear, the accessible library consisted only of six albums placed on an external drive connected to the Nuc+ via USB.

These all played, which really proved only that there is nothing wrong with the music files/folders. We knew that anyway because they play other ways. Still, this didn’t really determine if the problem is in the Nuc+ or with the router. But we know the router is fine because it works with a Mac core. Therefore, the problem must be either in the Nuc+ or in the ability to connect to the router.

But here is the amazing thing. I disconnected the USB drive. I turned on all my old directories on my NAS that were causing trouble. Now those six albums that I put on the drive are playing correctly, even though the drive was removed as a library directory and is no longer connected to the Nuc+.

Somehow by reading those albums once through a physical connection, the Nuc+ now has no trouble accessing the same files stored on the NAS. I do not really understand this at all.

Two of the six albums that I tested this way now appear with the “new” ribbon on the upper left of their icons. They both happen to be from the same small directory. The other four do not show up as “new.”

Albums that would not play before and were not included among the six still will not play.

I am an archaeologist. I literally am a specialist in stone-age technology. Got a question about ancient obsidian exchange and core-reduction strategies, and I am your man. Routers are not something I understand well at all, except that they are not plug & play and need to be configured.

If I replace the ATT router, what is a recommended brand and model that works well with Nuc+?
It will need to be configured to my network, and then I will have to do the same again for my QNAP NAS and my BlueSound Node 2, correct? I don’t know how to do any of this. Will Roon support walk me through it over the phone?

@MikeD - I am stuck with ATT, but I called and they are sending me a new router box. Still, using a 3rd party that is bridged is better? If so, does bridging require any sort of reconfiguration, or is it just a simple ethernet connection between the ATT router and the new one?
Any suggestions for a stable, fast router to bridge through the new ATT box?

@Geoffrey_Braswell - I would recommend you install the new ATT box for now. This way you are getting your internet and network up and running. ATT should assist you in getting back to where you are now.

This would still need to be done prior to bridging and yes it would require a configuration for your network.

–MD

Hi @Geoffrey_Braswell,

We suggest using non-ISP routers from a reputable brand - TP-Link/ASUS/Netgear/Eero/Orib all have some great options. There are also a few router suggestion threads on the forum. Having a non-ISP router can potentially save you some trouble down the road.

You can still use the ATT modem/router in what is called “Bridge Mode”, and have it just act as a modem (coax -> ethernet) and then have a better router handle the rest of the routing.

That is very strange indeed. If you notice another set of albums with the same behavior, can you please try to play them and let me know the exact local time + date + track you tried to play and had the failure? Afterwards I can enable diagnostics mode for your account and see if logs show any clues.