Playback Issues on Mac Mini with Channel D PAD and Schiit Yggdrasil

Upgraded to latest release. Now Roon WON’T play any more. It says “Transport: Device in use” when I hit PLAY.

Click on Roon in Application menu to run Roon.

Icon opens up on Menu bar at bottom of screen. Roon loads. As soon as main screen comes up, a SECOND Roon icon opens up in menu bar, bounces for about 20 seconds, then stays open alongside first Roon icon. Click on PLAY, and “Transport: Device in use” comes up, and NOTHING plays.

This SECOND icon has NEVER appeared before. It’s like the program is running twice. Clicking on either icon then on PLAY results in same Transport message. Click CLOSE on either icon, and they both close and Roon quits completely.

This used to work guys. You aren’t doing me any favors here!!! Pure Music has ALWAYS been stable, and I’ve had to fall back on it.

It’s this kind of crap happening which makes me NOT want to renew my subscription to Roon!!!

Mac Mini late 2012 2.6 GHz Intel core i7 16 GB 1600 DDR3 RAM. OS Mavericks. Schiit Audio Yggdrasil DAC running as a multi output device. NO problems running on Pure Music, so I know there is nothing wrong with the audio system.

Hi @DSNORD – sorry for the trouble here.

Audio playback has been rebuilt from the ground up in Roon 1.2, and while the upgrade has been pretty smooth for the vast majority of members, a few issues have cropped up. It’s not totally unexpected with changes this far-ranging, but I understand the frustration, and I’m sure we can get this working.

Does your setup only include Roon on the Mac Mini? Are there any other devices running Roon or any other Roon apps, like Roon Server or Roon Bridge?

Sorry to ask something so basic, but have you restarted the Mac Mini?

Can you post two screenshots like the ones at the end of this post, so we can see how your audio device(s) are configured?

Thanks for your patience here, @DSNORD!

Restarting Roon, resetting preferences on Mini, restarting Mini have no effect. Same “Transport: Device in use” error comes up. Still have 2 running Roon icons on desktop. No other devices running Roon, no other Roon apps except the main one are on the Mini. The Multi Output Device runs fine on Pure Music and used to run fine on the previous version of Roon. NO settings have changed. The new version of Roon is BROKEN!!!

Interesting. If I click on Multi Output Device icon on playback screen, this comes up:

The top Unnamed zone is the rogue one. Here’s what I get when I click on its play button:

It is playing, but nothing is being output. Here’s what I get when I click on the proper MOD zone’s play button:

So the rogue zone is taking things over.

Of the 2 Roon icons in the Task Bar, the left one is the main one and the right one is the rogue extra one. Right clicking on the rogue icon brings up a Force Quit option. Force quitting the rogue icon closes it, then brings up the following screen:

then 5 seconds later the rogue icon reloads, starts bouncing, and the very first screenshot above reappears:

Right clicking on the left main Roon icon in the Task Bar offers a Quit option which shuts Roon down completely. Doesn’t make any sense as to what the heck is going on!!!

Hello @DSNORD,

Thanks for info, it looks like Roon got into the corrupted state somehow. I’m sure we can solve this problem, but i need more info from you. Would you mind to do the following test and let us know the results:

  1. Launch Roon
  2. Wait while second Roon icon will appear in dock
  3. Open Terminal app
  4. Paste this command: ps aux | grep -v grep | grep oon
  5. Press Enter button
  6. Copy Terminal’s output and paste it here.

Few additional questions:
Did you install Roon into Application folder? If so, would you mind navigate to this folder and verify that only one Roon package is located there?

Thank you in advance.

I started shooting terminal queries from the moment the second icon appeared and started bouncing until it finally stopped. Only one copy of Roon on the Mini, and it’s in my Applications folder. I hope this helps.

More info:

Click on rogue unnamed Zone Info shows this to be Channel D’s Pure Music Zone:

Click on rogue Signal Path green light gives this:

Previously when things worked properly, I ALWAYS got the purple highest quality possible light instead.

Last ones I can think of that you might need:

If I disable the unnamed Channel D PAD Zone then restart Roon, I still get the second bouncing icon and the above mentioned “Transport: Device in use” problems still exist. This screen appears when I click on the MOD icon:

Hey @DSNORD@vova and I are going to do some more testing here to confirm there isn’t some weird interaction happening with Channel D PAD’s virtual sound card. I know we tested this a while back, but it’s possible there’s an issue with 1.2.

If so, we should be able to reproduce this in house and fix whatever’s gone wrong. In the meantime, you might try disabling the Channel D PAD and playing direct to the Schiit. It would be interesting to know if things are more stable without the virtual sound card, but like I said, we’re going to do some testing here and come back to you.

Sorry again for the trouble, and thanks for your patience!

Hey @DSNORD – we spent some time looking into this and I was hoping you could try disabling the multi-output device you have configured in OSX? More details are here.

Once you’ve disabled that (and Channel D Pad), I would be interested to know if things are more stable here, but let me know if not and we’ll take another look. Thanks!

Everything except Schiit Yggy disabled both in MIDI Audio Devices and Roon Settings panel. Roon restarted. Still having issue with second Roon icon appearing and bouncing. Roon DOES play to Yggy but only get GREEN quality indicator. ALWAYS got PURPLE highest quality previously, so this DOES NOT fix the problem. Reactivating MOD in MIDI panel while leaving Roon Settings unchanged makes NO difference.

Keep working on a fix ASAP- Roon is useless to my setup if I can’t continue using the MOD in MIDI as I have been able to in the past prior to the latest Roon build. I will continue to rely on my ROCK STABLE Pure Music for now. I can’t consider renewing my subscription if Roon is broken for me!!!

Some interesting new info:

MIDI output through MOD has been my standard setup. MOD comprises Schiit Yggy to my KEF LS50s as main desktop system with Audioquest Dragonfly to Bose as back up desktop system.

Everything is re-Enabled to baseline previous setup:

Here’s the Zones Menu:

2 different Roon icon appear on the task bar, and 3 different songs are playing!!!

-Clicking Play arrow button on MOD results in NO output to both Yggy/Dragonfly and “Transport: Device In Use” appears.
-Clicking Play arrow button on Schiit results in ONLY Yggy playing Schiit’s song
-Clicking Play arrow button on System Output results in Yggy and Dragonfly playing System Output’s song.
-BUT if while the above is playing, I then click the Play arrow on Schiit too, Yggy now plays BOTH Schiit’s AND System Output’s songs AT THE SAME TIME while Dragonfly plays only System Output’s song!!!
-Clicking Play arrow button on Unnamed results in NO output to both

Putting the checkmark in the different boxes makes NO difference.

I guess all I can say is WTF!!!

Hey @DSNORD – thanks for the screenshots. Roon is designed to playback to multiple outputs and rooms, and it is possible to configure things in ways that can cause conflicts. My sense is that this is what’s happening here, but let me clarify a few things and hopefully we can get this all working as expected.

This is probably because you’re not using Exclusive Mode. You can find information about setting the DAC up for bit-perfect playback here:

Let me know how that goes.

Moving on, I’d like to try simplifying the rest of your setup here, so we can address these issues one by one.

First, let’s disable the Multi Output Device in OSX – we can re-enable it later if you’d like, but it’s not something we test in house or recommend using with Roon, since Roon is able to play to multiple outputs by itself, and will be bit perfect too!

So, once you’ve disabled MOD in Audio Midi Setup, why don’t you go ahead and disable all the outputs in Roon as well. I’d really like to simplify things here, so bear with me.

Once that’s done, you should see Enable buttons next to every output in Settings.

Ok, now let’s focus on getting these working:[quote=“DSNORD, post:11, topic:10127”]
Schiit Yggy to my KEF LS50s as main desktop system with Audioquest Dragonfly to Bose as back up desktop system.

So, for both the Schitt and the Dragonfly, why don’t you follow the DAC setup instructions above – I would also recommend naming both outputs.

At this point you should be able to click the Zones menu and see something much closer to your actual setup – two outputs that you can use independently or grouped together, and which should both be bit-perfect.

Let me know if that eliminates the errors you’ve been seeing or if you’re still having some issues. Thanks @DSNORD!

Have taken your suggestions. Right now I have Yggy and Dragonfly both RESET to Exclusive Mode/Integer Mode and linked together. They both now play correctly like they did PRIOR to upgrading to the latest build when they WEREN’T linked. There was a glitch for awhile where the two zones were anywhere from 1/4 to 1/2 second out of sync- i.e., the output would not seamlessly overlap when I had them both playing resulting in a smearing echo effect. After enabling and disabling things followed by several restarts of the DACs and shutting down then restarting Roon, things eventually lined up correctly. The second Roon icon is still visible in the task bar, so I don’t know if that had anything to do with this glitch. This second icon was NEVER there in the previous build.

My MIDI MOD is active (I had turned it on/off to no avail trying to trouble shoot this delay) because Pure Music requires it. Fortunately it doesn’t seem to adversely affect things right now.

The screwy thing is that prior to the latest upgrade, I already HAD my Dragonfly, Yggy, and MOD set up as separate enabled zones each set to Exclusive/Integer modes. For some reason the upgrade turned these two modes OFF for both the Yggy and the Dragonfly but left them on for the MOD.

Why the unlinked MOD zone previously worked fine as my output to both music systems but now doesn’t remains a mystery- as long as things work okay, I guess it’s a moot point. I’ll post again if the delay glitch resurfaces.