Playback issues with DAC8PRO in Roon

We have now completed an active 3-way open baffle system. The filters are made in Audiolense, with convolver in Roon, after which I use an eight-channel DAC8PRO, for which I have updated the latest version USB Audio Driver DIYINHK V4.67. But I have the following problem, which bothers me a lot. All playlists are with songs from Tydal.
But when I play, this message appears on many songs and the song no longer plays:
*“Too many failures.Stopping playback”.
“Unexpected error communicating with Audio device.”
If I use a 2-channel stereo DAC, I don’t have this problem.
Can anyone help me with some advice on how to solve this problem?
Thanks a lot !

If you bothered to list the details requested when you opened a support request it might have helped me…but Im guessing your core’s CPU might be under powdered for the DSP needs you are placing on it.

In order for Roon’s support team and others to better assist you, please provide a brief description of your current setup using this link as a guide.

I apologize, this is my first post on this forum and I did not know all the necessary details.

Describe your configuration:
Windows 10
Motherboard MSI MSI Z170A GAMING M7, Z170, DualDDr4-2400, SATA3, HDMI, DP, USB 3.1, ATX - Z170A
Intel Core i7-6700K processor, Skylake Quad Core, 4.00GHz, 8MB, LGA1151, 14nm, 95W, VGA,
Video card MSI GeForce GTX 980 Ti Gaming, 6GB GDDR5, 384-bit - V323-001R
PSU EVGA SuperNova 850 G2, 850W, 80+ Gold, 140 mm fan, PFC Activ - 220-G2-0850-XR
Toshiba DT01ACA300 hard drive, 3 TB, SATA 3, 64MB, 7200rpm - DT01ACA300
SSD Crucial SSD MX200 1TB SATA3, 555 / 500MBs, IOPS 100 / 87K, 7mm
Memory Corsair Vengeance LPX, DDR4, 16GB, 3000 MHz, CL15,

Details about your remote controls: I don’t use them, everything is on the PC

Audio devices in use:
Audiolense crossover filters with an 8-channel DAC 8PRO
with DIYINHK V4.67 Driver
Library details:
I use a playlist created in ROON with songs from Tydal

Thank you.

when you play something what is the processing speed indicated (if nothing then its over 100X) ? can you show screen shots of the DSP settings in play too. Mine is only a DAC8 Stereo

Grab 2022-02-07 at  18.33.05

also maybe what your CPU is doing at the time

plus what bit rates are causing issues if any in particular

I use an Okto dac8pro with Audiolense XO correction filters which I run through Roon to HQPlayer to offload convolution to the GPU (in my case, an EVGA RTX 2080TI XC) because even with an i9-10900K processor in my Roon server, MCH with convolution was too much for Roon alone without stuttering and stopping playback. Your i7-6700 processor is probably underpowered for the task. Even with my big processor and GPU, I can run convolution at 384K and upscale 7 channel (5.2 for MCH) content using HQP running through Roon (but bypassing its convolution engine and using the HQP one) only to DSD64, rather than the Okto’s full DSD128 capabilities, without stuttering and stopping. Mind you, it still sounds terrific — the Okto is a great DAC. I can get to DSD128 for 2-channel content (2.2 for stereo) with my setup.

I agree with MrFixIt above that taking a look at your CPU loading whilst playing back — and the notation of CPU processing speed in Roon he notes above, will likely prove out the point here. JCR

Didn’t realize you posted elsewhere originally. My bad. Didn’t mean to sound that aggressive. After all you’re a fellow OKTO fan :blush:

Thank you so much for support :hugs:

But I don’t think I have a problem with the processor …
From the image you can see that during playback I have a load of 3…4%.
When the song jumps, the processor shows 10%
My problem is that when I click “Play” on the song, some sing to the end without any problem.
But some songs do not play when they click “Play”.
Simply skip over 3-4 songs and play another song again.

But when Roon plays the song, the sound is superb through my Open Baffle speakers with Audiolense filters :slightly_smiling_face:

I also have HQPlayer installed, but I couldn’t figure out how to make a convolver in it either :frowning:

1 Like

If you have both Audiolense XO and HQP, send me a PM and I will explain how you use Audiolense MCH filters in HQP’s pipeline matrix setup for playback using Roon control. JCR

It doesn’t look like CPU to me.

doesnt seem to be CPU to me either…strange I was putting money on that one.

I would try a few things first:

  • Maybe try dropping sampling rate and taps just as a trial. Does this change behaviour at all?
  • Do you have another software player you can use to implement the convolution filter and test? What is observed?
  • Do you need the DAC driver? I thought the OKTO worked driverless, and is class compliant? Or is the driver required for the Audiolense to Roon transfer function.
  • Have you tried other OS. Like Ubuntu 21.10? Does Audiolense work in Ubuntu/Linux?

I have run convolution on my Rock Nuc series4 i5, with 8 channels at 44.1 and decent taps 32/64k? (Can’t remember exactly) Without issues…… using Motu mk5 lite, connected to a RPI4 (usb) endpoint (Ubuntu server 21.10) and separate Roon core. No drivers. The Core and endpoint sit on separate mesh satellites to.

Do you have another software player that you can use to implement the convolution filter and test? What is observed?
I**'ll try JRiver and HQPlayer (Thanks a lot, Jeffrey!)**
Need a DAC driver? I thought OKTO worked without a driver and is compatible with the class? Or you need the driver for the Audiolense transfer function to Roon.
I use Windows10 and for that OKTO really needs a driver.
Have you tried another operating system? Like Ubuntu 21.10? Does Audiolense work in Ubuntu / Linux?
Unfortunately, I have never worked in Linux and I can’t tell you.
Did I run convolution on my Rock Nuc 4 i5 series, with 8 channels at 44.1 and decent 32 / 64k taps? (I don’t remember exactly) No problems …… using Motu mk5 lite, connected to an RPI4 (usb) endpoint (Ubuntu 21.10 server) and separate Roon kernel. No drivers. The core and endpoint are on separate satellites.
Maybe it’s the problem that everything (The core and endpoint) is on my PC?

It shouldn’t be, but I would personally test a few scenarios.
Maybe try a different core/PC, a capable endpoint like RPI4/PC.
I would also try different USB ports on the PC, to see if USB 2/3 options function any better.

I personally found that my Motu would not communicate correctly in multichannel mode using direct connection to my Nuc Rock. I believe this was due to an older Kernel used by Rock.

But since you are running Win10, that shouldn’t present an issue.

Thank you very much for all the suggestions and recommendations. I tried them all but without success, ROON didn’t want to play all the songs on the Playlist.
But last night I made some new ROON settings for DAC8PRO.
I can’t say how it was initially, but with these in the picture the problem is gone and now everything is OK, the music in Tydal plays without any problems.
Thank you again for your support!

Looks good! If you want, you can activate MQA core decoder so if you listen to Tidal MQA files, Roon will do the first unfold (ie, take a 44.1 track and decode to 192K). It’s not full MQA decoding because the Okto won’t do that, but you might try it out.

I still have an outstanding question over at the Audiolense forum on your setup and we will figure HQP setup on the back end of resolving that. But, great you got Roon sorted now. JCR

Thanks so much, Jeffrey, I’m not giving up on using HQPlayer, and I look forward to hearing from you!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.