Playback randomly stopping (pause actually)


(Kenneth Scissors) #1

I am playing Tidal using Roon (1.4) on iPad (12.1.1) to core Innuous Zenith SE (1.5) output to Aesthetix DAC. I’m wondering if this problem started since this last update recently, not sure, but it is a new problem within 1 month or so after over a year of this set-up. Playing 64/16. Approximately 2000 tracks total.

I mostly listen to playlists that were generated on Tidal. Anytime from 1minute to 60 or more the song simply stops and I find it in pause mode, tap the play arrow and it re-starts. There is no error message. We have cable internet and a Netgear 95 router both of which are working 100% for all other applications.

On rare occasions Roon and Zenith seem to lose connection and it resolves with turning Zenith off and back on. I don’t think this is related to the pause issue but I thought I’d mention it. Like I said, it is very rare whereas the pausing problem is constant, I haven’t been able to listen without it happening for the last month or so.

I saw other posts but got lost in the techno-talk of what sounded like more complicated set-ups than mine. I’m not super tech savvy, just like to listen to music :slight_smile:

Thanks
Ken


(Noris) #2

Hello @Kenneth_Scissors,

Thank you for providing that information. We have seen users have a better TIDAL experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS and you can use these instructions from Netgear to help you with this step.

Can you please give this a try and let me know if it helps? Also, what is the exact model of your Router? Does it by any chance fall under our Networking Best Practices List?

Thanks,
Noris


(Henry) #4

The description suggests an old version of Roon is being used. Can the version be checked and confirmed?


(Kenneth Scissors) #5

Thanks Henry. It looks like 1.5 with several updates has been out for a while, but I have 1.4 so maybe that’s it. I thought Roon automatically downloaded updates. I don’t know how to update otherwise. Suggestions?
Ken


(Kenneth Scissors) #6

I’d like to update from 1.4 to latest 1.5 before trying that, but don’t know how to do that. FAQ says Roon will download updates, but it doesn’t look like that’s been happening. Maybe I’m not understanding something here.
Thanks
Ken


(Noris) #7

Hello @Kenneth_Scissors,

To update Roon you would have to press the “About” button in settings and then use the prompts to update Roon. The about button is listed here:

Thanks,
Noris


(Kenneth Scissors) #8

I tried that before starting this session, I don’t see a prompt. Here’s what I do see: In “This Tablet” it says Roon Version 1.4 (298/64) and then there is a link to “Read Change Log”, but no update prompt.
Below that is “Core:zenith” with Roon Version 1.5 (363/64), and another link to “read change log”.
It looks like I have different versions in the tablet and zenith core, no prompt to update. Shouldn’t the versions match?
I am also having times when the Roon screen on the tablet completely freezes and I have to re-boot the tablet to bring it back.
What do you suggest if there is no prompt to update the tablet version? If there is no easy answer then I would appreciate a live session as I am unable to listen to music now for several days, maybe I’m just missing something that could easily be corrected.
Thanks


(Henry) #9

So you have 1,4 on your iPad and the correct version on the Zenith acting as your core. To update the iPad go to the App Store and search Roon. That should sort the issue out. Then test to see if the problem persists.


(Noris) #10

Hello @Kenneth_Scissors,

Having an outdated Roon Remote version could be the cause for some of these issues. If there is no update prompt in About, then you would need to update the iOS version on the iPad itself as the newer Roon Remote apps use a dependency in iOS 11+.

Thanks,
Noris


(Kenneth Scissors) #11

Thanks Noris and Henry. I updated the remote from iPad App store, simple. Playing music now. If pauses still occur I will change DNS on the Netgear 93 R7000 to Google as suggested and I’ll report back.
Ken


(Kenneth Scissors) #12

I have updated all Roon versions and that didn’t help, so I changed my Netgear DNS to Google. Unfortunately, playback is still pausing at random intervals. I want to emphasize that I have been using this system for over 1 year with no problem. Nothing else in my house that goes through the router is having any problems whatsoever. Logically, that points to the Roon app. Should I try deleting Roon and re-install on both the core and iPad? What else can we do to diagnose this?
Thanks
Ken


(Noris) #13

Hello @Kenneth_Scissors,

Ok, let’s try something else. Can you please let me know the exact local time in your country (ex. 10:33PM) that you notice the next pause? I can then enable diagnostics mode for your account and see if Roon is displaying an error message at that time. Please let me know that info when possible.

Thanks,
Noris


(Pierre Vandevenne) #15

Same here, everything was working fine until a couple of weeks ago.
Summary:

multiple CCAs: all affected when playing through roon, haven’t been able to play more than approximately seven minutes with roon. All CCAs are working fine with Tidal, for hours at a time.

Linn: no problem running from roon.

Wireless rock solid, three routers (one main, two APs), CCAs within 2-3 meters of the routers. Routers are fully managed, CCAs have static IPs. Tried the DNS “fix” even though I run a full dedicated DNS server myself, just in case roon is picky, absolutely no change. No other apps/kids game/affected even transiently.

I noticed, using the Windows player, that roon doesn’t simply pause play. If first thought it was what happened because I would just notice it when the music paused. But keeping an eye on the desktop player I can see that what happens is that periodically, just before going into pause, roon loses the CCAs. I am prompted for 1 or 2 seconds, to select an audio zone, some times twice, then connection resumes, paused.

Impression at this stage is that roon polls regularly to see which playing devices are available and sometimes (regularly) loses the CCAs.

I also disabled all firewalling to be complete, no change and unfirewalled phone clients are also affected anyway. And I also shut down all devices that I had used to play Tidal.

Last but not least, this also happens with tracks streamed from my NAS. The same track played from my NAS to CCA, Linn and another CCA through another application will stop on roon CCA, keep going on non-roon CCA and on roon Linn.

Next step will be to dump the trafic with wireshark, just to check if I can see anything special.

If the issue isn’t solved, I could also provide time stamps tomorrow if necessary.

Thanks
Pierre


(Kenneth Scissors) #16

Thanks Pierre. Sounds like you’re on the trail. Here is an update with more detail of where I’m at from Jan 10th:
Been listening for last hour or so with 2 pause events: 11:35AM and 12:38PM, Jan 10th. I’m in Colorado on Mountain Standard Time.

At 1:43 complete loss of music. I’m watching the display on the iPad-- Roon is skipping from song to song every 1 second or so trying to connect but never starting a song, it’s going right down the playlist. The pause button is showing, but pushing it has no effect. I can exit Roon but when I re-enter it is still cycling through. If I go to another playlist it keeps doing the same thing, there is no way I can get it to stop with the Roon app or controls. When it finishes the playlist or album the play button goes grey and if I hit it I get a message “Nothing Playing go find something to play”. I tried re-booting the iPad and then return to Roon, but it’s doing the same thing. I then re-booted the Innuous Zenith streamer and the connection is restored, playing normally for a while, then starts pausing, etc again. The Zenith is connected directly to the router by ethernet.

This is the typical pattern if I listen long enough. After several “pauses” it just loses connection altogether and only re-booting the Zenith restores connection. I hope this is helpful information.
Ken


(Pierre Vandevenne) #17

Got my disconnection dumped.

Will try to dig into the capture now.


(Noris) #18

Hello,

@Pierre_Vandevenne - Can you please let me know some timestamps of when the issue occurs? I’d like to take a look at diagnostics for your account.

@Kenneth_Scissors - I have enabled diagnostics mode for your account but our diagnostics servers have not received any reports. Would you mind manually sending them as per these instructions? If you don’t have dropbox or google drive just let me know and I can provide an alternate upload method.

@Kenneth_Scissors & @Pierre_Vandevenne - Can you please provide the model and manufacturer of all your networking gear? This includes any routers, access points, range extenders, powerline adapters, ect.

Thanks,
Noris


(Kenneth Scissors) #19

Thanks Noris. My router is Netgear93 R7000. My core server is in my Innuous Zenith SE streaming device (it is ethernet connected to the router). The Innuous is plugged into a Running Springs Audio Jaco power conditioner.
As to the manual sending of the diagnostics, I’m a bit overwhelmed with those instructions. I’ll see if a more tech savvy friend can help me with that.


(Noris) #20

Hello @Kenneth_Scissors,

I noticed that the Netgear R7000 is on our list of routers that need special settings applied. Can you please confirm that you have disabled the “Enable Smart Connect” setting on it? Also please do send us the logs when possible if the issue still exists afterwards.

Thanks,
Noris


(Kenneth Scissors) #21

Will do, thanks. I’ll let you know how it turns out.


(Kenneth Scissors) #22

We verified that Enable Smart Connect indeed is disabled. Regarding getting the logs to you from the Roon Core, it is an Innuous Zenith. Do you have information on how to access those?