Playback skips/too slow/too fast when changing bitrate

Not sure why this issue manifested itself recently, maybe to do with a fresh install of Windows; keen to get it fixed nonetheless!

When I select a track of a different bitrate in Roon (i.e. Roon has to tell the DAC to change bitrate), the DAC changes OK and playback starts, but it is either too fast or skips & is too slow. Funny thing is, if I pause Roon and wait about 5 seconds and then hit play again, playback resumes properly.

Latest version of Roon, Win 10, audio output is via firewire (Weiss Firewire IO Audio selected in Roon), DAC is Weiss DAC2 connected to audio PC with firewire cable.

Any ideas appreciated!

Edit: I see that others had previously complained about similar issues on another thread, though that thread has been closed.

Hi @extracampine ---- Thank you for the report and my apologies for the troubles here.

Can you confirm if you are to take the DAC out of the equation and play content directly of the internal speakers from the Windows machine if you are noticing the same playback issues?

Furthermore, can you also please provide screenshots of your audio settings.


Hi @Eric,

Thanks for your reply.

If I plug a speaker directly into the line out then there are no problems. Playback switching between bitrates is fine.

Screenshots of audio settings, as requested:

I’ve tried messing around with the settings - toggling exclusive mode & event driven mode, & work around drivers, with no difference. Tried changing the resync delay but same problem. I also tried the ASIO Weiss Firewire IO driver, which has a different problem - Roon would intermittently lose contact with the DAC, and also there were occasional static/interference type noises.

Many thanks.

Hi @extracampine ----- Thank you for the follow up and sharing the requested screenshots with me. Both are very appreciated :sunglasses:

Based on this observation we can see that Roon is able to playback content correctly from the internal sound card which would indicate that our communication with the DAC is where this issue is being encountered.

In your initial post you make mention that this problem seems to have appeared randomly and thus my assumption is that you have not always been in this state.

I understand that you have performed a Windows reinstall recently, can you verify if this action seems to have yielded this behavior and if not are there any other changes that you can think of that have been made to your setup?


Hi @Eric,

You are correct in your assumption that it was not always in this state. It used to work fine. That is, fine until I started having problems with Windows (I don’t think that was Roon related), and had to do a fresh install of Windows.

I don’t think the problem with Roon started right after the fresh install, though I can’t be 100% sure. I didn’t make any other particular changes apart from installing my DAC driver/app and installing Fidelizer.

So I don’t think that there is anything particularly unusual about my setup in that regard - but playback in Roon continues to stutter when there is a bitrate change.

Just to add - sometimes the playback stops and I get the error message “An audio file is loading slowly”, before playback moves on to the next track. This seems to happen sporadically but I wondered if it was another clue as to the problem.

Hi @extracampine ----- Thank you for the feedback :+1:

Can you confirm for me if there are any changes in behavior when you switch your “Buffer size” from 10ms to 100ms or if you use “Work around drivers…”


Hi Eric,

I tried both 10ms and 100ms buffer size, and same problem. I selected the work around drivers option, and the DAC cycled through the different sample rates. I then tried playing back some tracks of different bitrates and exactly the same problem.

For information, attached is a pic of the DAC settings:

I notice that there is a “buffer size” there too, with different values to Roon. I tried playing about with that too, but no difference to the problem. In the past when Roon was working, I didn’t really do anything with the DAC driver app. The “measured sampling rate” shown in the app is the same as that in Roon during playback, so the DAC seems to be getting the correct sample rate at least.

Hi @extracampine ----- Thank you for the screenshots and sharing the results of your testing with me.

Moving forward, before I grab some logs from you, I would like to ask you to please confirm the following for me:

  1. Have you tried testing with a SPDIF connection yet?

  2. If you let another device act as your Roon core (temporarily of course) do you notice this same behavior with the Weiss DAC2?


Hi Eric,

No I haven’t tried SPDIF - I hadn’t actually realised that both the DAC and PC have SPDIF connection. I will try and find a cable and give it a go.

Regarding the Roon core - can I install a second Roon core on another machine?

I just tried installing a different FireWire driver but it didn’t work in Roon. I installed the Weiss firewire driver again, and now the problem has changed - initially the bitrate of the DAC wouldn’t change - it just played all bitrates in Roon at the same bitrate. I then selected exclusive mode, and I get the error message “Transport: playback_error_endpoint_device_init_failed”.

Pulling my hair out!


HI @extracampine ---- The error message you are receiving means that we are struggling to communicate with the device :head_bandage:. I would like to propose the following, in order to try and save your hair :wink:

  1. Please if possible still conduct the test with the SPDIF connection and let me know the results of the experiment.

  2. If you let another device act as your Roon core (temporarily of course) do you notice this same behavior with the Weiss DAC2?

  • Let me clarify this a bit, my apologies for any confusion. The thought here is to have another device ACT as the core temporarily, not having TWO CORES running at the same time (that would be bad). As an example, at home my Roon core runs on a MBP which I control from from a few different devices, one of which is a Window laptop. Now, if I disconnect the core on my MBP my Windows computer will obviously lose connection but will ask me if I’d like to use that device as my core and if I select yes, now it is acting as such. I am aware that you have had some issues with your Windows computer and would like to try to isolate this variable by working on a different computer that hasn’t been experiencing the same OS level problems. If using a different computer with your DAC yields a different result then we know where the problem is and if the same observations are made we can determine that there is a broader issue happening here.

Moving forward…
Please let me know the results of these tests and once I have your feedback I would like to look into gather some logs.


Hi Eric,

Sorry for my delay in getting back to you!

I tried with an SP/DIF connection. I selected SP/DIF as the default sound output in Windows. In Roon audio settings there is an entry “High Definition Audio Device - WASAPI” listed - I tried that and it seemed to work. In terms of playback, going up in bitrate seemed to be fine. When going down in bitrate, there was a delay of a few seconds before playback would start (I had to stop the track and start it again). But at least the bitrate was changing.

The other thing about using SP/DIF is that the Dac driver app (Weiss Firewire IO) doesn’t see the DAC - probably because it’s a firewire thing.

Still want me to try a different Roon core? The only other computer I have in the house is USB-C only, so I would have to buy a USB-C to firewire cable or converter.

Hi @extracampine ---- Thank you for the follow up and sharing your observations with me. Both are appreciated!

Based on the test results with the SP/DIF connection I am now wondering if perhaps something went awry with a driver when the OS was reinstalled and that is what could be causing issues with using a firewire to connect to the DAC.

Moving forward, I am going to be contacting you via PM with instructions on how to grab some logs and send them over to us so our developers can have a closer look at what may be causing this behavior to occur.


Many thanks Eric. PM received and I will follow your instructions. I too suspect that it is something to do with a driver; I wondered if it was to do with a firewire driver; but it had worked fine initially following the fresh Windows 10 install. I’ll follow this up over PM.

Eric has very kindly been following this up via PM, though as we seem to be struggling to find a resolution to this problem I thought that I would ask again here to see if the user base has any suggestions for me.

The funny thing is that everything was working fine a number of weeks ago, though currently I am still experiencing the problem as described at the top of this thread. I again tried a fresh install (of Windows and Roon) but the same problem persists. I have tried changing the resync delay settings but again that makes no difference.

I’m all ears for any ideas!

Edit: Just to confirm that this problem occurs using other playback software also - I tried HQplayer and same problem.

Different FireWire cable?

Seems like if it’s Roon and HQPlayer, then it’s system (already under investigation) or possibly something as simple as a physical connection problem. In the past I’ve been known to spend days/weeks chasing down a system issue because it happened to occur at the same time I did something to the OS (so I was sure that was the cause) whereas actually a cable was loose and I wasted a lot of time, so still always best to check all the basics…