Playback stops abruptly, can’t be resumed for up to a minute

Roon Core Machine

Core: Intel NUC8i3BEH on Ubuntu 22.04 LTS w/ Roon 1272
CPU: Intel Core i3-8109U (4×3 GHz)
Storage: OS and apps on a M.2 SSD, files on an internal 2,5" SSD

Networking Gear & Setup Details

All devices are hardwired w/ cat. 6 Ethernet cables to my office network through Netgear and HPE switches. Wi-Fi is disabled on the core and my main client. UPnP and port forwarding is up and running. Our web provider offers IPv6 support, which I don’t want to disable for obvious reasons.

Connected Audio Devices

Main client: Mac mini M1 on macOS Ventura 13.4 w/ Roon 1272 feeding an external DAC.

Number of Tracks in Library

A little over 6 000, split 50/50 between 16/44 ALAC files and Qobuz favorites.

Description of Issue

Music playback stops abruptly from time to time with the “Nothing playing” message. I tried simplifying my setup to the bare minimum, cleaning the library, deactivating DSP, checking common recommandations, nothing works. It just keeps happening, sometimes once a day, sometimes twice in the same track (local file or streaming all the same).

It seems that Roon Server periodically looses its cool and chews up resources. As long as the CPU is maxed out at 300 to 400 %, the playback can’t be resumed on the clients end (no zone is available and the current track is “forgotten”). As soon as the server reverts back to a more sane state, playback can be resumed, but sometimes, all it takes is restarting Roon on the client side.

@support any idea? BTW, this problem also seems to explain why I was losing Arc access over the weekend. This weekend for exemple, Roon Server locked up at 2AM, and ended up crashing… Yay.

Throttling audio analysis seems to prevent Roon Server chewing up resources until it crashes — could a memory leak be lurking somewhere? I also disabled IPv6 on the core side and so far, I’ve not experienced interruptions. I’ll report back after trying to use Arc.

Try turning Audio Analysis completely off and see if the issue stops.

Personally, I always suggest leaving it off and turning on-demand Audio Analysis ON.

Or, another option is turning Analysis OFF completely during the day, and then turning it on at night while you are sleeping. Will take longer, but, will relieve any processing pressure while trying to use the system.

**As a side note, your signal path shows you using the OS Mixer. You might get better quality playback results using Core Audio.

Since I’ve throttled audio analysis, I’ve had 24 hours of continuous playback for the first time in weeks. Looks like something isn’t quite right on that front.

That’s the next thing I’ll try, thanks for the suggestion.

Good idea! I’ll give it a shot, thanks!

The background audio analysis engine seems to be the culprit. I reenabled it yesterday on one CPU core, rebooted the core… and Roon Server locked up twice in less than an hour. It managed to eat three to four CPU cores and more that 24 gigs of RAM! I then configured it just like @Rugby, rebooted the core… and everything has been working perfectly since. Case solved on my end, but I’m available if someone from Roon’s team want some logs.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.